libnotify1 missing from oneiric

Bug #859223 reported by Todd Vierling
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
libnotify (Ubuntu)
Undecided
Unassigned

Bug Description

The current version of libnotify in oneiric is libnotify4, and libnotify1 was removed in early September. However, there are third party binary packages using libnotify.so.1 (in my case, it's Jungle Disk, that I've found so far). It would be nice to have this available in oldlibs.

For now for my purposes, I've added it to ppa:duh/duh (the whole libnotify package, which of course is older than bundled libnotify except for the library). All I changed was to move libnotify1 itself to oldlibs in debian/control. I'm not sure what else is necessary to make it work in parallel with the newer libnotify for official inclusion.

Revision history for this message
Thomas Astleitner (danube) wrote :

I can reproduce this issue by installing handbrake-gtk from launchpad, which depends on libnotify1.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libnotify (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthew Tucker-Simmons (tucker-simmons) wrote :

I'm having the same issue with Jungle Disk not working. I added the ppa mentioned in the bug description, but I wasn't sure exactly what to do after that. Should I just install the package libnotify1, or will that conflict with the new version in Oneiric?

Sorry if this isn't the correct forum for this type of question, I'm new at this. Any help, suggestions, or advice much appreciated.

Revision history for this message
Todd Vierling (duh) wrote :

tucker-simmons: Simply install libnotify1. It provides the missing library, libnotify.so.1. I've already put in a ticket with the Jungle Disk maintainers to make the next versionof their .deb explicitly depend on the libnotify1 package.

(The libnotify4 package that is part of Oneiric has a different shared library filename, libnotify.so.4, which is non-conflicting.)

Revision history for this message
Matthew Tucker-Simmons (tucker-simmons) wrote :

Thanks for your near-instantaneous reply!

Revision history for this message
Oleg (olezhek) wrote :

I have the same as Thomas Astleitner has. Todd Vierling, thank you for adding libnotify to your PPA!

Revision history for this message
wlsuzuki (wlsuzuki) wrote :

IBM's Lotus Symponhy 3 also depends on libnotify1...

Revision history for this message
Jeffrey Shaffner (webslave) wrote :

I also use ZumoDrive which depends on libnotify1

Revision history for this message
Todd Vierling (duh) wrote :

Note, I've forward-copied libnotify1 from my PPA all the way through Saucy as of this writing.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Ubuntu 10.10 reached End of Life in April 2012. Please upgrade to a supported release:

https://wiki.ubuntu.com/Releases

The third-party apps need to be rebuild against libnotify. This isn't something that Ubuntu developers can fix.

Changed in libnotify (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Todd Vierling (duh) wrote :

10.10 (which introduced libnotify4) is EOL, but 10.04 (which contains libnotify1) is not. The problem _appeared_ in 10.10, but is still around today in 12.04, 12.10, 13.04. The older library is part of *10.04 LTS* (...why do you think this was reported in 2011?)

oldlibs packages are shipped for various other, quite common, libraries -- what's the issue for doing the same for libnotify1?

Changed in libnotify (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers