Ubuntu

libnfnetlink needs autoconf update for arm64 building

Reported by Wookey on 2012-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libnfnetlink (Debian)
Fix Released
Unknown
libnfnetlink (Ubuntu)
Undecided
Unassigned

Bug Description

This package needs autoconf updates (to config.guess and config.sub)
to build for 64-bit arm. The arm64 port is stalled until this package
is updated.

Support for aarch64 has been added to autotools config.guess and
config.sub in autotools 20120210.1

For upstream running autoreconf against autotools-dev 20120210.1 or
later will fix the autoconf part.

For the Debian package, if you wanted to keep this up to date
automatically in the future (generally a good idea to forestall bugs
like this every time a new architecture is added) then adding
something like this to your distclean target would be effective: -test
-r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub
config.sub -test -r /usr/share/misc/config.guess && cp -f
/usr/share/misc/config.guess config.guess (You could instead just make
those files links.) along with a build-dependency on autotools-dev

Please pass this bug report to upstream

Wookey (wookey) wrote :
affects: ubuntu → libnfnetlink (Ubuntu)
affects: debian → libnfnetlink (Debian)
Changed in libnfnetlink (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libnfnetlink - 1.0.0-1ubuntu1

---------------
libnfnetlink (1.0.0-1ubuntu1) raring; urgency=low

  * Update config.{guess,sub} for arm64 (LP: #1081600).
 -- Wookey <email address hidden> Tue, 20 Nov 2012 04:42:13 +0000

Changed in libnfnetlink (Ubuntu):
status: New → Fix Released
Changed in libnfnetlink (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.