New version of libnb-javaparser-java breaks netbeans

Bug #1274469 reported by Sergey Basalaev on 2014-01-30
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
libnb-javaparser-java (Ubuntu)
High
Unassigned
netbeans (Ubuntu)
High
Unassigned

Bug Description

In trusty package 'libnb-javaparser-java' is upgraded to version 7.4-1, but 'netbeans' is still version 7.0.1-1. Since API of the library changes, NetBeans fails to work properly with Java projects (among broken things are code highlighting and autocompletion), and reports the following error

java.lang.ClassNotFoundException: com.sun.tools.javac.util.CancelAbort

(stacktrace is in attachment)

Downgrading to libnb-javaparser-java 7.0.1-1 solves the problem.

If packaging new version of netbeans causes much trouble, please, either downgrade libnb-javaparser-java, or create separate package with older version of javaparser which netbeans can depend on.

Sergey Basalaev (sbasalaev) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libnb-javaparser-java (Ubuntu):
status: New → Confirmed
Changed in netbeans (Ubuntu):
status: New → Confirmed

It renders essential functionality of the package (or a dependent one) broken.

Changed in libnb-javaparser-java (Ubuntu):
importance: Undecided → High
Changed in netbeans (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Triaged
Changed in libnb-javaparser-java (Ubuntu):
status: Confirmed → Triaged
Changed in netbeans (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers