Spyder color 3 not being connected (USB)

Bug #874293 reported by MeneM on 2011-10-14
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
libmtp (Ubuntu)
Undecided
Unassigned

Bug Description

Since Oneiric now has the "color profile" thing prominently displayed as a feature, it's bad to see that a ColorSpyder 3 is not being "connected".

This is what dmesg gives me:
[ 40.901432] usb 2-1.3: USB disconnect, device number 59
[ 41.098439] usb 2-1.3: new full speed USB device number 60 using ehci_hcd
[ 41.412572] usb 2-1.3: USB disconnect, device number 60
[ 41.614162] usb 2-1.3: new full speed USB device number 61 using ehci_hcd
[ 41.924151] usb 2-1.3: USB disconnect, device number 61
[ 42.122027] usb 2-1.3: new full speed USB device number 62 using ehci_hcd
[ 42.435650] usb 2-1.3: USB disconnect, device number 62
[ 42.633680] usb 2-1.3: new full speed USB device number 63 using ehci_hcd
[ 42.947175] usb 2-1.3: USB disconnect, device number 63
[ 43.145420] usb 2-1.3: new full speed USB device number 64 using ehci_hcd
[ 43.458660] usb 2-1.3: USB disconnect, device number 64
[ 43.656995] usb 2-1.3: new full speed USB device number 65 using ehci_hcd
[ 43.970093] usb 2-1.3: USB disconnect, device number 65
[ 44.168804] usb 2-1.3: new full speed USB device number 66 using ehci_hcd

And it just goed on and on as long as the Spyder is connected.

It runs fine under Windows also using argyll and dispalgui, and it also runs fine using the 11.04 live cd environment (On the same machine). So that kinda rules out the spyder or the machine.

If more is needed, let me know.

This is a syslog excerpt:
Oct 14 16:40:46 tribble mtp-probe: checking bus 2, device 32: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:46 tribble mtp-probe: bus: 2, device: 32 was not an MTP device
Oct 14 16:40:46 tribble kernel: [ 410.420747] usb 2-1.3: USB disconnect, device number 32
Oct 14 16:40:47 tribble kernel: [ 410.620346] usb 2-1.3: new full speed USB device number 33 using ehci_hcd
Oct 14 16:40:47 tribble mtp-probe: checking bus 2, device 33: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:47 tribble mtp-probe: bus: 2, device: 33 was not an MTP device
Oct 14 16:40:47 tribble kernel: [ 410.931740] usb 2-1.3: USB disconnect, device number 33
Oct 14 16:40:47 tribble kernel: [ 411.131809] usb 2-1.3: new full speed USB device number 34 using ehci_hcd
Oct 14 16:40:47 tribble mtp-probe: checking bus 2, device 34: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:47 tribble mtp-probe: bus: 2, device: 34 was not an MTP device
Oct 14 16:40:47 tribble kernel: [ 411.443454] usb 2-1.3: USB disconnect, device number 34
Oct 14 16:40:48 tribble kernel: [ 411.643659] usb 2-1.3: new full speed USB device number 35 using ehci_hcd
Oct 14 16:40:48 tribble mtp-probe: checking bus 2, device 35: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:48 tribble mtp-probe: bus: 2, device: 35 was not an MTP device
Oct 14 16:40:48 tribble kernel: [ 411.954806] usb 2-1.3: USB disconnect, device number 35
Oct 14 16:40:48 tribble kernel: [ 412.155400] usb 2-1.3: new full speed USB device number 36 using ehci_hcd
Oct 14 16:40:48 tribble mtp-probe: checking bus 2, device 36: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:48 tribble mtp-probe: bus: 2, device: 36 was not an MTP device
Oct 14 16:40:48 tribble kernel: [ 412.466318] usb 2-1.3: USB disconnect, device number 36
Oct 14 16:40:49 tribble kernel: [ 412.663100] usb 2-1.3: new full speed USB device number 37 using ehci_hcd
Oct 14 16:40:49 tribble mtp-probe: checking bus 2, device 37: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Oct 14 16:40:49 tribble mtp-probe: bus: 2, device: 37 was not an MTP device

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: argyll 1.3.3-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 16:36:49 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: argyll
UpgradeStatus: No upgrade log present (probably fresh install)

MeneM (mark-maas-martin) wrote :
MeneM (mark-maas-martin) wrote :

Not really argyll I guess, but the "ubuntu-bug" program want's me to point to a package. And Argyll comes closest I guess.

MeneM (mark-maas-martin) on 2011-10-22
affects: argyll (Ubuntu) → colord (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in colord (Ubuntu):
status: New → Confirmed
Xoby (xoby) wrote :

I am also affected by this bug and available to do some tests.

I think it is more likely a kernel or udev-level bug as the device keeps being connected then disconnected then reconnected again and again ... with this message :
[ 4050.892294] usb 3-1: USB disconnect, device number 7
[ 4051.132207] usb 3-1: new full speed USB device number 8 using uhci_hcd
[ 4051.317266] usb 3-1: usbfs: USBDEVFS_CONTROL failed cmd mtp-probe rqt 128 rq 6 len 1024 ret -84
(the only difference being the device number which increases at each step)

Maybe we should try another distribution livecd to see whether this behavior comes from the kernel or the distribution ...

MeneM (mark-maas-martin) wrote :

I'm guessing it's the kernel. The live cd of Ubuntu 11.04 is fine, and I'm using that (On a USB drive) to do my calibrations for now.

Must be something with the new 3.0 kernel.

Lisje (kleinewereld) wrote :

it appears to be a bug relate to libmtp9 (see http://www.debian-fr.org/absence-de-reconnaissance-sonde-spyder3-lsusb-t35369.html)

someone succeeded at making his Spider3 work by downgrading to libmtp8 (at the cost of having to uninstall amarok & vlc)
I'll let you know if that works for me as well.

Lisje (kleinewereld) wrote :

I didn't get around to uninstalling libmtp9 yet, but it seems there's a fix upstream: http://sourceforge.net/tracker/?func=detail&aid=3303517&group_id=158745&atid=809061

affects: colord (Ubuntu) → libmtp (Ubuntu)
Download full text (3.5 KiB)

I used Spyder3 successfully in Ubuntu 11.04, buit it indeed isn working anymore in 11.10. I use the fine ArgyllCMS software. I both tried version 1.3.3 and 1.3.5 (64 bits and 32 bits on two different computers with 11.10).

Just for the record my experience. I issue the command
$dispcal -yl -r -D5

And the output is as follows (i deleted duplicate lines and replaced them with "(...)"):
$./dispcal -yl -r -D5
Checking XRandR 1.2 VideoLUT access
XRandR 1.2 is faulty - falling back to older extensions
get_displays checking for Xinerama
Display 0 name = ':0.0'
usb_get_paths about to look through devices:
usb_check_and_add() called with VID 0x1d6b, PID 0x2
usb_check_and_add() called with VID 0x1d6b, PID 0x2
usb_check_and_add() called with VID 0x1d6b, PID 0x2
usb_check_and_add() called with VID 0x1d6b, PID 0x1
usb_check_and_add() called with VID 0x1d6b, PID 0x1
usb_check_and_add() called with VID 0x1d6b, PID 0x1
usb_check_and_add() called with VID 0x1d6b, PID 0x1
usb_check_and_add() called with VID 0x1d6b, PID 0x2
usb_check_and_add() called with VID 0x1d6b, PID 0x3
usb_check_and_add() called with VID 0x1058, PID 0x1003
usb_check_and_add() called with VID 0x424, PID 0x2504
usb_check_and_add() called with VID 0x4fc, PID 0x5d8
usb_check_and_add() called with VID 0x85c, PID 0x300
usb_check_and_add() found known instrument
managed to open serial "/dev/ttyS0"
managed to open serial "/dev/ttyS31"
managed to open serial "/dev/ttyS30"
managed to open serial "/dev/ttyS29"
managed to open serial "/dev/ttyS28"
managed to open serial "/dev/ttyS27"
managed to open serial "/dev/ttyS26"
managed to open serial "/dev/ttyS25"
managed to open serial "/dev/ttyS24"
managed to open serial "/dev/ttyS23"
managed to open serial "/dev/ttyS22"
managed to open serial "/dev/ttyS21"
managed to open serial "/dev/ttyS20"
managed to open serial "/dev/ttyS19"
managed to open serial "/dev/ttyS18"
managed to open serial "/dev/ttyS17"
managed to open serial "/dev/ttyS16"
managed to open serial "/dev/ttyS15"
managed to open serial "/dev/ttyS14"
managed to open serial "/dev/ttyS13"
managed to open serial "/dev/ttyS12"
managed to open serial "/dev/ttyS11"
managed to open serial "/dev/ttyS10"
managed to open serial "/dev/ttyS9"
managed to open serial "/dev/ttyS8"
managed to open serial "/dev/ttyS7"
managed to open serial "/dev/ttyS6"
managed to open serial "/dev/ttyS5"
managed to open serial "/dev/ttyS4"
managed to open serial "/dev/ttyS3"
managed to open serial "/dev/ttyS2"
managed to open serial "/dev/ttyS1"
spyd2: About to init coms
spyd2: About to init USB
icoms: About to set usb port characteristics
icoms: About to open the USB port, tries 0
icoms: USB port needs opening
icoms: About to open USB port 'usb:/bus1/dev44/ (Datacolor Spyder3)'
open() of USB port 'usb:/bus1/dev44/ (Datacolor Spyder3)' suceeded
Number of configurations = 1
icoms: USB port is now open
icoms: Clearing any USB errors
icoms: usb port characteristics set ok
spyd2: init coms has suceeded
spyd2: About to init instrument
icoms: About to return usb read 0 bytes, ICOM err 0x100
(...)
icoms: About to return usb read 0 bytes, ICOM err 0x100
spyd2: about to read all the EEProm values

spyd2: Read EEProm addr 5, bytes 2

...

Read more...

I can confirm it's a problem with libmtp. From the argyll devloper: "This libmtp opens every USB device to see if it is a "media" device. This upsets the Spyder3."

The workaround is therefore simple: I removed libmtp from my system with synaptic (as a result I lost banshee too), and since then Spyder3 is working like before with ArgyllCMS on Ubuntu 11.10 (both 64/32 bits).

Of course libmtp should behave differently for a structural solution.

MeneM (mark-maas-martin) wrote :

Not only banshee but also VLC media player, so this is not a good deal (In my case anyway ;-)

But it's good to know where the problem originates. Should I move this but to that Package then?

MeneM (mark-maas-martin) wrote :

Oh, It's already moved... Thanks!

MeneM (mark-maas-martin) wrote :
Niku Toivola (niku-toivola) wrote :

I can confirm that the workaround of uninstalling libmtp-runtime solved the Spyder3 issue. No dependency problems here on Kubuntu 11.10.

However this means that Amarok no longer uses MTP to talk to my Sony mp3 player which makes it impossible to transfer album art...

Niku Toivola (niku-toivola) wrote :

Ah. From dispcalGUI documentation:

"Linux: Instrument not working correctly/constantly disconnecting (conflict with libmtp)

Solution: There is a bug on some systems with libmtp that causes instruments to continuously switch between connected and disconnected state. This seems to be a bug in libmtp-runtime. You can work around it by renaming /lib/udev/mtp-probe or updating to libmtp 1.0.6 where the issue should be fixed."

Adam Niedling (krychek) wrote :

I'm not sure if I have the same bug or not, but Oneiric does not recognize my Sony Memory Stick PRO Duo memory card:

dmesg:
[ 1774.871158] usb 3-2: new high speed USB device number 2 using xhci_hcd
[ 1776.030081] usb 3-2: usbfs: USBDEVFS_CONTROL failed cmd mtp-probe rqt 128 rq 6 len 1024 ret -110

Dylan Aïssi (daissi) wrote :

ColorSpyder devices are blacklisted from mtp-probe since a long time. This issue should not appear anymore. Please reopen otherwise.

Changed in libmtp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.