Samsung Galaxy SII not detected

Bug #815055 reported by gamx on 2011-07-23
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libmtp
Unknown
Unknown
libmtp (Ubuntu)
Undecided
Unassigned

Bug Description

I use Natty 64 bit. When I connect a Samsung Galaxy SII phone (using the mtp mode, the only one available as far as I know), lsusb detects it:

Bus 002 Device 004: ID 2001:f111 D-Link Corp. DBT-122 Bluetooth adapter
Bus 002 Device 003: ID 046e:5522 Behavior Tech. Computer Corp.
Bus 002 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 007: ID 04e8:6860 Samsung Electronics Co., Ltd
Bus 001 Device 005: ID 0bda:0111 Realtek Semiconductor Corp. Card Reader
Bus 001 Device 003: ID 0bda:2831 Realtek Semiconductor Corp. RTL2831U DVB-T
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

but according to mtp-detect it is not there:
libmtp version: 1.0.6

Listing raw device(s)
   No raw devices found.

Nautilus, however detects it as a camera (standard mtp behavior I guess) but it simply shows folders that are empty...
I guess this is the reason why I cannot sync music with Banshee, etc...

Changed in libmtp (Ubuntu):
status: New → Confirmed
Alessandro (pinguinofurioso) wrote :

any news?

Alexander Usyskin (sanniu) wrote :

With 1.1.0 from Oneric mtp-detect recognized device as Galaxy Tab, but failed to scan it.

zee (zeefreak) wrote :

i've got this same problem. i put a post about it on ubuntuforums but it's got at lot of views and 0 replies:

<begin ubuntu forum post>
mounting android - unable to see deeper than one level.
having a somewhat bizarre problem that i hope the knowledgeable folks here might be able to help with.

i tried to load some new music on my phone this morning, but i'm unable to see anything under the top level of the phone. e.g. i have all the directories under my phone, but all of them are reporting as empty through ubuntu. checking the filesystem on the phone, i see the content i expect.

on phone i have:
/sdcard/media/ringtones
/sdcard/media/music
/sdcard/media/alarms

on ubuntu i have:
SAMSUNG_Android/media/<empty directory>

i can create a new directory under media, say 'temp' and i see it on my phone. unmount, remount, temp is invisible to ubuntu.

checking dmesg i am seeing the following error:

[ 313.767405] usb 2-1.3: new high speed USB device number 7 using ehci_hcd
[ 314.099858] iwlagn 0000:02:00.0: Aggregation not enabled for tid 6 because load = 6
[ 315.324946] usb 2-1.3: usbfs: USBDEVFS_CONTROL failed cmd gvfs-gphoto2-vo rqt 33 rq 102 len 0 ret -71

i'm not sure if it shoudl be mounted as a gphoto2 fs or not. it used to work, and when it did i wasn't paying attention to how it was mounted.

i think, but i'm not certain that this problem has arisen as of the latest kernel update 3.0.0-12. i'm running ubuntu 11.10. the problem is consistent across both 64bit and 32bit. i am sad to say that mounting on a windows box i'm able to see all the directories as that seems to put the problem firmly with ubuntu.
<end ubuntu forum post>

as of a kernel update i did last night, which oddly hasn't updated the kernel number in uname, the error is gone, but the behavior is still the same:

ubuntu 11.10 64bit on a dell latitude e6410.

$ uname -a
Linux chen 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

dmesg:
[10732.785245] usb 2-1.3: new high speed USB device number 5 using ehci_hcd
[10732.877424] usb 2-1.3: config 1 has no interfaces?
[10733.034696] cdc_acm 2-1.3:2.0: This device cannot do calls on its own. It is not a modem.
[10733.034793] cdc_acm 2-1.3:2.0: ttyACM0: USB ACM device
[10733.035180] usbcore: registered new interface driver cdc_acm
[10733.035182] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[10735.142137] usb 2-1.3: USB disconnect, device number 5
[10735.344821] usb 2-1.3: new high speed USB device number 6 using ehci_hcd

let me know what other information you need to help resolve this issue, and i'll get it for you.

zee (zeefreak) wrote :

also, this used to work on 11.10. i loaded a bunch of music on my phone, as well as ringtones and whatnot just a few weeks ago.

zee (zeefreak) wrote :

a bit more tinkering and i've managed to get it to work, but you have to put the phone into usb debug mode.

on the phone, go to settings | applications | development. check 'usb debugging'. go back to your home screen. connect the phone to the computer. swipe down to open the notifications panel. press 'usb connected'. you should see a screen with a green android. press the 'connect usb storage' button. the android should turn orange.

when i use this method dmesg has the following:

[19402.127887] usb 2-1.3: new high speed USB device number 8 using ehci_hcd
[19402.222023] scsi8 : usb-storage 2-1.3:1.0
[19402.222644] cdc_acm 2-1.3:1.1: This device cannot do calls on its own. It is not a modem.
[19402.222745] cdc_acm 2-1.3:1.1: ttyACM0: USB ACM device
[19403.218746] scsi 8:0:0:0: Direct-Access Android UMS Composite 00 PQ: 0 ANSI: 2
[19403.219122] scsi 8:0:0:1: Direct-Access Android UMS Composite 00 PQ: 0 ANSI: 2
[19403.372025] sd 8:0:0:0: Attached scsi generic sg5 type 0
[19403.372400] sd 8:0:0:1: Attached scsi generic sg6 type 0
[19403.388841] sd 8:0:0:0: [sde] Attached SCSI removable disk
[19403.389744] sd 8:0:0:1: [sdf] Attached SCSI removable disk

tags: added: precise
fmo (fmo) wrote :

This bug seems to have been fixed on the newly released libmtp 1.1.3 see here http://sourceforge.net/projects/libmtp/files/libmtp/1.1.3/

I think it would probably also be a good idea to upgrade mtpfs to 1.1 http://www.adebenham.com/mtpfs/ (current version is 0.9-3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.