rhythmbox crashed while removing file from MTP device

Bug #144994 reported by Augusto on 2007-09-25
8
Affects Status Importance Assigned to Milestone
Rhythmbox
Unknown
Critical
libmtp (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: rhythmbox

I had my mp3 player set to MTP transfer. Rhythmbox detected it fine. Tried to remove a file from the device by right click remove and puff, rhythmbox crashed.

Version: 0.11.2

I cannot reproduce it with the above procedure though.

ProblemType: Crash
Architecture: i386
Date: Tue Sep 25 18:36:10 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: cdrom
Package: rhythmbox 0.11.2-0ubuntu3
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/ar
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 LIBMTP_Delete_Object () from /usr/lib/libmtp.so.6
 ?? ()
 ?? ()
 ?? ()
 ?? () from /lib/ld-linux.so.2
Title: rhythmbox crashed with SIGSEGV in LIBMTP_Delete_Object()
Uname: Linux arnb 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev powerdev scanner video

Augusto (augusto.rendon) wrote :

StacktraceTop:impl_delete (source=0x8a11800) at rb-mtp-source.c:467
rb_source_delete (source=0x8a11800) at rb-source.c:863
rb_shell_clipboard_cmd_delete (action=0x8286b40, clipboard=0x82aa0d8) at rb-shell-clipboard.c:687
IA__g_cclosure_marshal_VOID__VOID (closure=0x83a5120, return_value=0x0, n_param_values=1,
IA__g_closure_invoke (closure=0x83a5120, return_value=0x0, n_param_values=1, param_values=0xbfe099bc,

Changed in rhythmbox:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

The crash happens to libmtp6, reassigning

Sebastien Bacher (seb128) wrote :

Could also be due to rhythmbox, reassigning in case upstream has idea on the bug

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=480974

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

the crash is a libmtp one

Changed in rhythmbox:
assignee: desktop-bugs → nobody
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in hardy or intrepid?

Sense Egbert Hofstede (sense) wrote :

Unfortunately this bug didn't receive any responses for almost a year. Therefore I'm closing it. However, if you can still reproduce the bug, please reopen the report.

Changed in libmtp (Ubuntu):
status: Triaged → Invalid
Changed in rhythmbox:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.