New USB vendor_id/product_id for ARCHOS Cobalt tablet

Bug #1410177 reported by mihaim on 2015-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libmtp (Ubuntu)
Low
Unassigned

Bug Description

I have added these two rules:
#MTP mode:
ATTR{idVendor}=="0e79", ATTR{idProduct}=="15ba", SYMLINK+="libmtp-%k", MODE="0660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"
#PTP mode:
ATTR{idVendor}=="0e79", ATTR{idProduct}=="15bc", SYMLINK+="libmtp-%k", MODE="0664", GROUP="plugdev", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"
and it works.
The line for PTP mode actually does nothing, the device was created with the same parameters before I added it. I mentioned the line just as an excuse for providing the prod_id.

Package-version: 1.1.6-20-g1b9f164-1ubuntu2
File: /lib/udev/rules.d/69-libmtp.rules
Ubuntu 14.04.1 LTS

Previously the device only worked in PTP mode while in MTP mode it was silently failing (nothing was actually failing, but the device was created with the wrong attributes, so it didn't work). No device appeared in Nautilus, ADB was saying "insufficient permissions for device".

mihaim (mihaim) wrote :
Sebastien Bacher (seb128) wrote :

thanks, that should probably be reported upstream on http://sourceforge.net/p/libmtp/bugs/

Changed in libmtp (Ubuntu):
importance: Undecided → Low
Dylan Aïssi (daissi) wrote :

Should be fixed in the next libmtp release [1].

[1] http://sourceforge.net/p/libmtp/code/ci/463482/

Changed in libmtp (Ubuntu):
status: New → Fix Committed
Changed in libmtp (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers