Unable to directly access files of any smartphone from Ubuntu

Bug #1263355 reported by Sergio Benjamim on 2013-12-21
78
This bug affects 18 people
Affects Status Importance Assigned to Milestone
libmtp (Ubuntu)
Medium
Unassigned

Bug Description

Unable to access files of Samsung Trend from Nautilus, when you connect device a problem happens: "Unable to mound Android, Unable to open MTP device '[usb:003,003]' "

If i try to access files such music or pictures in Android device, i get some errors.

I can copy files from Android device, and paste to a home folder, like Pictures or Documents, and it's possible to see images or listen musics in this way, for example.

The expected behavior is to see an ask window, and I could choose what I do with the device (open with Nautilus, Rhythmbox, Image viewer, Gthumb...).

lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b3aa Chicony Electronics Co., Ltd
Bus 001 Device 023: ID 0489:e062 Foxconn / Hon Hai
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 003 Device 004: ID 04e8:6860 Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II], GT-I9300 Phone [Galaxy S III], GT-P7500 [Galaxy Tab 10.1]
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libmtp-runtime 1.1.6-20-g1b9f164-1ubuntu2
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic x86_64
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.336ubuntu1
Date: Sat Dec 21 17:09:49 2013
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131221)
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libmtp
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
Sergio Benjamim (sergio-br2) wrote :
tags: added: saucy
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libmtp (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1263355

tags: added: package-qa-testing
Sergio Benjamim (sergio-br2) wrote :

Maybe this bug is a duplicate of Bug #1203704 , but i'm not sure, because there is marked as "Fix relesead".

Sergio Benjamim (sergio-br2) wrote :

I tried to connect in a different laptop, with other smartphone, same issue.

Smartphone: ID 0fce:0195 Sony Ericsson Mobile Communications AB

Laptop: http://pastebin.com/DucfyCbs

Xubuntu trusty, tried access files with Thunar.

summary: - Unable to access files of Samsung Trend from Nautilus
+ Unable to directly access files of any smartphone from Ubuntu
Changed in libmtp (Ubuntu):
importance: Undecided → Medium
Sergio Benjamim (sergio-br2) wrote :

I tested a samsung S4 mini (GT-I9195) with Android 4.2.2, same issue.

I would wonder why this issue is marked as "fix released" in bug #1203704 and gnome-bugs #695984.

And it's not possible to do simple things like copy and paste, or cut and paste. I have to delete file and copy from ubuntu to a new place in android.

Alex Palmer (asjp100) wrote :

I am on Ubuntu 14.04

I have the same problem with a Samsung Galaxy S3 Mini on Android 4.1
but on a Galaxy Nexus with Android 4.3 I do not see the problem and can access files directly.
Both phones are setup with MTP enabled in USB settings.

Mark Schneider (mc-monti) wrote :

I am using Ubuntu 14.04 as well and I have the same problems with my Galaxy S3 mini (Android 4.1.2). If I plug in my phone I get an error message, that the phone can't be mounted. Then a window is opening where the internal and external storage of my phone is shown. I can browse through the folders but I can't open a file.

Rhythmbox only lists a portable player, and if I start syncing music only the internal storage of my phone is used. I can't access the external SD-card using rhythmbox.

Lucas Barros (lb-lucas) wrote :

Same problem here with Ubuntu 14.10 Utopic...
I plug in my Galaxy S4 Mini (GT-i9192) phone, or my Galaxy Note8 (GT-N5100), and I get the "Unable to mount" error... I can't open any images (JPG, PNG, etc) inside the external SD nor in the internal storage, and no thumbnail is shown for those image files.
Sometimes I get to delete files, but mostly I don't.

the_mechanical (mechanical) wrote :

Problem is still present at Ubuntu 15.10 (Wily) - i know it's not released yet, but soon!

Tried to edit /etc/udev/rules.d/69-libmtp.rules added the line for my Asus Zenpad, but there was no effect.

dmesg says:
[ 323.054437] usb 1-3: new high-speed USB device number 3 using xhci_hcd
[ 323.184081] usb 1-3: New USB device found, idVendor=0b05, idProduct=600f
[ 323.184091] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 323.184096] usb 1-3: Product: Android
[ 323.184100] usb 1-3: Manufacturer: Android
[ 323.184105] usb 1-3: SerialNumber: F8NPFX007863
[ 343.415915] usb 1-3: reset high-speed USB device number 3 using xhci_hcd
[ 348.860781] usb 1-3: usbfs: process 2251 (pool) did not claim interface 0 before use

lsusb:
Bus 001 Device 003: ID 0b05:600f ASUSTek Computer, Inc.

mtp-detect:
libmtp version: 1.1.9
Listing raw device(s)
Device 0 (VID=0b05 and PID=600f) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   0b05:600f @ bus 1, dev 3
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

I created the file /etc/udev/rules.d/51-android.rules like it was mentioned in an other post.
Then i switched on USB-Debugging and restarted the computer (to be sure ;-) )

dmesg:
[ 42.975528] usb 1-3: new high-speed USB device number 3 using xhci_hcd
[ 43.105193] usb 1-3: New USB device found, idVendor=0b05, idProduct=601f
[ 43.105202] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 43.105208] usb 1-3: Product: Android
[ 43.105212] usb 1-3: Manufacturer: Android
[ 43.105216] usb 1-3: SerialNumber: F8NPFX007863

mtp-detect:
libmtp version: 1.1.9

Listing raw device(s)
Device 0 (VID=0b05 and PID=601f) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   0b05:601f @ bus 1, dev 3
Attempting to connect device(s)
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): Resource temporarily unavailable
outep: usb_get_endpoint_status(): Device or resource busy
ignoring libusb_claim_interface() = -6LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

So no success.

uname -a: 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

It seems it's the same problem than Bug #1314556

Anyone who can help??

Phil Norisez (norisezp) wrote :

Joining to add heat. I think this would be resolved if the latest libmtp (1.1.9) were put into the repository for all LTS versions.

Phil Norisez (norisezp) wrote :

Make that 1.1.10.

Uwe Jugel (uwe.jugel) wrote :

I can confirm the problem on Xubuntu 17.10. I think the problem is caused by braces "()" in file names. [1]
The MTP backend does not seem to like them.

It can be reproduced as follows:

1. Check that mtp works in general
2. create a regular file with only "a-z0-9" chars in a dir on your MTP device
3. mount and access it from Linux. This should work in most cases.

4. Now try the error case
5. create file with braces "()" in a dir on your MTP device.
6. mount and access it from Linux using `thunar`, `nautilus`, or even using `ls` or `cd` on the command line. This should produce the file manager (or console) to hang and no longer respond to user input, etc.

I also suspect this bug to be the cause for other bugs, e.g. in `gvfs` [2]

[1] related error report at askubuntu https://askubuntu.com/questions/995383/nautilus-hangs-on-accessing-dcim-camera-on-android/1013351
[2] maybe related gvfs bug https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1314556

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers