[ac100] libmtp9 does not depend on its own runtime package and lubuntu-desktop does not seed it

Bug #1061430 reported by Dimitri John Ledkov on 2012-10-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libmtp (Ubuntu)
Medium
Unassigned
lubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

Upon booting installed quantal daily preinstalled lubuntu ac100 image. I get following messages on bootscreen/syslog:
"""
Failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/platform/tegra-ehci.2/usb/2/2-1/2-1.3 2 5
"""

libmtp-common provides a udev rule, which calls mtp-probe from mtp-runtime package. But mtp-runtime package is not installed.
Please either fix the dependencies, or pre-install it on the image.

tags: added: iso-testing qa-daily-testing qa-manual-testing quantal
Changed in libmtp (Ubuntu):
importance: Undecided → Medium

digging into this, the libmtp-common package is pulled in through a dependency from libmtp9 (which has a reverse dependency on audacious, which in turn is seeded in lubuntu), but the libmtp9 package does not depend on libmtp-runtime

summary: - [ac100] libmtp-runtime is not pre-installed
+ [ac100] libmtp9 does not depend on its own runtime package
Oliver Grawert (ogra) wrote :

this seems to be a fallout of lubuntu seeds not using recommends by default (libmtp-runtime is a recommends of libmtp9)

Oliver Grawert (ogra) wrote :

in the light of the above, libmtp-common needs to be seeded explicitly together with the audacious package

Changed in libmtp (Ubuntu):
status: New → Invalid
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → Medium
Oliver Grawert (ogra) wrote :

err, i indeed meant libmtp-runtime in my last comment

summary: - [ac100] libmtp9 does not depend on its own runtime package
+ [ac100] libmtp9 does not depend on its own runtime package and lubuntu-
+ desktop does not seed it
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.45

---------------
lubuntu-meta (0.45) quantal; urgency=low

  * Refreshed dependencies
  * Added libmtp-runtime to desktop (LP: #1061430)
  * Added libpam-xdg-support to core
 -- Oliver Grawert <email address hidden> Thu, 04 Oct 2012 12:07:53 +0200

Changed in lubuntu-meta (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers