Ubuntu

libmbca doesn't use LP translations

Reported by Gabor Kelemen on 2008-10-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libmbca (Ubuntu)
Undecided
Unassigned

Bug Description

This binary package contains it's translations, and is not translatable via LP translations, although it's in the main repository.

Gabor Kelemen (kelemeng) wrote :

Hello? Anybody there?

Antti Kaijanmäki (kaijanmaki) wrote :

libmbca is translated by the gnome translators. AFAIK because of that libmbca should not be translated in launchpad also. If someone has insight how gnome translation project and launchpad project co-operate I'm happy to hear about it.

Changed in libmbca:
status: New → Confirmed
Gabor Kelemen (kelemeng) wrote :

No, you are wrong.
Any package that is in Ubuntu main, should be translatable via Launchpad. These translations are going to the language pack updates of Ubuntu and are not intended to be the general translation, which is the one in Gnome SVN.

About the cooperation between Gnome and launchpad: You develop software in Gnome SVN, the Gnome translators translate it, then you release a source package. This gets packaged by Ubuntu, then it's translation will be imported into launchpad. Here Ubuntu translators fix up problems with the original translation, then the translation will be packaged into language packs and deployed to users, who in turn will love Ubuntu because translations suck less than in other distributions ;). The Ubuntu translators (ideally, this is not always the case :() then export their updated po file and send it to the upstream translators.

Antti Kaijanmäki (kaijanmaki) wrote :

Well then, it's fine by me. I just don't want to get later in the crossfire between launchpad and gnome translator ;-)

I don't know how the translations are made available in launchpad, and quite frankly, I don't have the time to find out right now. Just go for it if you know how.

Changed in libmbca:
status: Confirmed → In Progress
Gabor Kelemen (kelemeng) wrote :

https://help.launchpad.net/Translations/YourProject#Uploading%20translation%20files
I hope this helps. As I'm only a translator, I don't have the rights to do actually do it for you :(.

On Tue, Dec 09, 2008 at 10:54:34AM -0000, Antti Kaijanmäki wrote:
> Well then, it's fine by me. I just don't want to get later in the
> crossfire between launchpad and gnome translator ;-)
>
> I don't know how the translations are made available in launchpad, and
> quite frankly, I don't have the time to find out right now. Just go for
> it if you know how.

You are right, its a difficult point .... usually its encouraged to
send fixes for translations upstream, but those are not always easy to
identify.

Usually launchpad translators should focus on languages not delt with
upstream and also with ubuntu specific syntax for certain kind of
things (e.g. how quoting is done etc.).

 - Alexander

Antti Kaijanmäki (kaijanmaki) wrote :

I opened up the translations for libmbca. I did initial import from the SVN and the files are in import queue currently.
https://translations.launchpad.net/libmbca/+imports

I hope this doesn't end up to be a complete disaster, but if it does I'm more than happy to let the l10n-people to handle that :)

Alexander Sack (asac) wrote :

On Wed, Dec 17, 2008 at 10:23:04AM -0000, Antti Kaijanmäki wrote:
> I opened up the translations for libmbca. I did initial import from the SVN and the files are in import queue currently.
> https://translations.launchpad.net/libmbca/+imports
>
> I hope this doesn't end up to be a complete disaster, but if it does I'm
> more than happy to let the l10n-people to handle that :)

If you dont get this in, remind me in a few days please so i can push
harder :).

 - Alexander

> I opened up the translations for libmbca. I did initial import from the SVN and the files are in import
> queue currently.
> https://translations.launchpad.net/libmbca/+imports

Unless you really want to run into problems with translators, you should either set the project to use 'gnome-translators' translation group, or not do the import. What Gabor was talking about was enabling translations in Ubuntu, which is a different thing. That would live here:

https://translations.launchpad.net/ubuntu/intrepid/+source/libmbca

I see no imports there (they should come from libmbca package in Ubuntu, so there's probably something wrong there), and as Gabor said that there are translations in the binary package, they should probably be stripped from it and put into Launchpad and language packs instead.

Arne, can you help with this?

Antti, I've blocked the POT import on libmbca project. If you are sure you want it imported into Launchpad, please file a question on answers.launchpad.net/rosetta and I'll take care of it (but you'll have to use GNOME Translators group to manage libmbca's translations then).

Timo Jyrinki (timo-jyrinki) wrote :

Antti most probably does not want to have the translations where they were uploaded to, so they can also be deleted (not only blocked).

Meanwhile, https://translations.launchpad.net/ubuntu/jaunty/+source/libmbca is still empty. It's still not too clear for me, but I have used to think that those should happen automatically for all packages in main - Ubuntu build system should strip the translations from the source package, but them into Launchpad/Rosetta and from there they should go to language packs. I don't know what's blocking those or more exactly, what's preventing the automatic stripping from happening since they are indeed in the libmbca0 binary package.

It's not that it would actually be a huge problem, since it seems GNOME translation teams have already translated libmbca into quite many languages, but still something is wrong somewhere.

Alexander Sack (asac) wrote :

On Sat, Feb 14, 2009 at 11:33:37AM -0000, Timo Jyrinki wrote:
> Antti most probably does not want to have the translations where they
> were uploaded to, so they can also be deleted (not only blocked).

antti, whats you opinion on this. Should this be translated in
launchpad - at least for ubuntu?

 - Alexander

Timo Jyrinki (timo-jyrinki) wrote :

> antti, whats you opinion on this. Should this be translated in
> launchpad - at least for ubuntu?

I think I can almost speak for Antti :) There is nothing unclear about this: libmbca is in main, therefore the Ubuntu translation for it should be in Rosetta, and there is a problem since it isn't. It shouldn't be upstream's concern at all. People are mixing Rosetta's project translation capabilities and Ubuntu translation capabilities: Antti uploaded project translations as if they were to be translated in Rosetta - this is clearly wrong, since they are done as part of the GNOME translation project. They were already blocked, I just proposed they could be deleted as well so as not to look like they might some day become unblocked.

The problem is that translations are not stripped by the Ubuntu build system, and I do not know whose responsibility at Ubuntu that would be. Antti could try to see if there is something fixable/wrong on the package, but probably only someone who knows how the system works could see why the translations aren't being made available in Ubuntu translations.

Would Danilo, Arne, Gabor, anyone have insight what to do with this? There is a similar problem with computer-janitor, bug 334203.

Antti Kaijanmäki (kaijanmaki) wrote :

OK. I closed translation section of upstream libmbca in launchpad and marked the blocked translation as "Deleted". Let me know if there's still something wrong with that ;-)

Let's keep upstream translation in svn.gnome.org, but also have ubuntu sources translated in Rosetta, just as Timo said.

.pot should be generated automatically during the build. Build log could help.. We are preparing new release and packages of m-b-p-i next week for hardy, intrepid and jaunty. I try to look into this template problem also.

Alexander Sack (asac) wrote :

On Fri, Mar 06, 2009 at 08:08:40AM -0000, Antti Kaijanmäki wrote:
> OK. I closed translation section of upstream libmbca in launchpad and
> marked the blocked translation as "Deleted". Let me know if there's
> still something wrong with that ;-)
>
> Let's keep upstream translation in svn.gnome.org, but also have ubuntu
> sources translated in Rosetta, just as Timo said.
>
> .pot should be generated automatically during the build. Build log could
> help.. We are preparing new release and packages of m-b-p-i next week
> for hardy, intrepid and jaunty. I try to look into this template problem
> also.
>

AFAICT, there is not much we can do wrong except trying to not ship
the translations in the binary packages at all (do we do this?). The
buildds binary package mangler will automatically strips the
translations from the binary packages and imports them into rosetta.

 - Alexander

Timo Jyrinki (timo-jyrinki) wrote :

Antti asked me to remind him here that intltool-update needs to be run. One way is to use cdbs's gnome.mk which does that, but probably in case of libmbca manual running of intltool-update in debian/rules is preferred.

Timo Jyrinki (timo-jyrinki) wrote :

If no-one has better ideas, I think this kind of patch would be enough.

Adi Roiban (adiroiban) on 2009-03-22
tags: added: i18n
Alexander Sack (asac) wrote :

On Fri, Mar 13, 2009 at 08:34:43AM -0000, Timo Jyrinki wrote:
> If no-one has better ideas, I think this kind of patch would be enough.
>
> ** Attachment added: "add_intltool_update.patch"
> http://launchpadlibrarian.net/23817892/add_intltool_update.patch
>

I think we should also start to make the package clean on clean::
target.

Can you remove the created files in clean:: target too?

 - Alexander

Timo Jyrinki (timo-jyrinki) wrote :

Sure. Attached is a patch that also removes the generated .pot file on clean. Not that the whole package would be properly cleaning itself up with fakeroot debian/rules clean, but at least the part that was introduced with intltool-update.

Alexander Sack (asac) wrote :

bzr commit -m '* fix LP: #291226 - libmbca doesn't use LP translations; we run intltool-update
  in debian/rules in common-build-arch:: and cleanup generated files in clean::
  - update dbian/rules' --fixes 'lp:291226'
Committing to: bzr+ssh://<email address hidden>/~network-manager/libmbca/libmbca.ubuntu/
modified debian/changelog
modified debian/rules
Committed revision 50.

Changed in libmbca (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libmbca - 0.0.4+bzr66-0ubuntu1

---------------
libmbca (0.0.4+bzr66-0ubuntu1) jaunty; urgency=low

  * new 0.0.4 upstream snapshot (bzr66)
    - fix LP: #290625 - New CDMA entries added as GSM
  * add hardy intltool-*in templates (intltoolize -f -c)
    - add intltool-extract.in
    - add intltool-merge.in
    - add intltool-update.in
  * fix LP: #334377 - Lots of country names are missing, showing "missing from
    libgweather" in mobile broadband connection wizard.
    - add debian/patches/lp334377_debian_libgweather_breakage.patch
  * fix LP: #291226 - libmbca doesn't use LP translations; we run intltool-update
    in debian/rules in common-build-arch:: and cleanup generated files in clean::
    - update dbian/rules

 -- Alexander Sack <email address hidden> Mon, 30 Mar 2009 14:08:59 +0200

Changed in libmbca:
status: Fix Committed → Fix Released
Adi Roiban (adiroiban) wrote :

I have approved the template.

If the translation domain is "libmbca" everything should be OK,

Timo, next time a template is waiting in the queue please let me know and I will try to aprove it as soon as posible :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers