Audio dirft while playing few movies in VLC

Bug #494656 reported by deppfx on 2009-12-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libmad (Ubuntu)
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

While playing videos on VLC, I see some clutters in the audio being played. The following is what VLC shows in its Messages log.

main debug: audio output is starving (21262), playing silence
main warning: output date isn't PTS date, requesting resampling (48198)
main warning: audio drift is too big (141255), dropping buffer
mpgatofixed32 debug: libmad error: bad main_data_begin pointer
main warning: output date isn't PTS date, requesting resampling (52838)
main warning: audio drift is too big (169010), dropping buffer
main warning: audio drift is too big (145010), dropping buffer
main warning: audio drift is too big (121010), dropping buffer
mpgatofixed32 debug: libmad error: bad main_data_begin pointer
main warning: output date isn't PTS date, requesting resampling (48249)
main warning: audio drift is too big (144301), dropping buffer
main warning: audio drift is too big (120301), dropping buffer
main warning: output date isn't PTS date, requesting resampling (41187)
main warning: audio drift is too big (122238), dropping buffer
mpgatofixed32 debug: libmad error: bad main_data_begin pointer
main warning: output date isn't PTS date, requesting resampling (40263)
main warning: audio drift is too big (129001), dropping buffer
main warning: output date isn't PTS date, requesting resampling (54201)
main warning: audio drift is too big (128014), dropping buffer
mpgatofixed32 debug: libmad error: bad main_data_begin pointer

ProblemType: Bug
Architecture: i386
Date: Wed Dec 9 17:22:49 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: vlc 1.0.2-1ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.52-generic
SourcePackage: vlc
Uname: Linux 2.6.31-16-generic i686

deppfx (deppfx) wrote :

Is this symptom with the pulseaudio output in VLC?

On Dec 9, 2009 1:50 PM, "deppfx" <email address hidden> wrote:

** Attachment added: "Dependencies.txt"
  http://launchpadlibrarian.net/36634042/Dependencies.txt

** Attachment added: "XsessionErrors.txt"
  http://launchpadlibrarian.net/36634043/XsessionErrors.txt

-- Audio dirft while playing few movies in VLC
https://bugs.launchpad.net/bugs/494656 You received...

deppfx (deppfx) wrote :

I guess its with direct ALSA [or whatever came with Ubuntu Karmic] because I haven't installed PULSE yet during the test.

deppfx (deppfx) wrote :

The problem still persists even after trying to uninstall/reinstall VLC, after deleting/resetting its preferences. I'd be glad to provide with any kind of information you might need. I see that the problem is widespread without a solution all over when I searched with Google. I doubt if its an Ubuntu core-bug.

Rémi Denis-Courmont (rdenis) wrote :

libmad is complaining about invalid input. I would guess there is something wrong with the input file. In principle, it could also be something in libmad or the VLC MPGA packetizer.

Do you have a sample?

Changed in vlc (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Changed in vlc (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers