package libkipi-data 4:4.8.4-0ubuntu0.1 failed to install/upgrade: Versuch, »/usr/share/kde4/apps/kipi/data/kipi-plugins_logo.png« zu überschreiben, welches auch in Paket libkipi7 4:4.4.5-0ubuntu1.1 ist

Bug #1041766 reported by Tomas Pospisek on 2012-08-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libkipi (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Felix Geyer

Bug Description

During an upgrade 10.04 -> 12.04.1 libkipi-data is trying to overwrite files that belong to libkipi7

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libkipi-data 4:4.8.4-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Sat Aug 25 23:07:54 2012
Dependencies:

ErrorMessage: Versuch, »/usr/share/kde4/apps/kipi/data/kipi-plugins_logo.png« zu überschreiben, welches auch in Paket libkipi7 4:4.4.5-0ubuntu1.1 ist
PackageArchitecture: all
SourcePackage: libkipi
Title: package libkipi-data 4:4.8.4-0ubuntu0.1 failed to install/upgrade: Versuch, »/usr/share/kde4/apps/kipi/data/kipi-plugins_logo.png« zu überschreiben, welches auch in Paket libkipi7 4:4.4.5-0ubuntu1.1 ist
UpgradeStatus: Upgraded to precise on 2012-08-25 (0 days ago)

Tomas Pospisek (tpo-deb) wrote :
Felix Geyer (debfx) on 2012-08-28
Changed in libkipi (Ubuntu Precise):
assignee: nobody → Felix Geyer (debfx)
status: New → In Progress
Changed in libkipi (Ubuntu):
status: New → Invalid

Hello Tomas, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libkipi (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Felix Geyer (debfx) wrote :

I have verified that the libkipi-data package correctly Replaces and Breaks libkipi7.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libkipi - 4:4.8.5-0ubuntu0.1

---------------
libkipi (4:4.8.5-0ubuntu0.1) precise-proposed; urgency=low

  [ Scott Kitterman ]
  * New upstream bugfix release (LP: #1047417)

  [ Felix Geyer ]
  * Make libkipi-data break/replace libkipi7 due to file conflicts.
    (LP: #1041766)
 -- Felix Geyer <email address hidden> Fri, 07 Sep 2012 16:53:26 +0200

Changed in libkipi (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers