avoid libkate in vorbis (Was: [MIR] promote libkate, needed as b-d/d for vorbis-tools)

Bug #641322 reported by Matthias Klose on 2010-09-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libkate (Ubuntu)
High
Unassigned
Maverick
High
Unassigned
liboggz (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
vorbis-tools (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

please promote libkate, needed as b-d/d for vorbis-tools; it's a library package, not pulling any other packages to main. package maintenance looks sane.

the 0.3.7 version is from December 2009, there is a newer version in Debian unstable available

The alternative is to drop the kate support from vorbis-tools.

Matthias Klose (doko) on 2010-09-17
Changed in libkate (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.10
status: New → Triaged
Matthias Klose (doko) wrote :

sorry libkate pulls in liboggz as well

Alexander Sack (asac) wrote :

i think we can just use --without-kate for maverick and properly review this codec thing after release.

summary: - [MIR] promote libkate, needed as b-d/d for vorbis-tools
+ avoid libkate in vorbis (Was: [MIR] promote libkate, needed as b-d/d for
+ vorbis-tools)
Changed in libkate (Ubuntu):
milestone: ubuntu-10.10 → later
Changed in vorbis-tools (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-10.10
Changed in libkate (Ubuntu):
status: Triaged → Invalid
status: Invalid → Triaged
Alexander Sack (asac) wrote :

from what i understand vorbis-tools ftbfs now because of this. RC for release. building it --without-kate should work and we can avoid pulling in more codec libs into main at this point in cycle.

Changed in libkate (Ubuntu Maverick):
status: Triaged → Invalid
Changed in liboggz (Ubuntu Maverick):
status: New → Invalid
Changed in libkate (Ubuntu Maverick):
status: Invalid → Won't Fix
Changed in libkate (Ubuntu):
status: Invalid → Confirmed
Changed in liboggz (Ubuntu Maverick):
status: Invalid → Won't Fix
Changed in liboggz (Ubuntu):
status: Invalid → Confirmed
Alexander Sack (asac) wrote :

build --without-kate

Alexander Sack (asac) wrote :

seems to build without libkate-dev with the patch from above. but i am not so sure how to test vorbis-tools ... to see if they are still useful this way.

Matthias Klose (doko) wrote :

uploaded. this seems to be safe. vorbis-tools was never built with libkate in Ubuntu. no regression compared to lucid.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vorbis-tools - 1.4.0-1ubuntu1

---------------
vorbis-tools (1.4.0-1ubuntu1) maverick; urgency=low

  * build --without-kate; avoid MIR for kate/liboggz (LP: #641322)
 -- Alexander Sack <email address hidden> Fri, 17 Sep 2010 16:43:53 +0200

Changed in vorbis-tools (Ubuntu Maverick):
status: Triaged → Fix Released
Alexander Sack (asac) on 2010-09-18
Changed in libkate (Ubuntu):
milestone: later → none
Changed in libkate (Ubuntu Maverick):
milestone: later → none
ogg.k (ogg-k-ogg-k) wrote :

Hi, I (author of libkate) have been pointed to here, and, for the record, the optional dependency on liboggz is for the tools from liboggz, which are only optionally used for the "make test" target.
The library and its tools do not need liboggz, and configure ought to set things up just fine if liboggz isn't there.

Matthias Klose (doko) wrote :

ok, thanks for the clarification. closing the report with the current solution.

Changed in liboggz (Ubuntu):
status: Confirmed → Fix Released
Changed in libkate (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers