libkarma-cil's .pc file contains a blank Version field

Bug #451914 reported by Chow Loong Jin on 2009-10-15
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libkarma (Debian)
Fix Released
libkarma (Ubuntu)

Bug Description

$ cat /usr/lib/pkgconfig/karma-sharp.pc

Name: karma-sharp
Description: karma-sharp - Library for interfacing with Rio Karma devices
Libs: -r:${Libraries}

This causes issues when applications like Banshee issue a
PKG_CHECK_MODULES([karma-sharp >= <VERSION>]).

As a result of this, Banshee has not had Karma support since before 1.4.3. I'll
attach a debdiff for this shortly.

  affects ubuntu/libkarma
  status inprogress
  assignee hyperair

Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

Related branches

Chow Loong Jin (hyperair) wrote :

And here's the debdiff. The package has been uploaded to my bugfixes PPA: for testing purposes.

Iain Lane (laney) on 2009-10-15
Changed in libkarma (Ubuntu):
status: In Progress → Fix Committed
assignee: Chow Loong Jin (hyperair) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libkarma - 0.0.6-4.1ubuntu2

libkarma (0.0.6-4.1ubuntu2) karmic; urgency=low

  * debian/rules:
    + Add VERSION=0.0.6 to make install calls. VERSION=0.0.6 is exported
      by the top-level Makefile, and not propagated to the inner Makefiles.
      (LP: #451914)

 -- Chow Loong Jin <email address hidden> Thu, 15 Oct 2009 14:09:48 +0800

Changed in libkarma (Ubuntu):
status: Fix Committed → Fix Released
Changed in libkarma (Debian):
status: Unknown → New
Changed in libkarma (Debian):
status: New → Fix Committed
Changed in libkarma (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.