Scilab 6.0.1 shows on start warning in terminal - /usr/share/java/jlatexmath-fop-1.0.6.jar, but there is /usr/share/java/jlatexmath-fop-1.0.7.jar in repository

Bug #1767082 reported by Norbert on 2018-04-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libjlatexmath-java (Ubuntu)
Undecided
Unassigned
scilab (Debian)
Fix Released
Unknown
scilab (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Have Ubuntu 18.04 LTS and Scilab installed
2. Try to launch Scilab from terminal

Expected results:
* Scilab starts without errors

Actual results:
* Scilab shows warning in terminal

$ scilab
Warning: Could not find Java package '/usr/share/java/jlatexmath-fop-1.0.6.jar'.
Some problems during the loading of the Java libraries occurred.
This could lead to inconsistent behaviours.
Please check SCI/etc/classpath.xml.

Note:

$ dpkg -S /usr/share/java/jlatexmath-fop*
libjlatexmath-fop-java: /usr/share/java/jlatexmath-fop-1.0.7.jar
libjlatexmath-fop-java: /usr/share/java/jlatexmath-fop.jar

$ apt-cache policy libjlatexmath-fop-java
libjlatexmath-fop-java:
  Installed: 1.0.7-1
  Candidate: 1.0.7-1
  Version table:
 *** 1.0.7-1 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://ru.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: scilab 6.0.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: MATE
Date: Thu Apr 26 12:17:14 2018
PackageArchitecture: all
SourcePackage: scilab
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) on 2018-07-07
no longer affects: scilab
Norbert (nrbrtx) wrote :

Bug still exists on Ubuntu 18.04 LTS with all updates.

Changed in scilab (Debian):
status: Unknown → New

solution works for me...
https://askubuntu.com/questions/1029163/how-to-get-scilab-6-0-1-working-on-ubuntu-18-04-lts
cd ~/Downloads
wget http://http.kali.org/pool/main/libj/libjlatexmath-java/libjlatexmath-fop-java_1.0.6-1_all.deb

(just in case it fails access the link and download it...)

sudo apt-get install ./libjlatexmath-fop-java_1.0.6-1_all.deb --allow-downgrades
sudo tee /etc/apt/preferences.d/pin-jlfop >/dev/null <<EOF
Package: libjlatexmath-fop-java
Pin: version 1.0.6-1
Pin-Priority: 1337
EOF

works great...!!

Norbert (nrbrtx) wrote :

18.10 cosmic is affected too.

tags: added: cosmic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libjlatexmath-java (Ubuntu):
status: New → Confirmed
Changed in scilab (Ubuntu):
status: New → Confirmed
Changed in scilab (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.