need default-jdk migration

Bug #422788 reported by Martin Pitt on 2009-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libjamon-java (Ubuntu)
Low
Unassigned
Karmic
High
Thierry Carrez

Bug Description

Binary package hint: libjamon-java

Package still builds with gcj, needs default-jdk migration. See https://wiki.ubuntu.com/EucalyptusInMainSpec/Packages

Martin Pitt (pitti) wrote :

Making release blocker, since package is already in main.

Changed in libjamon-java (Ubuntu Karmic):
assignee: nobody → Thierry Carrez (ttx)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → Triaged
Thierry Carrez (ttx) wrote :

Packages shouldn't use the deprecated java-*-compat-* virtuals but properly depend on the new *-jdk stuff instead. But at this point, if something only builds with gcj, making them build-depend on gcj-jdk is acceptable and correct. At least that was my understanding when I wrote up https://wiki.ubuntu.com/JavaTeam/LibraryPackaging.

Changed in libjamon-java (Ubuntu Karmic):
status: Triaged → Won't Fix
Changed in libjamon-java (Ubuntu):
assignee: Thierry Carrez (ttx) → nobody
importance: High → Low
milestone: ubuntu-9.10 → none
Thierry Carrez (ttx) wrote :

Fixed in the merge to 2.7-1ubuntu1

Changed in libjamon-java (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers