libio-socket-ssl-perl depends on obsolete libssl1.1

Bug #1957170 reported by Simon Chopin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libio-socket-ssl-perl (Ubuntu)
Undecided
Unassigned

Bug Description

The package declares an explicit dependency on libssl1.1, which we don't really want since we're transitioning to OpenSSL 3.0

Revision history for this message
Simon Chopin (schopin) wrote :

Attached is a patch removing the hard-coded dependency. A fixed package has also been uploaded to a PPA (just pop the last changelog entry): https://launchpad.net/~schopin/+archive/ubuntu/test-ppa/+sourcepub/13196884/+listing-archive-extra

Revision history for this message
Simon Chopin (schopin) wrote :

gregoa uploaded this patch to Debian, and the new version has been synced over to -proposed. Marking as Fix Committed, unsubscribing Sponsors.

Changed in libio-socket-ssl-perl (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libio-socket-ssl-perl - 2.074-2

---------------
libio-socket-ssl-perl (2.074-2) unstable; urgency=medium

  [ Simon Chopin ]
  * d/control: Drop libssl1.1 explicit dependencies (LP: #1957170)

 -- gregor herrmann <email address hidden> Thu, 13 Jan 2022 20:02:13 +0100

Changed in libio-socket-ssl-perl (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers