Touchpad button doesn't work on Dell Precision 7550/7750

Bug #1906341 reported by Kai-Chuan Hsieh on 2020-12-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
libevdev (Ubuntu)
High
Kai-Chuan Hsieh
Bionic
High
Unassigned
Focal
High
Unassigned
Groovy
High
Unassigned
libinput (Ubuntu)
High
Kai-Chuan Hsieh
Bionic
High
Unassigned
Focal
High
Unassigned
Groovy
High
Unassigned

Bug Description

[Impact]

 * The touchpad's right button become no function after update to 5.4 kernel

 * The INPUT_PROP_BUTTONPAD property is set by 5.4 kernel, so that libinput regard it as clickpad, the root cause is that the touchpad
firmware doesn't config correctly.

 * Add a model quirk to unset the bit can make touchpad's right button works normally.

[Test Case]

 * 1. Boot into Ubuntu
   2. Identify touchpad input device number,
      can be obtained in $HOME/.local/share/xorg/Xorg.0.log
   3. $ udevadm info /sys/class/input/inputX
      check PROP environment variable,
      it is 5 if INPUT_PROP_BUTTONPAD property is set
   4. And the touchpad right button become no function
   5. After update the libevdev with disable_property
      API and libinput10 with model quirk
   6. reboot
   7. The input device PROP is still 5,
      but touchpad right button is workable

[Where problems could occur]

 * For libevdev2 package, backport the upstream commit:
   https://gitlab.freedesktop.org/libevdev/libevdev/-/commit/4226c7801b4ea1b0c7d1eaac47ca24ece8f24809
   The API is not originally exist in the system,
   so it will only be utilized by our model quirk.

 * For libinput, add model quirk for the platform to disable
   INPUT_PROP_BUTTONPAD bit.
   Only disable the INPUT_PROP_BUTTONPAD for specified model,
   and it doesn't issue any
   IO command to kernel, so the behavior should be the same
   as previous kernel when INPUT_PROP_BUTTONPAD is not set.

[Other Info]

 * A public bug is reported
   https://www.dell.com/community/Linux-Developer-Systems/Touchpad-right-click-button-not-working-with-Ubuntu-20-04-on/td-p/7636831
 * A workable build for Bionic/Focal/Groovy are in my ppa
   https://launchpad.net/~kchsieh/+archive/ubuntu/training
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.16
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: u 1646 F.... pulseaudio
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
DistUpgraded: Fresh install
DistroCodename: bionic
DistroRelease: Ubuntu 18.04
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Device [8086:9bc4] (rev 05) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:09c3]
InstallationDate: Installed on 2020-12-01 (0 days ago)
InstallationMedia: Ubuntu 18.04.5 LTS "Bionic Beaver" - Release amd64 (20200806.1)
MachineType: Dell Inc. Precision 7550
Package: linux (not installed)
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-42-generic root=UUID=2964a5af-ac17-45ee-a009-41879da14e1b ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 5.4.0-42.46~18.04.1-generic 5.4.44
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-42-generic N/A
 linux-backports-modules-5.4.0-42-generic N/A
 linux-firmware 1.173.19
Tags: bionic ubuntu
Uname: Linux 5.4.0-42-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/01/2020
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.4.0
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.4.0:bd09/01/2020:svnDellInc.:pnPrecision7550:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Precision
dmi.product.name: Precision 7550
dmi.product.sku: 09C3
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.0.8-0ubuntu1~18.04.1
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

description: updated
tags: added: focal

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1906341

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oem-priority originate-from-1905819 timbuktu
Kai-Chuan Hsieh (kchsieh) wrote :

Upload libinput debdiff

Kai-Chuan Hsieh (kchsieh) wrote :

Upload bionic libevdev debdiff.

description: updated
description: updated

apport information

tags: added: apport-collected bionic ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in libevdev (Ubuntu):
assignee: nobody → Kai-Chuan Hsieh (kchsieh)
Changed in libinput (Ubuntu):
assignee: nobody → Kai-Chuan Hsieh (kchsieh)
Changed in libevdev (Ubuntu):
status: New → In Progress
Changed in libinput (Ubuntu):
status: New → In Progress
Changed in linux (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Kai-Chuan Hsieh (kchsieh) wrote :

Upload libevdev debdiff for focal.

Kai-Chuan Hsieh (kchsieh) wrote :

Upload libinput debdiff for focal.

The attachment "libinput.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Kai-Chuan Hsieh (kchsieh) wrote :

Upload libevdev debdiff for groovy.

Kai-Chuan Hsieh (kchsieh) wrote :

Upload libinput devdiff for groovy.

description: updated
Kai-Chuan Hsieh (kchsieh) wrote :

The upstream has the fix already https://gitlab.freedesktop.org/libinput/libinput/-/commit/69959c8a3b0612fb2bea015713f630a896188529

Will hirsute libinput sync the latest commit for it?

Sebastien Bacher (seb128) wrote :

Thank Kai, some questions and notes
- lidevdev is in hirsute now and include the change

- the libevdev debdiff
  - the version '+lp1906341~rc1' was ok for a ppa but should be changed for the archive
  - the patch should include a description, a reference to the upstream commit would be enough

- the libinput debdiff
  - the changelog should describe the debian/control change and why it's there
  - the patch should include a description (use the git commit maybe there?)
  - shouldn't you update the Depends on libevdev? if libinput source uses the new symbol it should ensure the new libinput is installed right?

Changed in libevdev (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

Reading the description is also sounds like it's a kernel bug if the device is wrongly tagged no? if so why not fix the kernel instead of workaround in userland?

Kai-Chuan Hsieh (kchsieh) wrote :

reply #32

@seb128

Thanks for review, actually, it is not a kernel bug, it is because the touchpad report descriptor doesn't config correctly, please refer to the windows document "Device capabilities feature report" part.
https://docs.microsoft.com/en-us/windows-hardware/design/component-guidelines/windows-precision-touchpad-required-hid-top-level-collections

The touchpad device announce it is a depressible touchpad, which is not, so that the kernel set the INPUT_PROP_BUTTONPAD bit which leads the libinput won't handle the BTN_RIGHT event. I have asked the touchpad vendor, they have no capability to update touchpad firmware on Linux currently.

Sorry that I just attach the debdiff for my test ppa, will upload a more official debdiff here.
May I know how many release should I do SRU? Bionic, Focal, and Groovy is enough?

Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :

@seb128

Hello,

I re-upload the debdiff, would you please check it again.
By the way, I don't know if I have to do SRU for hirsute. Would you provide you suggestion?

Thanks,

Sebastien Bacher (seb128) wrote :

hirsute isn't stable yet so there is no SRU process there, I'm happy to handle the update to that serie. You updated the libinput debdiff to add libevdev-dev to the libinput-dev Depends but isn't the new version needed by the actual library? what happens if you install the new libinput10 without the updated libevdev (which the packaging depends aren't preventing to do now unless I'm overlooking something)

Sebastien Bacher (seb128) wrote :

Oh and on the series you need to SRU to, you are the one that has the customer requirement there, if you want it back to Bionic then yes you need B/F/G

Kai-Chuan Hsieh (kchsieh) wrote :

@seb128,

reply to #41

> You updated the libinput debdiff to add libevdev-dev to the libinput-dev Depends but isn't the
> new version needed by the actual library?

[ANS]: the libinput10 packages dependency is based on the build environment's libevdev-dev version, therefore, I only have to designate the libevdev build-dep. I attach the control file for the build of libinput10_1.10.4-1ubuntu0.18.04.2_amd64.deb, which I extract it by "$ dpkg-deb -e libinput10_1.10.4-1ubuntu0.18.04.2_amd64.deb".

When install libinput10_1.10.4-1ubuntu0.18.04.2_amd.deb, it requires libevdev2 (>= 1.5.8+dfsg-1ubuntu0.1).

description: updated
Sebastien Bacher (seb128) wrote :

Oh thanks, looks like dpkg-gensymbols is adding the symbols even if the debian/libname.symbols isn't updated which makes that work automatically, ideally the list would be manually updated and the build log has a warning about that but that should make a difference for a SRU. I've uploaded now

Changed in libinput (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libinput - 1.16.4-1ubuntu1

---------------
libinput (1.16.4-1ubuntu1) hirsute; urgency=medium

  * quirks: Unset INPUT_PROP_BUTTONPAD for Dell Precision 7550/7750.
    (LP: #1906341)
  * Update control build-dep libevdev-dev (>= 1.10.0) for
    libevdev_disable_property API

 -- Sebastien Bacher <email address hidden> Thu, 03 Dec 2020 16:32:27 +0100

Changed in libinput (Ubuntu):
status: Fix Committed → Fix Released
Kai-Chuan Hsieh (kchsieh) wrote :

@seb128

Thanks for reviewing it carefully and the explicit explanation.

Timo Aaltonen (tjaalton) wrote :

is the libinput quirk sent upstream?

Changed in libevdev (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-groovy

Hello Kai-Chuan, or anyone else affected,

Accepted libevdev into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libevdev/1.9.1+dfsg-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libevdev (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Timo Aaltonen (tjaalton) wrote :

Hello Kai-Chuan, or anyone else affected,

Accepted libevdev into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libevdev/1.9.0+dfsg-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Kai-Chuan, or anyone else affected,

Accepted libevdev into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libevdev/1.5.8+dfsg-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libevdev (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello Kai-Chuan, or anyone else affected,

Accepted libinput into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libinput/1.16.2-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libinput (Ubuntu Groovy):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Kai-Chuan, or anyone else affected,

Accepted libinput into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libinput/1.15.5-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libinput (Ubuntu Focal):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

bah, accepted libinput for bionic just before realizing that the bug in the changelog was for the private project and not this.. so it's tracking will be broken

Kai-Chuan Hsieh (kchsieh) wrote :

@tjaalton

reply to #54

ah, yes. it was my mistake, I initially create the debdiff without caution, I'll re-upload the the debdiff for bionic, can you help to switch the deb in bionic queue for me?

Sorry for your inconvenience,

Kai-Chuan Hsieh (kchsieh) wrote :
Kai-Chuan Hsieh (kchsieh) wrote :

Verify pass on focal.

Test on machine with clickpad bit is 0:

1. install 20.04 on Precision 7750
2. enable developer option
3. $ sudo apt install libinput10
4. $ sudo reboot
5. check the touchpad input device properties is 5
6. Test that left/right button works

Test on machine with clickpad bit is 1:

1. install 20.04 on Precision 7750
2. enable developer option
3. $ sudo apt install libinput10
4. $ sudo reboot
5. check the touchpad input device properties is 1
6. Test that left/right button still works

tags: added: verification-done-focal
removed: verification-needed-focal
Kai-Chuan Hsieh (kchsieh) wrote :

Verify pass on groovy.

Test on machine with clickpad bit is 0:

1. install 20.10 on Precision 7750
2. enable developer option
3. $ sudo apt install libinput10
4. $ sudo reboot
5. check the touchpad input device properties is 5
6. Test that left/right button works

Test on machine with clickpad bit is 1:

1. install 20.10 on Precision 7750
2. enable developer option
3. $ sudo apt install libinput10
4. $ sudo reboot
5. check the touchpad input device properties is 1
6. Test that left/right button still works

tags: added: verification-done-groovy
removed: verification-needed-groovy
Kai-Chuan Hsieh (kchsieh) wrote :

According to https://bugs.launchpad.net/timbuktu/+bug/1905819/comments/7

The bionic is also verified.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Mathew Hodson (mhodson) on 2020-12-11
tags: added: patch-accepted-upstream
no longer affects: linux (Ubuntu)
no longer affects: libevdev (Ubuntu Bionic)
Changed in libevdev (Ubuntu Bionic):
status: New → Fix Committed
Changed in libinput (Ubuntu Bionic):
status: New → Fix Committed
Changed in libevdev (Ubuntu):
importance: Undecided → High
Changed in libevdev (Ubuntu Bionic):
importance: Undecided → High
Changed in libevdev (Ubuntu Focal):
importance: Undecided → High
Changed in libevdev (Ubuntu Groovy):
importance: Undecided → High
Changed in libinput (Ubuntu):
importance: Undecided → High
Changed in libinput (Ubuntu Bionic):
importance: Undecided → High
Changed in libinput (Ubuntu Focal):
importance: Undecided → High
Changed in libinput (Ubuntu Groovy):
importance: Undecided → High

The verification of the Stable Release Update for libevdev has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libevdev - 1.9.1+dfsg-1ubuntu0.1

---------------
libevdev (1.9.1+dfsg-1ubuntu0.1) groovy; urgency=medium

  * debian/patches/Add libevdev_disable_property:
    - needed for libinput quirks on some Dell Precision configurations
      (lp: #1906341)

 -- Kai-Chuan Hsieh <email address hidden> Thu, 03 Dec 2020 15:31:26 +0100

Changed in libevdev (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libinput - 1.16.2-1ubuntu0.1

---------------
libinput (1.16.2-1ubuntu0.1) groovy; urgency=medium

  * quirks: Unset INPUT_PROP_BUTTONPAD for Dell Precision 7550/7750.
    (LP: #1906341)
  * Update control build-dep libevdev-dev (>= 1.9.1+dfsg-1ubuntu0.1) for
    libevdev_disable_property API

 -- Kai-Chuan Hsieh <email address hidden> Thu, 03 Dec 2020 16:35:46 +0100

Changed in libinput (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libevdev - 1.9.0+dfsg-1ubuntu0.1

---------------
libevdev (1.9.0+dfsg-1ubuntu0.1) focal; urgency=medium

  * debian/patches/Add libevdev_disable_property:
    - needed for libinput quirks on some Dell Precision configurations
      (lp: #1906341)

 -- Kai-Chuan Hsieh <email address hidden> Thu, 03 Dec 2020 15:32:01 +0100

Changed in libevdev (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libevdev - 1.5.8+dfsg-1ubuntu0.1

---------------
libevdev (1.5.8+dfsg-1ubuntu0.1) bionic; urgency=medium

  * debian/patches/Add libevdev_disable_property:
    - needed for libinput quirks on some Dell Precision configurations
      (lp: #1906341)

 -- Kai-Chuan Hsieh <email address hidden> Thu, 03 Dec 2020 15:37:38 +0100

Changed in libevdev (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libinput - 1.15.5-1ubuntu0.2

---------------
libinput (1.15.5-1ubuntu0.2) focal; urgency=medium

  * quirks: Unset INPUT_PROP_BUTTONPAD for Dell Precision 7550/7750.
    (LP: #1906341)
  * Update control build-dep libevdev-dev (>= 1.9.0+dfsg-1ubuntu0.1) for
    libevdev_disable_property API

 -- Kai-Chuan Hsieh <email address hidden> Tue, 01 Dec 2020 15:17:34 +0800

Changed in libinput (Ubuntu Focal):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson) wrote :

This bug was fixed in the package libinput - 1.10.4-1ubuntu0.18.04.2

---------------
libinput (1.10.4-1ubuntu0.18.04.2) bionic; urgency=medium

  * Unset INPUT_PROP_BUTTONPAD for Dell Precision 7x50. (LP: #1905819)
  * Update control build-dep libevdev-dev (>= 1.5.8+dfsg-1ubuntu0.1) for
    libevdev_disable_property API.

 -- Kai-Chuan Hsieh <email address hidden> Mon, 30 Nov 2020 20:08:24 +0800

Changed in libinput (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.