Touchpad vertical sensitivity is much higher than horizontal sensitivity [HP Pavilion g6]

Bug #1825499 reported by Sherif on 2019-04-19
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
systemd
Fix Released
Unknown
libinput (Fedora)
Won't Fix
Undecided
libinput (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
systemd (Ubuntu)
Medium
Unassigned

Bug Description

After installing Kubuntu 19.04, I found that vertical sensitivity is much higher than horizontal sensitivity.
Installing xserver-xorg-input-synaptics improved the situation a bit and enabled KDE touchpad setting that were disabled.

It's very annoying.

Laptop: HP Pavilion g6.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xserver-xorg-input-synaptics 1.9.1-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CurrentDesktop: KDE
Date: Fri Apr 19 12:00:02 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
MachineType: Hewlett-Packard HP Pavilion g6 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.0.0-13-generic root=UUID=e1903286-a666-49b1-8177-cf31dc5c8e9f ro quiet splash vt.handoff=1
SourcePackage: xserver-xorg-input-synaptics
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/29/2013
dmi.bios.vendor: Insyde
dmi.bios.version: F.25
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 183E
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 56.32
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.25:bd05/29/2013:svnHewlett-Packard:pnHPPaviliong6NotebookPC:pvr0885120000005D10000600000:rvnHewlett-Packard:rn183E:rvr56.32:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV X=Null
dmi.product.name: HP Pavilion g6 Notebook PC
dmi.product.sku: D4Z91EA#ABV
dmi.product.version: 0885120000005D10000600000
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Sherif (ali-sherif10) wrote :
Sherif (ali-sherif10) wrote :

This is the first time this bug happen to me with any distribution.

Sherif (ali-sherif10) wrote :

I tried using the command `xinput`, so libinput might be related?
I couldn't add systemsettings5 for KDE, but added systemsettings, because it should include GUI for this.

Daniel van Vugt (vanvugt) wrote :

Does the problem happen in Gnome Shell too?

summary: - Different touchpad sensitivity
+ Touchpad vertical sensitivity is much higher than horizontal sensitivity
summary: Touchpad vertical sensitivity is much higher than horizontal sensitivity
+ [HP Pavilion g6]
Changed in libinput (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete
Sherif (ali-sherif10) wrote :

In Ubuntu 18.10, no, it doesn't happen.
I didn't try Ubuntu 19.10.

Sherif (ali-sherif10) wrote :

Maybe Synaptic driver needs to be installed for laptops that need it.

Daniel van Vugt (vanvugt) wrote :

I mean, does the problem happen in Gnome Shell in Ubuntu 19.04? To test that please try just booting it from USB:

  http://releases.ubuntu.com/19.04/

no longer affects: systemsettings (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Please also try installing some older kernel versions from here:

  https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

then reboot and as soon as the purple screen appears tap Escape. Then navigate through the menus and choose an older kernel version to boot.

Daniel van Vugt (vanvugt) wrote :

Actually if the problem existed before you installed xserver-xorg-input-synaptics then we can exclude that as a cause.

no longer affects: xserver-xorg-input-synaptics (Ubuntu)
Douglas Crooke (drcrooke) wrote :

Also have same symptoms following 19.04 upgrade.

Douglas Crooke (drcrooke) wrote :

HP Pavilion model G6-2264sa

Daniel van Vugt (vanvugt) wrote :

Someone please answer comments #7 and #8.

Douglas Crooke (drcrooke) wrote :

Re: #7 - I'm running vanilla Ubuntu on Xorg / Gnome shell.

Daniel van Vugt (vanvugt) wrote :

OK then. This sounds like a regression in vanilla Ubuntu between versions 18.10 and 19.04. Next please try installing some older kernel versions from here:

  https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

then reboot and as soon as the purple screen appears tap Escape. Then navigate through the menus and choose an older kernel version to boot.

We need to find out the last kernel version without the bug, and the first kernel version with the bug.

Douglas Crooke (drcrooke) wrote :

Using Gnome 3.32.1 on Xorg, (vanilla Ubuntu).
Current kernel 5.0.0-15-generic, same behaviour in 5.0.0-13-generic

Daniel van Vugt (vanvugt) wrote :

Ubuntu 18.10 (which does not have the bug) uses kernel version 4.18 so please start testing versions around there. If you find 4.18 fixes the bug then next please find a version roughly halfway between 4.18 and 5.0.0 ...

Douglas Crooke (drcrooke) wrote :

OK, installing old kernels seems to be beyond me at the moment, trying to install 4.20 & 4.19 following https://seagullbird.xyz/posts/how-to-install-an-older-kernel/ or some askubuntu results so far leaves me with non-booting kernels. Is there a reliable beginners guide somewhere I can follow?

Daniel van Vugt (vanvugt) wrote :

I don't know of a reliable beginners guide. The above link looks good and is what I would do.

Hi.

I have the same problem. It has appeared after updating to 19.04.

HP Pavilion model G6-2264sa

# 7 - I'm also using Ubuntu vanilla and Gnome Shell

# 8 - Using kernel 4.18.20 does not solve the problem.

Uninstalling xserver-xorg-input-libinput and installing xserver-xorg-input-synaptics does not solve the problem either.

# 20: Yes, that's it. Thank you!

The touchpad works perfectly again.

I have changed the following lines in the file /lib/udev/hwdb.d/60-evdev.hwdb:

# HP Pavilion g6
evdev: name: SynPS / 2 Synaptics TouchPad: dmi: * svnHewlett-Packard: pnHPPaviliong6 *
  EVDEV_ABS_00 = 1284: 5696: 88
  EVDEV_ABS_01 = 1287: 4838: 39
  EVDEV_ABS_35 = 1284: 5696: 88
  EVDEV_ABS_36 = 1287: 4838: 39

With the following:

# HP Pavilion g6
#evdev: name: SynPS / 2 Synaptics TouchPad: dmi: * svnHewlett-Packard: pnHPPaviliong6 *
# EVDEV_ABS_00 = 1284: 5696: 88
# EVDEV_ABS_01 = 1287: 4838: 39
# EVDEV_ABS_35 = 1284: 5696: 88
# EVDEV_ABS_36 = 1287: 4838: 39

Changed in libinput (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Sherif (ali-sherif10) wrote :

I installed Fedora 30 (64-bit) and I've the same issue.

Changed in libinput:
status: Unknown → Fix Released
affects: libinput → systemd
Daniel van Vugt (vanvugt) wrote :
Changed in systemd (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: fixed-upstream
tags: added: eoan
Kareem (sephirothgd) wrote :

This bug affects me linux wide.
Laptop: HP Pavilion G6 2209se
tried touchpad-edge-detector and it detects resolution correctly.
tried removing pre-set resolution in 60-evdev.hwdb for G6 model with no difference.
tried installing synaptics client and it detects and actually modifies the touchpad parameters normally but the issue still persists. (too high speed vertically and too low horizontally).

tried distros:
Manjaro 18.
Ubuntu 19.
Fedora 30.
Kubuntu 19 (Current).

its driving me crazy because i even tried installing the latest Manjaro 18.1.0 and it still produces the same issue.

Description of problem:
After installing Fedora 30, I found that vertical sensitivity is much higher than horizontal sensitivity.

Version-Release number: 1.14.1.

How reproducible:
Always, because I got it in Kubuntu 19.04 too.

Steps to Reproduce:
1. Install Fedora 30.

Actual results:
Vertical sensitivity is higher than horizontal sensitivity and moving the cursor horizontally is slow.

Expected results:
Vertical and horizontal touchpad speeds are proper.

Additional info:
Laptop: HP Pavilion g6.
I didn't have the problem in previous versions of distributions. I don't know exactly when it started.

Changed in libinput (Fedora):
importance: Unknown → Undecided
status: Unknown → Confirmed

please run the touchpad-edge-detector tool from the libevdev-utils package and post the output here, thanks.

How to use it? Sorry.
I tried:
$ sudo touchpad-edge-detector 40x60 /dev/input/event0
$ sudo touchpad-edge-detector 40x60 /dev/input/event1
The output was:
Error: this device does not have abs axes

I chose the size inaccurately.

you'll need to run it against the correct event node, run libinput record (libinput-utils.rpm) without arguments, it'll give you a list of devices. Pick your touchpad from that list. Note that you may have 2 touchpad kernel devices, only one of which will send events. So while libinput record is running, touch the device - if you see events scroll past that's the right event node.

Once you identified the device node, use that same event node for the touchpad-edge-detector

PRIHLOP (ilya-prihlop) wrote :

I solved this issue by the next actions:
- run the touchpad-edge-detector tool from the libevdev-utils package
in my case command is sudo touchpad-edge-detector 96x46 /dev/input/event6
- then I pasted output of previous command to file /lib/udev/hwdb.d/60-evdev.hwdb
- and apply this changes by commands
sudo systemd-hwdb update
sudo udevadm trigger /dev/input/event*
like commented in head of redacted file

And problem solved.

In my case code is:

 EVDEV_ABS_00=1261:5717:46
 EVDEV_ABS_01=1001:4907:85
 EVDEV_ABS_35=1261:5717:46
 EVDEV_ABS_36=1001:4907:85

On my notebook touchpad is rectangular and not a square.

I apologize for the late reply.
After either installing Fedora 31 or installing it followed by some updates, the problem seems to be fixed.

$ sudo touchpad-edge-detector 40x60 /dev/input/event4
Touchpad SynPS/2 Synaptics TouchPad on /dev/input/event4
Move one finger around the touchpad to detect the actual edges
Kernel says: x [1222..5734], y [910..4974]
Touchpad sends: x [2970..4853], y [1948..4009] |^C

Touchpad size as listed by the kernel: 94x42mm
User-specified touchpad size: 40x60mm
Calculated ranges: 1883/2061

Suggested udev rule:
# <Laptop model description goes here>
evdev:name:SynPS/2 Synaptics TouchPad:dmi:bvnInsyde:bvrF.25:bd05/29/2013:svnHewlett-Packard:pnHPPaviliong6NotebookPC:pvr0885120000005D10000600000:rvnHewlett-Packard:rn183E:rvr56.32:cvnHewlett-Packard:ct10:cvrChassisVersion:*
 EVDEV_ABS_00=2970:4853:47
 EVDEV_ABS_01=1948:4009:34
 EVDEV_ABS_35=2970:4853:47
 EVDEV_ABS_36=1948:4009:34

Recently, touchpad movement is slow, before login to account only.

There is a hwdb entry in systemd for the Paviliong6, but that seems to be a different device than what you have. To fix this, find the 60-evdev.hwdb file on your system, it has the instructions on what to do with this snippet. You can shorten the lookup rule a bit so you end up with this:

evdev:name:SynPS/2 Synaptics TouchPad:dmi:*svnHewlett-Packard:pnHPPaviliong6NotebookPC:*
 EVDEV_ABS_00=2970:4853:47
 EVDEV_ABS_01=1948:4009:34
 EVDEV_ABS_35=2970:4853:47
 EVDEV_ABS_36=1948:4009:34

This should take care of any pointer movement issues. Ideally you can submit this to systemd upstream as a PR, the 60-evdev.hwdb file has instructions for that too.

Thanks #29!
Works like a charm on my HP Pavilion g6 2394sr

Gael Lafond (gaellafond) wrote :

Thanks #29!
Your fix worked for me as well.

I have an old HP Pavillon g6.

I calculated my touchpad edge like so:

1. Physically measure the touchpad.
    Mine is 90mm x 50mm

2. Find the input device used for the touchpad.
    $ ll /dev/input/by-path/
    platform-i8042-serio-1-event-mouse -> ../event1

3. Run edge detector using the measurement done in step 1, on the device found in step 2
    $ sudo touchpad-edge-detector 90x50 /dev/input/event1
    Run the finger on the touchpad until the number stop changing, then hit CTRL+C

4. Edit the evdev config file
    $ sudo vim /lib/udev/hwdb.d/60-evdev.hwdb

    Comment out the whole "HP Pavillon g6" section
    Added the following lines, bellow the now commented out "HP Pavillon g6" section

    evdev:name:SynPS/2 Synaptics TouchPad:dmi:bvnInsyde:bvrF.53:bd10/24/2012:svnHewlett-Packard:pnHPPaviliong6NotebookPC:pvr0690130000204610000620100:rvnHewlett-Packard:rn3566:rvr21.3A:cvnHewlett-Packard:ct10:cvrChassisVersion:*
     EVDEV_ABS_00=1208:5767:51
     EVDEV_ABS_01=1163:4838:74
     EVDEV_ABS_35=1208:5767:51
     EVDEV_ABS_36=1163:4838:74

You-Sheng Yang (vicamo) on 2020-04-30
tags: added: hwe-touchpad

This message is a reminder that Fedora 30 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 30 on 2020-05-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '30'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 30 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

David Schoen (neerolyte) wrote :

My partners "HP Pavillon g6" started showing this issue upgrading from 19.04 -> 19.10.

Following the steps documented in 29/31 I ended up with:

evdev:name:SynPS/2 Synaptics TouchPad:dmi:bvnInsyde:bvrF.22:bd11/22/2012:svnHewlett-Packard:pnHPPaviliong6NotebookPC:pvr087A110000385B10000620100:rvnHewlett-Packard:rn183E:rvr56.32:cvnHewlett-Packard:ct10:cvrChassisVersion:*
 EVDEV_ABS_00=1266:5733:47
 EVDEV_ABS_01=1029:4944:85
 EVDEV_ABS_35=1266:5733:47
 EVDEV_ABS_36=1029:4944:85

Which fixed it.

Fedora 30 changed to end-of-life (EOL) status on 2020-05-26. Fedora 30 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Changed in libinput (Fedora):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.