Apple Magic Trackpad sensitivity too low (does not detect touches unless pressing hard)

Bug #1751190 reported by Daniel van Vugt on 2018-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libinput
Fix Released
Medium
libinput (Ubuntu)
Medium
Unassigned

Bug Description

Apple Magic Trackpad sensitivity too low (does not detect touches unless pressing hard)

WORKAROUND:
 1. sudo apt install xserver-xorg-input-synaptics
 2. Log into 'Ubuntu on Xorg' only (or just 'Ubuntu' if that option isn't listed)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libinput10 1.10.0-1
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Fri Feb 23 11:36:56 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3 Processor Integrated Graphics Controller [8086:041a] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Xeon E3-1200 v3 Processor Integrated Graphics Controller [17aa:30a1]
InstallationDate: Installed on 2017-12-12 (72 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171211)
MachineType: LENOVO 30AJS05700
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-10-generic.efi.signed root=UUID=f9fe7460-9c41-4d4a-8376-e5ceb57bbec8 ro quiet splash vt.handoff=1
SourcePackage: libinput
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/02/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: FBKTB6AUS
dmi.board.name: SHARKBAY
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50519 PRO
dmi.chassis.type: 7
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvrFBKTB6AUS:bd08/02/2015:svnLENOVO:pn30AJS05700:pvrThinkStationP300:rvnLENOVO:rnSHARKBAY:rvrSDK0E50519PRO:cvnToBeFilledByO.E.M.:ct7:cvrToBeFilledByO.E.M.:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: 30AJS05700
dmi.product.version: ThinkStation P300
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+18.04.20171116-0ubuntu1
version.libdrm2: libdrm2 2.4.90-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Daniel van Vugt (vanvugt) wrote :
Changed in libinput (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in libinput:
importance: Unknown → High
status: Unknown → Confirmed
Changed in libinput (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in libinput:
importance: High → Unknown
status: Confirmed → Unknown
Changed in libinput:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in libinput:
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Looks like the fix is still missing in 1.10.1-1

Changed in libinput (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Triaged
Daniel van Vugt (vanvugt) wrote :

In progress (fix coming in 1.10.2)

Changed in libinput (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libinput - 1.10.3-2

---------------
libinput (1.10.3-2) unstable; urgency=medium

  [ Jeremy Bicha ]
  * control: Update VCS urls.
  * control: Add more packages to libinput-dev Depends as a workaround for
    buggy meson/pkg-config. (Closes: #893067)

 -- Timo Aaltonen <email address hidden> Sun, 18 Mar 2018 15:39:44 +0200

Changed in libinput (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.