bad 'Breaks' causes natty -> oneiric upgrade failure

Bug #839098 reported by James Troup
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libindicator (Ubuntu)
Undecided
Steve Langasek

Bug Description

My natty -> oneiric upgrade failed, with the following output:

 http://paste.ubuntu.com/680120/

I whined on IRC, and slangasek told me:

<slangasek> Broken libindicator6:i386 Breaks on libindicator3 [ i386 ] < 0.3.22-0ubuntu1 -> 0.3.22-0ubuntu2 > ( universe/libs ) (<= 0.3.93-0ubuntu1)
<slangasek> Considering libindicator3:i386 10 as a solution to libindicator6:i386 5
<slangasek> Holding Back libindicator6:i386 rather than change libindicator3:i386
<slangasek> that's not good
<slangasek> libindicator6 should drop the Breaks: libindicator[123], there are no file overlaps

And I don't disbelieve him.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 0.3.93-0ubuntu2

---------------
libindicator (0.3.93-0ubuntu2) oneiric; urgency=low

  * Drop the Breaks: against old versions of libindicator and libindicator3;
    there are no file conflicts between the libraries, so this doesn't
    accurately reflect the package relationships but does make it harder to
    calculate upgrades from natty. LP: #839098.
 -- Steve Langasek <email address hidden> Thu, 01 Sep 2011 14:22:12 -0700

Changed in libindicator (Ubuntu):
status: New → Fix Released
Revision history for this message
Ted Gould (ted) wrote : Re: [Bug 839098] Re: bad 'Breaks' causes natty -> oneiric upgrade failure

On Thu, 2011-09-01 at 21:25 +0000, Launchpad Bug Tracker wrote:
> libindicator (0.3.93-0ubuntu2) oneiric; urgency=low
>
> * Drop the Breaks: against old versions of libindicator and libindicator3;
> there are no file conflicts between the libraries, so this doesn't
> accurately reflect the package relationships but does make it harder to
> calculate upgrades from natty. LP: #839098.
> -- Steve Langasek <email address hidden> Thu, 01 Sep 2011 14:22:12 -0700

The problem is that since libindicator is the interface between the
indicator loader (unity-panel-service, indicator-applet, etc.) and the
actual indicators (indicator-messages, indicator-session, etc.) you
really only want one version of that interface installed.

What ends up happening is since the indicators are installed in a
different directory depending on the ABI version, the loader won't load
them, and thus you could end up with a desktop where you couldn't log
out. Or, worse yet, easily control your music player.

In the end, if there were a "highlander" directive that we could ensure
there was only one we'd use that, but manually using Breaks is the only
solution we could come up with. It seems to me apt should be able to
handle this situation.

  --Ted

Revision history for this message
Ted Gould (ted) wrote :

Reopening as we still need to fix this.

Changed in libindicator (Ubuntu):
status: Fix Released → Confirmed
assignee: nobody → Steve Langasek (vorlon)
Revision history for this message
Steve Langasek (vorlon) wrote :

Current libindicator doesn't have any Breaks; this seems to be permanently resolved.

Changed in libindicator (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers