libindicator3-dev has incorrect path in pkg-config --cflags

Bug #803136 reported by Jason Conti on 2011-06-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libindicator (Ubuntu)
High
Ken VanDine

Bug Description

This is against libindicator3-dev in oneiric (0.3.22-0ubuntu1):

Attempting to port an indicator to gtk3 and noticed that pkg-config --cflags indicator3 yields:

-I/usr/include/libindicator-0.3

as one of the arguments, however, the headers are installed to /usr/include/libindicator3-0.3. Identical headers are also installed with libindicator-dev at the above location, and that is probably why none of the other indicators have failed to build, because they build-dep on both.

Including a patch against libindicator/indicator3.pc.in

Jason Conti (jconti) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in libindicator (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

The headers are actually installed twice, so I think the best fix for this is to not include the headers in libindicator3-dev and make it depend on libindicator-dev.

Changed in libindicator (Ubuntu):
status: Confirmed → Fix Released
Vlad Orlov (monsta) wrote :

Hi Ken,

Since this bug has been closed, the headers haven't been removed from libindicator3-dev, they're still included there.
In addition, the path in the Cflags field has been corrected just like Jason suggested, see [1].

So, now it seems there's no reason for libindicator3-dev to depend on libindicator-dev.

Can you please remove this dependency then?

(If a new bug report is needed for that, no problem - I'll file it.)

[1] http://bazaar.launchpad.net/~indicator-applet-developers/libindicator/trunk.15.04/revision/437#libindicator/indicator3-0.4.pc.in.in

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers