libindicator is not multi-arch aware

Bug #1757204 reported by Olivier Tilloy on 2018-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libindicator (Ubuntu)
Undecided
Olivier Tilloy

Bug Description

This is preventing libappindicator from becoming multi-arch aware (bug #1081938).

$ dpkg --print-architecture
amd64

$dpkg --print-foreign-architectures
i386

$ sudo apt install libindicator3-7 libindicator3-7:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libindicator3-7 : Conflicts: libindicator3-7:i386 but 16.10.0+18.04.20171205.1-0ubuntu1 is to be installed
 libindicator3-7:i386 : Conflicts: libindicator3-7 but 16.10.0+18.04.20171205.1-0ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libindicator3-7 16.10.0+18.04.20171205.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Mar 20 17:34:22 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-07-02 (625 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: libindicator
UpgradeStatus: Upgraded to bionic on 2018-01-29 (50 days ago)

Related branches

Olivier Tilloy (osomon) wrote :
Olivier Tilloy (osomon) wrote :

libindicator3-dev depends on libgtk-3-dev, and it appears it is not installable in parallel for two architectures:

$ sudo apt install libgtk-3-dev:amd64 libgtk-3-dev:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgtk-3-dev is already the newest version (3.22.28-1ubuntu3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev:i386 : Depends: libgdk-pixbuf2.0-dev:i386 (>= 2.30.0) but it is not going to be installed
                     Depends: libpango1.0-dev:i386 (>= 1.40.5) but it is not going to be installed
                     Depends: libegl1-mesa-dev:i386 but it is not going to be installed
                     Depends: libxkbcommon-dev:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Olivier Tilloy (osomon) wrote :

The issue with libgtk-3-dev is bug #1317116.

Olivier Tilloy (osomon) wrote :

Getting the -dev packages to be co-installable would require fixing libgtk-3*, but there is already value in having the library packages co-installable.

Changed in libindicator (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → In Progress
Juhani Numminen (jsonic) on 2018-12-27
tags: added: multiarch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers