Use cli-common-dev packaging helpers

Bug #832222 reported by Iain Lane on 2011-08-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libindicate (Ubuntu)
Undecided
Unassigned

Bug Description

libindicate doesn't use cli-common-dev's packaging helpers. Observe the empty Depends

  (oneiric-amd64)root@raleigh:~# apt-cache show libindicate0.1-cil | grep Depends
  (oneiric-amd64)root@raleigh:~#

  (oneiric-amd64)root@raleigh:~# apt-cache show libindicate-gtk0.1-cil | grep Depends
  Depends: libindicate0.1-cil (= 0.5.91-0ubuntu1)

This is because it doesn't call dh_clideps during the build.

Also, there's no clilibs. This means that CLI applications linking against
libindicate*cil won't get a correct dependency. Ths is because it doesn't call
dh_makeclilibs. Attached is a debdiff to fix that:

  laney@raleigh> dpkg --info libindicate0.1-cil_0.5.91-0ubuntu2_all.deb | grep Depends
  Depends: cli-common (>= 0.5.1), libglib2.0-cil (>= 2.12.10-1ubuntu1),
  libindicate5 (>= 0.4.90), libmono-corlib4.0-cil (>= 2.10.1)

  laney@raleigh> dpkg --info libindicate0.1-cil_0.5.91-0ubuntu2_all.deb | grep Depends
  Depends: cli-common (>= 0.5.1), libglib2.0-cil (>= 2.12.10-1ubuntu1),
  libindicate5 (>= 0.4.90), libmono-corlib4.0-cil (>= 2.10.1)

They also have clilibs now too.

Cheers.

Iain Lane (laney) wrote :
Changed in libindicate (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

I forgot to close the bug in the changelog. Please add that for me, dear sponsor :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicate - 0.5.91-0ubuntu2

---------------
libindicate (0.5.91-0ubuntu2) oneiric; urgency=low

  * debian/rules: Call dh_cli* helpers so we get correct dependencies and
    generate clilibs. (LP: #832222)
 -- Iain Lane <email address hidden> Thu, 25 Aug 2011 11:58:58 +0200

Changed in libindicate (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers