conversation window stays in background after selecting incoming message in indicator-applet

Bug #442389 reported by Janne Hyötylä on 2009-10-04
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libindicate (Ubuntu)
Low
Rick Spencer

Bug Description

Binary package hint: empathy

Steps to reproduce:
* Start a conversation with somebody over Empathy
* Focus some other window, wait until other party responds
* Click on the incoming message in indicator-applet to show the new message

What happens:
Empathy conversation window flashes in task list, but stays in background

What should happen:
The conversation window should be focused, since this is what the user specifically requested

This happens with metacity and compiz, so is not a window manager problem.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 4 18:48:48 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: empathy
Uname: Linux 2.6.31-11-generic i686

Janne Hyötylä (janne-hyotyla) wrote :
affects: empathy (Ubuntu) → indicator-applet (Ubuntu)
Ted Gould (ted) on 2009-10-07
affects: indicator-applet (Ubuntu) → empathy (Ubuntu)
Nicolò Chieffo (yelo3) wrote :

I marked "regression-potential" because pidgin works well in this scenario

tags: added: regression-potential
affects: empathy (Ubuntu) → indicator-applet (Ubuntu)
Pedro Villavicencio (pedro) wrote :

confirming same issue here

Changed in indicator-applet (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Ted Gould (ted) on 2009-10-26
affects: indicator-applet (Ubuntu) → empathy (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in empathy (Ubuntu):
status: Confirmed → Invalid
status: Invalid → New
affects: empathy (Ubuntu) → indicator-applet (Ubuntu)
Sebastien Bacher (seb128) wrote :

Ted, that doesn't happen in upstream empathy and seems an issue on how you call it there

Sebastien Bacher (seb128) wrote :
Ken VanDine (ken-vandine) wrote :

Changing this to libindicate. libindicate will need to send timestamps.

affects: indicator-applet (Ubuntu) → libindicate (Ubuntu)
Changed in libindicate (Ubuntu):
assignee: nobody → Rick Spencer (rick-rickspencer3)
Changed in libindicate (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
Sebastien Bacher (seb128) wrote :

libindicate use timestamps now which should fix the issue, let me know if you still get the issue but closing for now

Changed in libindicate (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers