lucid and maverick are incompatible with latest iOS

Bug #793616 reported by Marc Deslauriers on 2011-06-06
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libimobiledevice (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Marc Deslauriers
Maverick
Undecided
Marc Deslauriers
Natty
Undecided
Unassigned

Bug Description

A 3G iPod Touch was upgraded from iOS 4.0.1 to 4.3.3, and stopped working with rhythmbox and gtkpod in Lucid.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: libimobiledevice0 0.9.7-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-32.62-generic-pae 2.6.32.38+drm33.16
Uname: Linux 2.6.32-32-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Jun 6 11:53:17 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: libimobiledevice

Marc Deslauriers (mdeslaur) wrote :
Changed in libimobiledevice (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in libimobiledevice (Ubuntu Lucid):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in libimobiledevice (Ubuntu Maverick):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in libimobiledevice (Ubuntu Lucid):
status: New → Confirmed
Changed in libimobiledevice (Ubuntu Maverick):
status: New → Confirmed
Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact of the issue: Lucid and Maverick users that update the firmware of their iPod Touch and iPhone devices can no longer access them in Lucid and Maverick.

This issue was resolved by backporting a couple of minimal changes from the upstream tree. These fixes already ship in Natty. See attached debdiffs for Lucid and Maverick.

I tested this update on Lucid with gtkpod and rhythmbox on an iPod Touch still running 4.0.1, and an iPod Touch that had been upgraded to 4.3.3. The updated packages solved the issue for the new iOS version, while maintaining compatibility with the old one.

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Changed in libimobiledevice (Ubuntu Natty):
status: New → Fix Released
Changed in libimobiledevice (Ubuntu):
status: New → Fix Released
assignee: Marc Deslauriers (mdeslaur) → nobody

Accepted libimobiledevice into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libimobiledevice (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in libimobiledevice (Ubuntu Maverick):
status: Confirmed → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Accepted libimobiledevice into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Geir Ove Myhr (gomyhr) wrote :

I have tested 0.9.7-1ubuntu1.1, and now my iPhone (with iOS 4.2.1) is detected. It wasn't before upgrading from 0.9.7-1ubuntu1.

Martin Pitt (pitti) on 2011-07-14
tags: added: verification-done verification-done-lucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libimobiledevice - 0.9.7-1ubuntu1.1

---------------
libimobiledevice (0.9.7-1ubuntu1.1) lucid-proposed; urgency=low

  * Add compatibility for iOS 4.2 and 4.3. This doesn't add new device
    support, it only maintains support for devices which were updated to
    the new firmware. (LP: #793616)
    - debian/patches/04-ios-42-compat.patch: Fix compatibility with iOS
      4.2 by passing a cert in the handshake.
    - debian/patches/05-ios-43-compat.patch: Fix compatibility with iOS
      4.3 by handling invalid null characters in the plist.
 -- Marc Deslauriers <email address hidden> Mon, 06 Jun 2011 12:31:24 -0400

Changed in libimobiledevice (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Adjusting verification tags to point out that maverick still needs testing.

tags: removed: verification-done
Marc Deslauriers (mdeslaur) wrote :

I've just tested this on a clean maverick install. iPod touch with iOS 4.3.3 gave an error when plugged in without the update. After installing the package in proposed, it mounts correctly and music and photos are visible.

tags: added: verification-done
removed: verification-done-lucid verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libimobiledevice - 1.0.1-1ubuntu0.1

---------------
libimobiledevice (1.0.1-1ubuntu0.1) maverick-proposed; urgency=low

  * Add compatibility for iOS 4.2 and 4.3. This doesn't add new device
    support, it only maintains support for devices which were updated to
    the new firmware. (LP: #793616)
    - debian/patches/04-ios-42-compat.patch: Fix compatibility with iOS
      4.2 by passing a cert in the handshake.
    - debian/patches/05-ios-43-compat.patch: Fix compatibility with iOS
      4.3 by handling invalid null characters in the plist.
 -- Marc Deslauriers <email address hidden> Mon, 06 Jun 2011 12:31:59 -0400

Changed in libimobiledevice (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in libimobiledevice (Ubuntu):
assignee: nobody → Josh Williams (ijoshmobile)
Changed in libimobiledevice (Ubuntu):
assignee: Josh Williams (ijoshmobile) → nobody
barry allen (doom-tech2099) wrote :

update libimobiledevice from your package manager and restart your computer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers