iPhone no longer mounting after iOS 4.2 upgrade

Bug #685752 reported by Miguel Mendes Ruiz on 2010-12-06
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
libimobiledevice (Ubuntu)
Undecided
Unassigned

Bug Description

While trying to mount my IPhone I getDBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

As related in http://ubuntuforums.org/showthread.php?t=1628529 : in libimobiledevice's place, they say they have support for 4.2.1 devices with their 1.0.4 release, this version is shipped in the PPA https://launchpad.net/~pmcenery/+archive/ppa and it seems to work with iOS 4.2 also according to the thread.

Miguel Mendes Ruiz (migmruiz) wrote :

As stated in http://ubuntuforums.org/showthread.php?t=1628529 , specifically in
http://ubuntuforums.org/showpost.php?p=10182217&postcount=24 and
http://ubuntuforums.org/showpost.php?p=10205459&postcount=32 :

To do what fallows you need libimobiledevice-utils installed, if you don't have it

    sudo apt-get install libimobiledevice-utils

DodgeV83 ( http://ubuntuforums.org/member.php?u=547250 ) said, and it is also true for me
The PPA by itself didn't work for me. I then had to run:

   idevicepair unpair
   idevicepair pair
   idevicepair validate

Got the answer from the following Bug Reports

http://libiphone.lighthouseapp.com/projects/27916/tickets/183-cannon-mount-iphone-with-ios-421-in-ubuntu-1010#ticket-183-13

http://libiphone.lighthouseapp.com/projects/27916/tickets/181-cant-mount-iphone-in-ios-421#ticket-181-10

Changed in libimobiledevice (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers