Unable to mount iPad with IOS 8

Bug #1385882 reported by manfreed
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
libimobiledevice (Ubuntu)
High
Unassigned

Bug Description

I can't mount my iPad after I upgraded to IOS 8. After plugging in I get a series of error messages, also my iPad keep asking wether I trust my computer.

I get messages like:
Unable to mount ...'s iPad: Location is already mounted - (it's not)
Unable to mount iPhone: Unhandled lockdown error (-3) (also sometimes -20)

If I remember correctly this happened last year after I upgraded to iOS 7.

The problem exists in Utopic too.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libimobiledevice4 1.1.5+git20140313.bafe6a9e-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Oct 26 14:36:14 2014
InstallationDate: Installed on 2014-01-10 (288 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: libimobiledevice
UpgradeStatus: Upgraded to trusty on 2014-04-10 (198 days ago)

Revision history for this message
manfreed (manfreed) wrote :
tags: added: utopic
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libimobiledevice (Ubuntu):
status: New → Confirmed
Changed in libimobiledevice (Ubuntu):
importance: Undecided → High
Revision history for this message
Max Barry (max-maxbarry) wrote :

Also occurs with iPhone 6 running iOS 8.1.2 (not just iPad).

After plugging in my phone, I get two icons in the sidebar: "<My name>'s iPhone" and "iPhone." They look identical and offer the same right-click menu choices ("Open", "<Name>", "Unlock from launcher"). Only the first one works, though: when clicked, the file browser opens and displays the contents of the phone, and the sidebar menu gains a new right-click option "Unmount." The second icon ("iPhone") seems completely inert.

So the error doesn't seem to prevent the phone from being mounted, but something's not quite right.

Revision history for this message
paul scarbro (paulrscarbro) wrote :

I concur with Max Barry. I too have the same issue. I wonder if Max has attempted to copy data to the phone? I am able to use Banshee to copy tracks across but they cannot yet be recognised by the phone! It's bound to be a small coding issue as the phone is mounted, tracks can be copied - yet not recognised.

Any ideas?

Revision history for this message
dave wy (davewy) wrote :

I am getting the same errors as the original description, as well as the issues described by Max Barry. Happening for me with an iPhone 5S with iOS 8.1.2, with Ubuntu 14.04 on the host. Any ideas or progress on this issue?

Revision history for this message
nam1962 (amauryat) wrote :

One just has to first unlock the iDevice and then to plug on USB & to allow the computer.
Tutorial there : http://dolys.fr/forums/topic/tuto-iphone-ubuntu-erreur-de-verrouillage-non-geree-20/

Revision history for this message
Francois Botha (francoisbotha2) wrote :

I'm afraid it's not that simple. Unlocking the phone has been tried and it doesn't work.

Revision history for this message
Albert (sapristi) wrote :

I confirm the same errors occur with iPhone4s and iOS 8.2, ubuntu 14.04.

After installing the ppa for libimobiledevice 1.6, I manage to sometimes, inconsistently, be able to mount the phone and transfer files (e.g. pictures from the DCIM folder). The sequence that has worked (sometimes) is the following:

1. write "sudo idevicepair pair" to a terminal and push enter. Enter your password. The phone is not plugged yet so nothing happens.
2. push the up arrow to have the above command ready for execution.
3. make sure the phone is unlocked (that is, you can click on apps, etc.)
4. plug the phone
5. push enter quickly
6. Select "Trust" in the popup that shows in the phone.
7. Sometimes, you will get the phone mounted. Copy files. Make sure the phone doesn't lock up from lack of activity or the file transfer will be interrupted (happened at least once).

So: brittle, but it can work.

Would be lovely if this could be made robust. Thanks a lot to the authors of the libimobiledevice library.

Revision history for this message
woodstonelee (muyanzi721) wrote :

download deb file of latest version of libimobiledevice from http://www.libimobiledevice.org/ and installed it on my ubuntu. It says supporting ios8. But now no response when I plug in my iphone. Help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions