libidn11 is not compiled as PIC

Bug #24314 reported by Esteve Fernandez
4
Affects Status Importance Assigned to Milestone
libidn (Ubuntu)
Medium
Matthias Klose

Bug Description

I was prelinking my laptop, after the upgrade from hoary to breezy, when I
noticed that prelink is no longer able to make its magic on KDE (among other
packages).

The root cause is that prelink complains that libidn is not compiled as PIC:

Prelinking /usr/bin/amarok
/usr/sbin/prelink.bin: /usr/bin/amarok: Cannot prelink against non-PIC shared
library /usr/lib/libidn.so.11
Prelinking /usr/bin/k3b
/usr/sbin/prelink.bin: /usr/bin/k3b: Cannot prelink against non-PIC shared
library /usr/lib/libidn.so.11
...

and so on.

In fact, there are many other packages depending on libidn and affected by this
issue. However, the startup time (the reason to prelink is to reduce the number
of reallocations in shared libraries) is most noticeable on KDE.

I compiled libidn11 from sources and everything is being prelinked again:

Prelinking /usr/bin/amarok
Prelinking /usr/bin/k3b
...

This is not a serious bug, but a wish, since everything runs ok.

Colin Watson (cjwatson)
Changed in libidn:
assignee: kamion → nobody
Revision history for this message
Matthias Klose (doko) wrote :

compiled with -fPIC, at least the version 1.0-0, which will enter gutsy (7.10)

Changed in libidn:
assignee: nobody → doko
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.