don't crash on incorrect values or errors

Bug #368508 reported by Sebastien Bacher on 2009-04-28
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libical (Ubuntu)
Wishlist
Unassigned
Jaunty
Wishlist
Ubuntu Desktop Bugs

Bug Description

There is lot of evolution crashes since evolution uses the system libical rather than a copy, upstream recommend building libical using --disable-icalerrors-are-fatal since that's what the copy was doing and it would lead to error and not evolution crashers

Related branches

Sebastien Bacher (seb128) wrote :
Changed in libical (Ubuntu Jaunty):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Confirmed
Changed in libical (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted libical into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libical (Ubuntu Jaunty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Bob (bbrazie) wrote :

Will this be available as an automatic install soon? (a lot of steps and decisions to make that aren't fully understood by new users)

Tim Gilbert (knaak) wrote :

I did not try the -proposed libical, but I did apply the patch presented by Kib Reed:

https://bugs.launchpad.net/ubuntu/jaunty/+source/evolution-exchange/+bug/353187/comments/10

This solved my problem which was very similar (same) as this ticket.

My only question is once Martin's patch makes it from proposed to release, will I get that release or will Kib's patch stay installed? I usually just wait for the patches to be released, this is my first time having to apply a patch myself so I am not sure about this.

Bob [2009-04-29 14:32 -0000]:
> Will this be available as an automatic install soon?

Yes, but only after we received some confirmation from testers that
the proposed update fixes the problem and does not cause regressions.

Bob (bbrazie) wrote :

Thanks Martin, I will be waiting. <g>

On Thu, 2009-04-30 at 06:47 +0000, Martin Pitt wrote:

> Bob [2009-04-29 14:32 -0000]:
> > Will this be available as an automatic install soon?
>
> Yes, but only after we received some confirmation from testers that
> the proposed update fixes the problem and does not cause regressions.
>

Bob (bbrazie) wrote :

Has the fix been released yet as I am still having the problem and see nothing new in the update of 9.04.
Thanks, Bob.

Martin Pitt (pitti) wrote :

Bob, no, because still nobody reported back about testing the proposed package. Maybe you can do that and say how it works for you?

Bob (bbrazie) wrote :

Is there some automated way to try the fix? I am rather new to this and am not comfortable working with commands and the terminal. A nubee if you will. <g>

Thanks in advance. Bob.

Luke Anderson (lynysys) wrote :

@Bob:
As Martin said, you need to first enable the proposed repository (https://wiki.ubuntu.com/Testing/EnableProposed).
Afterwards, the following commands will install Martins version of the libical0 library:-

sudo apt-get update
sudo aptitude -t jaunty-proposed install libical0

@Martin and other watchers of this bug:-
FIX CONFIRMED here - Clicking onto calendar button no longer crashes evolution.

Luke Anderson (lynysys) wrote :

@Bob, please ignore the above comment and please copy and paste the following exact three lines into the terminal, enter your user password (Not root password) when asked:-

echo "deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed restricted main multiverse universe" | sudo tee -a /etc/apt/sources.list

sudo apt-get update

sudo aptitude -t jaunty-proposed install libical0

Please let me know if you need any assistance beyond the above (The terminal is under Applications > Accessories)

Bob (bbrazie) wrote :

Thanks but what did I do wrong?

bob@bob-laptop:~$ echo "deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed
restricted
> main multiverse universe" | sudo tee -a /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed restricted
main multiverse universe
bob@bob-laptop:~$ sudo apt-get update
E: Type 'main' is not known on line 59 in source list /etc/apt/sources.list
bob@bob-laptop:~$ sudo aptitude -t jaunty-proposed install libical0
E: Type 'main' is not known on line 59 in source list /etc/apt/sources.list
E: Type 'main' is not known on line 59 in source list /etc/apt/sources.list
E: The list of sources could not be read.
E: Type 'main' is not known on line 59 in source list /etc/apt/sources.list
E: The list of sources could not be read.
bob@bob-laptop:~$

--

On Tuesday 12 May 2009 15:30:26 Luke Anderson wrote:
> @Bob, please ignore the above comment and please copy and paste the
> following exact three lines into the terminal, enter your user password
> (Not root password) when asked:-
>
> echo "deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed restricted
> main multiverse universe" | sudo tee -a /etc/apt/sources.list
>
> sudo apt-get update
>
> sudo aptitude -t jaunty-proposed install libical0
>
> Please let me know if you need any assistance beyond the above (The
> terminal is under Applications > Accessories)

Tim Gilbert (knaak) wrote :

Sorry I haven't been able to test the proposed. Paying job has been brutal with the hours this week. :)

I installed the proposed libical0 package, dpkg -s libical0 reports:

tim@tim-laptop:/var/log$ dpkg -s libical0
Package: libical0
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 712
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: amd64
Source: libical
Version: 0.43-2ubuntu1
Depends: libc6 (>= 2.4), tzdata
Description: iCalendar library implementation in C (runtime)
 libical is an open source implementation of the IETF's iCalendar calendaring
 and scheduling protocols (RFC 2445, 2446, and 2447). It parses iCal components
 and provides a C API for manipulating the component properties, parameters,
 and subcomponents.
 .
 This package contains the files necessary for running applications that use
 the libical library.
Homepage: http://freeassociation.sourceforge.net
Original-Maintainer: Fathi Boudra <email address hidden>

Please confirm I have the correct version info as I had installed the patch earlier.

If I have the expected version, I can confirm that the 'crash' of calendar updates no longer occurs and that the calendar is now updating properly. I will need more time to thoroughally check for any other unintended side-effects.

Bob, you can look in teh file /etc/apt/sources.list and email it to me (<email address hidden>) and I will try to tell you what went wrong.

Tim

Luke Anderson (lynysys) wrote :

@Bob:
First, to fix this error type:-
sudo sed -ie "s/^\s*main.*$//g" /etc/apt/sources.list

It is important that the first line you type is all on one line (I think that launchpad may have cut it in half), instead type these four lines but make sure that you DONT SPLIT ANY OF THE LINES (Each time there is a new line the Terminal reads that as a new command).

# LINE 1
SRCLINE="deb http://archive.ubuntu.com/ubuntu/ jaunty-proposed restricted main multiverse universe"
# ^^^^ ALL ON ONE LINE!!! ^^^^

# LINE 2
echo "$SRCLINE" | sudo tee -a /etc/apt/sources.list

# LINE 3
sudo apt-get update

# LINE 4
sudo aptitude -t jaunty-proposed install libical0

Also my apologies, I should have anticipated this.

Luke Anderson (lynysys) wrote :

/me just thought to maybe tell about the end of line terminator "\" but don't want to confuse the issue further :(

Martin Pitt (pitti) on 2009-05-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libical - 0.43-2ubuntu1

---------------
libical (0.43-2ubuntu1) jaunty-proposed; urgency=low

  * rules:
    use -DICAL_ERRORS_ARE_FATAL=false since those lead to quite some evolution
    hangs and crashes where those should be warnings (lp: #368508)

 -- Sebastien Bacher <email address hidden> Tue, 28 Apr 2009 12:18:54 +0200

Changed in libical (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to karmic as well

Changed in libical (Ubuntu):
status: Confirmed → Fix Released
Bob (bbrazie) wrote :

OK all went well, with the install that is. Thanks for the lesson on using one
full line in terminal. I am always open to learning.
Now for the calendar: It worked better before even though it froze when saving
reoccurring events. <g>
Now if I create one and save all instances it does not show up in the yearly
dates I set it for. Reoccurring every 10 years it does not show in the
upcoming years.
I can try to delete all instances and it does not even delete the one. It will
delete the one instance though.
I can change the text and try so save the changes in all occurrences but when
I open it again the changes are not saved.
If I change anything in the text three times and save all instances each time
it freezes and a force quite is required.
This is too bad as I really like this small compact application but I do need
reoccurring events to work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers