[21.10 FEAT] libica: make software fallback call to openSSL/libcrypto

Bug #1929176 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
libica (Ubuntu)
Fix Released
Undecided
Skipper Bug Screeners

Bug Description

In libica, eliminate implementations of SW fallback functions and replace them by calls to openSSL/libcrypto.
Note this may require adaptation of ibmca: ibmca must disable libica SW fallbacks when calling libica but rather trigger SW fall backs in openSSL directly.

dev: requires code changes in libica, may also required adaptation of ibmca
test: run regression tests for libica and ibmca
perf: n/a
id: n/a

Available with libica 3.8.0

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-192837 severity-high targetmilestone-inin2110
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
affects: linux (Ubuntu) → libica (Ubuntu)
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
importance: Undecided → High
status: New → Triaged
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Triaged → Fix Released
Changed in libica (Ubuntu):
status: New → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-08-09 06:16 EDT-------
Remark: Corresponding LP#1929176 is marked as duplicate of LP#1928799 in Canonical Lauchpad.

fix available with libica 3.8.0 which is included in Impish / U21.10, hence closing.
Status: ->CLOSED

Frank Heimes (fheimes)
information type: Private → Public
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers