Decoding/rendering breaks sometimes when seeking from the mediaplayer-app

Bug #1234207 reported by Jim Hodapp on 2013-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libhybris (Ubuntu)
Critical
Jim Hodapp

Bug Description

The decoding/rendering of hardware accelerated video playback breaks after seeking too fast or after several seeks. The issue lives in the media_compat_layer.cpp and has to do with running out of valid output buffers to decode raw frames into.

This has been verified for both maguro and mako devices.

You should be able to seek through the video as fast and as often as you desire.

Jim Hodapp (jhodapp) on 2013-10-02
Changed in libhybris (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
Michael Frey (mfrey) wrote :

I can confirm this happens on a mako device.

Changed in libhybris (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libhybris - 0.1.0+git20130606+c5d897a-0ubuntu32

---------------
libhybris (0.1.0+git20130606+c5d897a-0ubuntu32) saucy; urgency=low

  * 0032-Make-the-decoding-rendering-loop-much-more-robust.-F.patch:
    - Making the decoding/rendering loop more robust by releasing
      the output buffers in case the hal call fails (LP: #1234207)
 -- Ricardo Salveti de Araujo <email address hidden> Wed, 02 Oct 2013 22:48:24 -0300

Changed in libhybris (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers