Sync libhibernate3-java 3.3.2.GA-2 (universe) from Debian unstable (main)

Bug #595864 reported by Angel Abad on 2010-06-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libhibernate3-java (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync libhibernate3-java 3.3.2.GA-2 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:

The ubuntu chages was

"debian/control: Can't build with a jdk 1.6, so it needs an explicit
java-gcj-compat-dev build-dependency rather than default-jdk"

Now debian package build depends on gcj-jdk what provides java-gcj-compat-dev

The debian package compiles well in maverick pbuilder.

Thanks!

Changelog entries since current maverick version 3.3.1.GA+dak1-3ubuntu1:

libhibernate3-java (3.3.2.GA-2) unstable; urgency=low

  * Switch to gcj-jdk.
  * Add encoding attribute to javadoc task.
  * Switch to source format 3.0.
  * Update Standards-Version: 3.8.4.

 -- Torsten Werner <email address hidden> Tue, 13 Apr 2010 00:12:28 +0200

libhibernate3-java (3.3.2.GA-1) unstable; urgency=low

  * New upstream release.
    - Drop asm.diff and cglib.diff: merged upstream
  * Update my email address
  * Build-Depends on debhelper (>= 7)
  * Build-Depends on libcglib-java instead of libcglib2.1-java
    - libcglib-java now provide cglib 2.2
  * Build-Depends on libasm3-java instead of libasm-java

 -- Damien Raude-Morvan <email address hidden> Thu, 08 Oct 2009 22:21:14 +0200

libhibernate3-java (3.3.1.GA+dak1-5) unstable; urgency=low

  * Fix the installation of the jar file. (Closes: #545643)

 -- Torsten Werner <email address hidden> Tue, 08 Sep 2009 22:23:16 +0200

libhibernate3-java (3.3.1.GA+dak1-4) unstable; urgency=low

  [ Torsten Werner ]
  * Set nowarn="true" in javac task in debian/build.xml.
  * Add asm to DEB_JARS in debian/rules.

  [ Damien Raude-Morvan ]
  * Add myself as Uploaders
  * Build with java-gcj-compat-dev instead of default-jdk (OpenJDK-6) as
    Hibernate FTBFS with JDBC4 API. (Closes: #543085)
    <http://opensource.atlassian.com/projects/hibernate/browse/HHH-2412>
  * Bump Standards-Version to 3.8.3:
    - Move to "java" section of Debian archive
    - Move debian/README.Debian-source to debian/README.source
    - Describe quilt patch system in debian/README.source
  * debian/control:
    - Move ant and java-gcj-compat-dev to B-D-I (needed for clean target)
    - Fix Vcs-Svn field (use svn access instead of svn+ssh)
    - Add ${misc:Depends} for every binary package
  * debian/copyright:
    - Update copyright years
    - Update files locations regarding upstream tarball
    - Use LGPL-2.1 instead of LGPL symlink
  * Javadoc API:
    - Install Javadoc API to /usr/share/doc/libhibernate3-java/api/
    - Register with doc-base

 -- Damien Raude-Morvan <email address hidden> Mon, 31 Aug 2009 21:48:32 +0200

Benjamin Drung (bdrung) on 2010-06-18
Changed in libhibernate3-java (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libhibernate3-java - 3.3.2.GA-2

---------------
libhibernate3-java (3.3.2.GA-2) unstable; urgency=low

  * Switch to gcj-jdk.
  * Add encoding attribute to javadoc task.
  * Switch to source format 3.0.
  * Update Standards-Version: 3.8.4.

libhibernate3-java (3.3.2.GA-1) unstable; urgency=low

  * New upstream release.
    - Drop asm.diff and cglib.diff: merged upstream
  * Update my email address
  * Build-Depends on debhelper (>= 7)
  * Build-Depends on libcglib-java instead of libcglib2.1-java
    - libcglib-java now provide cglib 2.2
  * Build-Depends on libasm3-java instead of libasm-java

libhibernate3-java (3.3.1.GA+dak1-5) unstable; urgency=low

  * Fix the installation of the jar file. (Closes: #545643)

libhibernate3-java (3.3.1.GA+dak1-4) unstable; urgency=low

  [ Torsten Werner ]
  * Set nowarn="true" in javac task in debian/build.xml.
  * Add asm to DEB_JARS in debian/rules.

  [ Damien Raude-Morvan ]
  * Add myself as Uploaders
  * Build with java-gcj-compat-dev instead of default-jdk (OpenJDK-6) as
    Hibernate FTBFS with JDBC4 API. (Closes: #543085)
    <http://opensource.atlassian.com/projects/hibernate/browse/HHH-2412>
  * Bump Standards-Version to 3.8.3:
    - Move to "java" section of Debian archive
    - Move debian/README.Debian-source to debian/README.source
    - Describe quilt patch system in debian/README.source
  * debian/control:
    - Move ant and java-gcj-compat-dev to B-D-I (needed for clean target)
    - Fix Vcs-Svn field (use svn access instead of svn+ssh)
    - Add ${misc:Depends} for every binary package
  * debian/copyright:
    - Update copyright years
    - Update files locations regarding upstream tarball
    - Use LGPL-2.1 instead of LGPL symlink
  * Javadoc API:
    - Install Javadoc API to /usr/share/doc/libhibernate3-java/api/
    - Register with doc-base
 -- Angel Abad <email address hidden> Tue, 13 Apr 2010 00:12:28 +0200

Changed in libhibernate3-java (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers