haml-elisp incompatible with xemacs21: !! Wrong number of arguments ((require 3))

Bug #784185 reported by Xeno Campanoli on 2011-05-17
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libhaml-ruby (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libhaml-ruby

Just trying to get this off. It keeps failing.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: haml-elisp 3.0.15-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Tue May 17 10:13:48 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
PackageArchitecture: all
SourcePackage: libhaml-ruby
Title: package haml-elisp 3.0.15-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-05-02 (15 days ago)

Xeno Campanoli (xeno) wrote :
Xeno Campanoli (xeno) wrote :

xc

era (era) wrote :

Quoting the attached DpkgTerminalLog.gz:
> Compiling /usr/share/xemacs21/site-lisp/haml-elisp/haml-mode.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haml-elisp/haml-mode.el:
> !! Wrong number of arguments ((require 3))
> >>Error occurred processing haml-mode.el:
> Wrong number of arguments: require, 3
>
>
> Compiling /usr/share/xemacs21/site-lisp/haml-elisp/sass-mode.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haml-elisp/sass-mode.el:
> !! Wrong number of arguments ((require 3))
> >>Error occurred processing sass-mode.el:
> Wrong number of arguments: require, 3

haml-elisp appears to be incompatible with xemacs21. The fix is not too hard, but should be taken upstream. In the meantime, if you can get by without xemacs21, it should continue to work with GNU emacs (at least emacs23, I hope).

summary: - package haml-elisp 3.0.15-1 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ haml-elisp incompatible with xemacs21: !! Wrong number of arguments
+ ((require 3))
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libhaml-ruby (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers