weather doesn't show forecast anymore

Bug #367291 reported by Tom on 2009-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgweather (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-applets

Weather Report 2.26.0 no longer has a tab to read the future forecast. Prior to Ubuntu 9.04 I could select my city (Saginaw, Michigan, USA) and then was able to select MBS or another sub-location. These sub-locations are no longer there. I also had three tabs; Current Conditions, Forecast, Radar Map. The Forecast tab is no longer showing up. And last of all, nothing shows when selecting Radar Map, just a empty window. When I press the Update button it redisplays an empty window. This used to be a very useful applet but now shows only the current conditions.

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ apt-cache policy gnome-applets
gnome-applets:
  Installed: 2.26.0-0ubuntu4
  Candidate: 2.26.0-0ubuntu4
  Version table:
 *** 2.26.0-0ubuntu4 0
        500 http://us.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, there is probably no forecast informations for this location, that's not a software bug

Changed in gnome-applets (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid

First, the location that I want, MBS, is no longer there. Second, I have
used this application in Ubuntu 8.04 and 8.10 and the forecast and radar
map always worked before. It only stopped working on Ubuntu 9.04 which
is now using Gnome 2.26. Under Ubuntu 8.10 I was using Weather Report
2.24.1 which ran perfectly and I could select North America -> United
States -> Michigan -> Saginaw -> MBS and get the Forecast and Radar Map.
Now with Weather Report 2.26.0 my location is no longer there to select
and picking just North America -> United States -> Michigan -> Saginaw
does NOT give me the Forecast nor Radar Map.

On Sun, 2009-04-26 at 17:26 +0000, Sebastien Bacher wrote:
> Thank you for your bug report, there is probably no forecast
> informations for this location, that's not a software bug
>
> ** Changed in: gnome-applets (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: gnome-applets (Ubuntu)
> Status: New => Invalid
>
> ** Changed in: gnome-applets (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>

Sebastien Bacher (seb128) wrote :

could you try on hardy or intrepid if that's still working on the same location? trying with san francisco for example displays forecast correctly

Tom (ttwaro) wrote :

Thanks for checking to this but, YES, MBS International Airport shows up
as a selectable location under Weather Report 2.24.1 and I can get the
forecast AND radar map.

Also, Weather Report 2.26.0 DOES show the forecast and radar map for San
Francisco.

As I said initially, there used to be two additional locations under
Saginaw, MBS was one and another airport that I can't remember was the
other. Now neither one is showing up to select. I believe that is where
the problem is. If MBS was placed back in the "database" then I bet I
would have the forecast and radar map again.

ps: I tried Detroit, Michigan and it works also.

Sebastien Bacher wrote:
> could you try on hardy or intrepid if that's still working on the same
> location? trying with san francisco for example displays forecast
> correctly
>

--

http://www.thetwaros.com
Registered Linux User #466934
http://counter.li.org/

affects: gnome-applets (Ubuntu) → libgweather (Ubuntu)
Changed in libgweather (Ubuntu):
importance: Low → Wishlist
status: Invalid → New
Sebastien Bacher (seb128) wrote :

how many citizen do you have in your city? See http://live.gnome.org/LibGWeather/ImprovingLocations about how locations are handled, upstream decide to add only major cities, the request should be opened on bugzilla.gnome.org

Tom (ttwaro) wrote :
Download full text (4.1 KiB)

I understand that you can't have every single town in the world in the
database. I ran

svn co http://svn.gnome.org/svn/libgweather/trunk libgweather

to see what is there.

 From what I see it is NOT a database issue. My town, and more
importantly MBS International Airport, is still listed in the database.
The Weather Report program has been changed so that I can no longer
select it. I can only select the higher level town, Saginaw.

The difference I see between 2.24.1 and 2.26.0 is that Weather Report no
longer allows one to select a sub-location like it use to. Take San
Diego for instance:

         <city>
           <!-- A city in California in the United States -->
           <_name>San Diego</_name>
           <coordinates>32.715329 -117.157255</coordinates>
           <location>
             <name>San Diego International-Lindbergh Field</name>
             <code>KSAN</code>
             <zone>CAZ043</zone>
             <radar>lax</radar>
             <coordinates>32.733611 -117.183056</coordinates>
           </location>
           <location>
             <name>San Diego, North Island, Naval Air Station</name>
             <code>KNZY</code>
             <radar>lax</radar>
             <coordinates>32.690833 -117.208889</coordinates>
           </location>
           <location>
             <name>Montgomery Field</name>
             <code>KMYF</code>
             <zone>CAZ043</zone>
             <radar>lax</radar>
             <coordinates>32.814444 -117.136389</coordinates>
           </location>
           <location>
             <name>Miramar MCAS / Mitscher Field Airport</name>
             <code>KNKX</code>
             <zone>CAZ043</zone>
             <radar>lax</radar>
             <coordinates>32.868333 -117.142500</coordinates>
           </location>
           <location>
             <name>San Diego / El Cajon, Gillespie Field Airport</name>
             <code>KSEE</code>
             <zone>CAZ050</zone>
             <radar>lax</radar>
             <coordinates>32.826111 -116.972222</coordinates>
           </location>
           <location>
             <name>Brown Field Municipal Airport</name>
             <code>KSDM</code>
             <zone>CAZ050</zone>
             <radar>lax</radar>
             <coordinates>32.575278 -116.993056</coordinates>
           </location>
         </city>

There are SIX airport sub-locations. Weather Report use to be able to
let me select which one to use. Now it doesn't give me a choice anymore.
I don't know which one it uses now.

Likewise for my location, Saginaw:

         <city>
           <!-- A city in Michigan in the United States -->
           <_name>Saginaw</_name>
           <coordinates>43.419470 -83.950807</coordinates>
           <location>
             <name>Saginaw County H.W. Browne Airport</name>
             <code>KHYX</code>
             <coordinates>43.433333 -83.862500</coordinates>
           </location>
           <location>
             <name>MBS International Airport</name>
             <code>KMBS</code>
             <zone>MIZ053</zone>
             <radar>mkg</radar>
             <coordinates>43.532778 -84.079444</coordinates>
           </location>
       ...

Read more...

I am having the same trouble. The weather worked great in 8.04 and 8.10. Now with 9.04 it doesn't work at all regardless of what location or time zone is selected. There is a small space next to the date where it should be but nothing shows anymore. It seems like this only happens on some machines too. I have about 200 computers loaded up with 9.04 in our school system. Every HP Compaq nc6220 (laptop) has this problem. But all of the desktop PC's are fine. Our other laptops are fine as well. All the Toshiba's and Dell's. Is it possible this is a video driver issue? Maybe a space problem?

This may seem like a small issue but when every student and every teacher in the school system watches the temperature and weather in the toolbar to see if they will have outdoor recess (or not), it becomes a pretty substantial problem. Little features like this really make Ubuntu a plus to have...

Jon.

Nicholas (nicholas-a) wrote :

I can confirm it too. I am based in Perth, Western Australia. Its suddenly stopped working in Ubuntu 9.04 (x64).

I can confirm this bug on Ubuntu 9.10 64-bit.

Works for me with the Ubuntu development version, Lucid Lynx. In case you want to verify the current forecast at MBS is:

THIS AFTERNOON
PARTLY SUNNY
THEN BECOMING MOSTLY SUNNY LATE.
SCATTERED FLURRIES
ENDING AROUND 4 PM. HIGHS 37 TO 41. NORTHEAST
WINDS 5 TO 10 MPH
BECOMING LIGHT AND VARIABLE LATE.

TONIGHT
MOSTLY CLEAR
BECOMING PARTLY CLOUDY TOWARD DAYBREAK.
LOWS 20 TO 24. LIGHT AND VARIABLE WINDS
BECOMING SOUTHEAST 5 TO 10
MPH
THEN TURNING TO SOUTH LATE.

SATURDAY
PARTLY SUNNY. HIGHS 48 TO 52. SOUTH WINDS 5 TO 15 MPH.

SATURDAY NIGHT
PARTLY CLOUDY DURING THE EVENING. MOSTLY CLOUDY
OVERNIGHT. LOWS 31 TO 35. SOUTHEAST WINDS 5 TO 10 MPH
BECOMING
LIGHT AND VARIABLE.

SUNDAY
MOSTLY CLOUDY. A CHANCE OF RAIN. HIGHS 47 TO 51. LIGHT AND
VARIABLE WINDS
BECOMING NORTH 5 TO 15 MPH. CHANCE OF RAIN 30
PERCENT.

SUNDAY NIGHT
PARTLY CLOUDY. LOWS 25 TO 29.

MONDAY
PARTLY SUNNY. HIGHS 43 TO 47.

MONDAY NIGHT
CLEAR. LOWS 26 TO 30.

TUESDAY
MOSTLY SUNNY. HIGHS 51 TO 55.

TUESDAY NIGHT
MOSTLY CLEAR. LOWS 33 TO 37.

WEDNESDAY
MOSTLY SUNNY. HIGHS 58 TO 62.

WEDNESDAY NIGHT
MOSTLY CLEAR. LOWS 38 TO 42.

THURSDAY
MOSTLY SUNNY. HIGHS 63 TO 67.

Tom (ttwaro) wrote :

I am the person that opened this bug. My main systems are Ubuntu 9.10 and this is still a problem. BUT, I have installed 10.04 in a guest virtualbox machine and can, indeed, confirm that the Weather Report applet is now working correctly the way it use to. I am looking forward to the final 10.04 release so that I can install it on my main systems.

~$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

~$ apt-cache policy gnome-applets
gnome-applets:
  Installed: 2.29.5-0ubuntu2
  Candidate: 2.29.5-0ubuntu2
  Version table:
 *** 2.29.5-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Changed in libgweather (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers