no Asia/BeiJing option in TimeZone

Bug #228554 reported by ForLuck on 2008-05-09
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Invalid
Undecided
Unassigned
libgweather (Ubuntu)
Low
Unassigned
system-tools-backends (Ubuntu)
Undecided
Unassigned
tzdata (Ubuntu)
Undecided
Unassigned

Bug Description

there is no the Asia/BeiJing option in the selection of Time Zone in Time Zone. for i'm from P.R.China and BeiJing is our capital city, we are always using BeiJing time zone. please fix it. thank you very much.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report and helping to make Ubuntu better.

Confirming this issue either when setting timezone from the clock applet or System -> Administration -> Time & Date

Changed in system-tools-backends:
status: New → Confirmed
Chris Jones (cmsj) wrote :

fwiw Beijing isn't listed in /usr/share/zoneinfo either, adding tzdata

Changed in tzdata:
status: New → Confirmed
Martin Pitt (pitti) wrote :

tzdata covers Beijing:

CN +3114+12128 Asia/Shanghai east China - Beijing, Guangdong, Shanghai, etc.

So unless Beijing actually has a different timezone than Shanghai, this is not a tzdata issue. However, the libgweather one is valid, since it has (and is supposed to have) many more cities than tzdata.

Changed in tzdata:
status: Confirmed → Invalid

Actually, we Chinese people would like to use Asia/Beijing for we're using the Time Zone in our daily life or work but not Asia/Shanghai.

In China, there are only two time zone which are Asia/Beijing and Asia/Urumuqi, but no Asia/Shanghai or Asia/Chongqing, it's weird.

So, all Chinese Ubuntu users would appreciate it if you could help to modify it.

Thank you for your great work on Ubuntu!

Yours sincerely,

ForLuck Yang
AsiaSoft International Limited
TEL:
(86)755-88854188-300
FAX:
(86)755-88353630
Mobile:
(86)13530790234
Email:
<email address hidden>

> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
> Martin Pitt
> Sent: 2008年10月28日 17:39
> To: <email address hidden>
> Subject: [Bug 228554] Re: no Asia/BeiJing option in TimeZone
>
> tzdata covers Beijing:
>
> CN +3114+12128 Asia/Shanghai east China - Beijing,
> Guangdong,
> Shanghai, etc.
>
> So unless Beijing actually has a different timezone than Shanghai, this
> is not a tzdata issue. However, the libgweather one is valid, since it
> has (and is supposed to have) many more cities than tzdata.
>
> ** Changed in: tzdata (Ubuntu)
> Status: Confirmed => Invalid
>
> --
> no Asia/BeiJing option in TimeZone
> https://bugs.launchpad.net/bugs/228554
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “libgweather” source package in Ubuntu: Confirmed
> Status in “system-tools-backends” source package in Ubuntu: Confirmed
> Status in “tzdata” source package in Ubuntu: Invalid
>
> Bug description:
> there is no the Asia/BeiJing option in the selection of Time Zone in Time Zone.
> for i'm from P.R.China and BeiJing is our capital city, we are always using
> BeiJing time zone. please fix it. thank you very much.

Martin Pitt (pitti) wrote :

ForLuck [2008-10-29 1:11 -0000]:
> Actually, we Chinese people would like to use Asia/Beijing for we're
> using the Time Zone in our daily life or work but not Asia/Shanghai.

Right, the time zone selector in the GNOME panel should have all the
big cities. However, in tzdata there is only ever one representative
city (usually the largest) for a time zone.

> In China, there are only two time zone which are Asia/Beijing and
> Asia/Urumuqi, but no Asia/Shanghai or Asia/Chongqing, it's weird.

Ah, so you are saying that the "representatives" for the zones should
change? If so, this should be discussed at <email address hidden>, to
make this change upstream (maintaining this as a Delta in Ubuntu would
be error prone and incompatible with other software).

Thanks!

Alex Stansfield (casualgenius) wrote :

2008/10/29 Martin Pitt <email address hidden>

> ForLuck [2008-10-29 1:11 -0000]:
> > Actually, we Chinese people would like to use Asia/Beijing for we're
> > using the Time Zone in our daily life or work but not Asia/Shanghai.
>
> Right, the time zone selector in the GNOME panel should have all the
> big cities. However, in tzdata there is only ever one representative
> city (usually the largest) for a time zone.
>

By the time zone selector in GNOME panel do you also mean the Time/Date
selector in GNOME Adminstration? Because that has Harbin, Chongqing,
Shanghai, Urumqi, Hong Kong and Macau but no Beijing.

Interestingly enough the time zone of Urumqi is officially China Standard
Time (GMT+8). But locally they adopt, unoffically, GMT+6.

Also I'd be interested to know how the tzdata people chose the biggest city,
urban population or municipal population. If it's the latter then Chongqing
is much larger than Shanghai by about 14 million.

regards

Tao Wang (dancefire) wrote :

I don't know how tzdata evaluate the largest city in the time zone, however, Beijing is capital of China, where held 2008 Olympic games, and it IS large enough.

And the problem is even not so related to the size of the city, however, there is actually no Shanghai timezone in China. China government officially use GMT+8 in Beijing time zone as standard time in the country since maybe 50 years ago. I don't know where tzdata come from, but obviously out of date.

Since "Beijing local time", GMT+8, is the standard time for whole the country, it is very strange to choose other city in the time zone, no matter how large the city is. So, Beijing should be the REQUIRED city in the time zone, since it is standard time in China, and other city like Shanghai, Chongqing, may be OPTIONAL cities.

So, please add Beijing to the TimeZone. if tzdata don't, ubuntu should.

Sebastien Bacher (seb128) wrote :

The jaunty versions lists "Beijing, Beijing, China" and China timezone

Changed in libgweather (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The clock applet lists it correctly in jaunty

Could somebody check that the time-admin tool works right in Karmic now? You can start it from System->Administration->Time and Date. Thanks!

There's no bug in the system-tools-backends. They are listing the time zones contained in tzdata, that's all. Either Beijing should be added to it, or we can't do anything about that. Showing like gweather more cities than timezones is another issue, that would have to be discussed and would require work.

If you think Shangai has a time zone is wrong, please reopen that task and go discuss that in the appropriate list.

Changed in system-tools-backends (Ubuntu):
status: Confirmed → Invalid
An Yang (euroford) wrote :

Martin Pitt wrote on 2008-10-29:

>Ah, so you are saying that the "representatives" for the zones should
>change? If so, this should be discussed at <email address hidden>, to
>make this change upstream (maintaining this as a Delta in Ubuntu would
>be error prone and incompatible with other software).

From the technical view, there's an easy way to fix this bug without any error or incompatible, just add Asia/Beijing and keep Asia/Shanghai.
US is an example, which have 5 timezones, but have more than 29 cities in the timezone table, no problem at all.

From the policy view, ubuntu should use Asia/Beijing, if you want more chinese people use ubuntu,
I can not imagine that lenovo would OEM ubuntu without Asia/Beijing support, it hurt most people in China.

An Yang (euroford) on 2011-06-28
Changed in tzdata (Ubuntu):
status: Invalid → Confirmed
An Yang (euroford) wrote :

Please look at my ppa:euroford/chinese for patched tzdata.

An Yang (euroford) wrote :

with time-admin, I can choose Beijing in the correct location, nothing is broken.

An Yang (euroford) on 2011-06-28
Changed in tzdata (Ubuntu):
status: Confirmed → Fix Committed
tags: added: patch
An Yang (euroford) wrote :

Hi ZhengPeng Hou,

It's a serious user requirement in China.

Javier Jardón (jjardon) wrote :

No problems in oneiric indicator-datetime

Changed in indicator-datetime:
status: New → Invalid
An Yang (euroford) wrote :

Hi jjardon,

The name is Beijing, but the location is Shanghai. It's very very funny.

An Yang (euroford) wrote :

Using a bug to fix an other bug is not good choice, just use my beijing.patch is the best choice.

Changed in tzdata (Ubuntu):
status: Fix Committed → In Progress
James M. Leddy (jm-leddy) wrote :

Think this patch is a bit better. If we define Beijing as a new time zone, we lose a lot of information. However, since it is the same timezone as Shanghai, we can just link the two.

An Yang (euroford) wrote :

Good news, thanks James.

Though Asia/Beijing is alias to Asia/Shanghai in tech, My suggestion is replace the comment to "China Standard Time"

lorancou (lorancou) wrote :

This could be a proposed change for the IANA Time Zone Database, so tzdata would be changed upstream and all distribs using it would benefit from the update. Changes can be proposed on a dedicated mailing list, more info here: http://www.iana.org/time-zones.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints