FTBFS in Bionic due to update to JDK

Bug #1782138 reported by Christian Ehrhardt  on 2018-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libguestfs (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

 * Newer Java dropped the javah tool, instead javac -h has to be used.
 * This package was built when javah was around, but since the java
   updates to openjdk-10 FTBFS
 * Fix is a backport from upstream that uses javac -h if javah is not
   available

[Test Case]

 * Correctly build again in Ubuntu
 * Proven on the PPA

[Regression Potential]

 * If people rebuilt intentionally with other Java versions that might now
   behave slightly different. But since it is conditional "if javah exists
   as before, otherwise use javac -h" it it not even changing those
   really.
   Eventually the real regression came with the bump to a newer java
   version which was done long ago, this only cleans up the FTBFS.

[Other Info]

 * n/a

---

FTBFS is due to http://openjdk.java.net/jeps/313 which makes jdk >=10 unusable for the libguestfs code that is in Bionic.
Also see https://bugs.java.com/view_bug.do?bug_id=JDK-8182758
Fixed by https://github.com/libguestfs/libguestfs/commit/662dc5d0bf65e72dab11aa58d4bc373b5a3b7e75

Looks like: https://launchpadlibrarian.net/378892118/buildlog_ubuntu-bionic-amd64.libguestfs_1%3A1.36.13-1ubuntu3.1~ppa2_BUILDING.txt.gz

We could either
- depend on openjdk-8-jdk (just as it was built before, this still is available)
- Try to backport and use the upstream fix.

Related branches

Changed in libguestfs (Ubuntu):
status: New → Triaged

Ok, builds are good now with the fix applied.
The Upload will be bundled with the SRU for 1766534.

I juts realized this is only in 1.39.5 and later by upstream and wondered about Cosmic.
But I found that Debian added this in 1:1.38.1-1 by
  * Add patch to handle OpenJDK 10 (Closes: #897476)

It is reassuring that they have used the same patch to do so :-)
That said cosmic is good.

Changed in libguestfs (Ubuntu Bionic):
status: New → Triaged
Changed in libguestfs (Ubuntu):
status: Triaged → Fix Released
Łukasz Zemczak (sil2100) wrote :

I will assume that the test-case here is: making sure the package builds successfully. I guess I'd appreciate a regression potential change, e.g. what could have been broken by the FTBFS patch potentially, but this time I'll let it slip as it's bunched up with one more fix.

Changed in libguestfs (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello , or anyone else affected,

Accepted libguestfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libguestfs/1:1.36.13-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

It seems when pushing this I had a streak of bad SRU descriptions and I want to fix that, so I added the description even though as you assumed for the FTBFS that was all quite clear.

Also the build in proposed is already done and working now, so we can set verified.

description: updated
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Yeah, for FTBFS fixes that are batched up with other changes I am not really strict on missingSRU descriptions. A regression potential field is always welcome, but I don't always block on that if the changes seem straightforward.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libguestfs - 1:1.36.13-1ubuntu3.1

---------------
libguestfs (1:1.36.13-1ubuntu3.1) bionic; urgency=medium

  * d/p/lp-1766534-s390x-*: backport s390x/CCW support from 1.37.22 to Bionic
    (LP: #1766534)
  * d/p/lp-1782138-java-support-OpenJDK-10.patch: Fix FTBFS due to newer
    jdk >=10 being in Bionic (LP: #1782138)

 -- Christian Ehrhardt <email address hidden> Tue, 17 Jul 2018 10:34:31 +0200

Changed in libguestfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libguestfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers