FTBFS in trusty: variable 'optargs_s' has initializer but incomplete type

Bug #1501075 reported by dann frazier on 2015-09-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libguestfs (Ubuntu)
Undecided
dann frazier
Trusty
Medium
Unassigned

Bug Description

[Impact]
In addition to LP: #1498618, there's a secondary issue that causes libguestfs to *sometimes* [1] FTBFS in trusty.

The issue stems from debian/rules overrides CFLAGS when calling dh_auto_test. These CFLAGS take precedence over the CFLAGS defined by the generated Makefile (e.g. -DGUESTFS_PRIVATE=1), which are required.

[1] "Sometimes" because there appears to be some build system issue (race? timestamp?) that prevents this test from running. I haven't been able to root cause that issue, but I've confirmed my proposed fix works when the test does run.

[Test Case]
Build libguestfs and look for "rake2.0 test" in the buildlog. If that string exists, and the build passes, then the issue is fixed.

[Regression Risk]
This change only impacts build-time testing.

Chris J Arges (arges) on 2015-10-07
Changed in libguestfs (Ubuntu):
status: In Progress → Fix Released
Changed in libguestfs (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium

Hello dann, or anyone else affected,

Accepted libguestfs into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libguestfs/1:1.24.5-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libguestfs (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
dann frazier (dannf) wrote :

No previously built architectures failed to build (and no previously failed architectures failed the build due to to this).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libguestfs - 1:1.24.5-1ubuntu0.1

---------------
libguestfs (1:1.24.5-1ubuntu0.1) trusty; urgency=medium

  * d/p/configure-Make-sure-grep-matches-qemu-2.x-version-st.patch:
      Fix FTBFS caused by QEMU 1.x->2.x update during trusty devel
      (LP: #1498618)
  * d/rules: Fix FTBFS by no longer force-overriding CFLAGS during
    dh_auto_test (LP: #1501075)
  * libguestfs-tools: Add missing dependency on curl (LP: #1368819)
  * Enable building on additional architectures:
    - d/{control,rules}: Enable builds on non-x86 architectures.
      This is sufficient for building on powerpc.
    - d/p/configure-Fix-tests-of-qemu-on-ARM.patch: Teach configure
      how to properly test qemu on ARM. This adds armhf support.
    - d/p/Fix-building-on-architectures-where-ocamlopt-is-not-.patch,
      d/p/More-fixes-for-situations-where-ocamlopt-is-not-avai.patch:
      Use ocamlc on architectures where ocamlopt is not available. This
      will unblock building on arm64 and ppc64el should systemtap-sdt-dev
      become installable there.

 -- dann frazier <email address hidden> Wed, 23 Sep 2015 16:48:41 -0600

Changed in libguestfs (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libguestfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers