libguestfs-tools requires curl, not currently a dependency

Bug #1368819 reported by Sean Smith on 2014-09-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libguestfs (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned

Bug Description

Description: Ubuntu 14.04.1 LTS
Release: 14.04

libguestfs-tools:
  Installed: 1:1.24.5-1
  Candidate: 1:1.24.5-1
  Version table:
 *** 1:1.24.5-1 0
        500 http://buildhost.missiondata.net/depot/ubuntu/mirror/archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

After installing libguestfs-tools, an attempt to run `virt-builder --list` errors with the following error message:

$ virt-builder --list
virt-builder: curl is not installed (or does not work)

libguestfs-tools should require curl

Sean Smith (seansith) wrote :
description: updated
Richard Jones (rjones-redhat) wrote :

Tis true. 1.26/1.27 added the following dependencies for virt-builder:

xz
curl
gpg

and for virt-v2v:

gawk
gzip
curl
virsh
strip

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libguestfs (Ubuntu):
status: New → Confirmed
Changed in libguestfs (Ubuntu Trusty):
importance: Undecided → Medium
status: New → Triaged
Changed in libguestfs (Ubuntu):
status: Confirmed → Fix Released

Hello Sean, or anyone else affected,

Accepted libguestfs into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libguestfs/1:1.24.5-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libguestfs (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
dann frazier (dannf) wrote :

ubuntu@trusty:~$ virt-builder --list
virt-builder: curl is not installed (or does not work)
ubuntu@trusty:~$ sudo apt-get install libguestfs-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  curl libguestfs-perl libguestfs0
The following NEW packages will be installed:
  curl
The following packages will be upgraded:
  libguestfs-perl libguestfs-tools libguestfs0
3 upgraded, 1 newly installed, 0 to remove and 26 not upgraded.
Need to get 3,569 kB of archives.
After this operation, 315 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://nova.clouds.archive.ubuntu.com/ubuntu/ trusty-proposed/universe libguestfs-tools amd64 1:1.24.5-1ubuntu0.1 [2,529 kB]
Get:2 http://nova.clouds.archive.ubuntu.com/ubuntu/ trusty-proposed/universe libguestfs-perl amd64 1:1.24.5-1ubuntu0.1 [268 kB]
Get:3 http://nova.clouds.archive.ubuntu.com/ubuntu/ trusty-updates/main curl amd64 7.35.0-1ubuntu2.5 [123 kB]
Get:4 http://nova.clouds.archive.ubuntu.com/ubuntu/ trusty-proposed/universe libguestfs0 amd64 1:1.24.5-1ubuntu0.1 [649 kB]
Fetched 3,569 kB in 0s (14.3 MB/s)
Preconfiguring packages ...
(Reading database ... 102152 files and directories currently installed.)
Preparing to unpack .../libguestfs-tools_1%3a1.24.5-1ubuntu0.1_amd64.deb ...
Unpacking libguestfs-tools (1:1.24.5-1ubuntu0.1) over (1:1.24.5-1) ...
Preparing to unpack .../libguestfs-perl_1%3a1.24.5-1ubuntu0.1_amd64.deb ...
Unpacking libguestfs-perl (1:1.24.5-1ubuntu0.1) over (1:1.24.5-1) ...
Selecting previously unselected package curl.
Preparing to unpack .../curl_7.35.0-1ubuntu2.5_amd64.deb ...
Unpacking curl (7.35.0-1ubuntu2.5) ...
Preparing to unpack .../libguestfs0_1%3a1.24.5-1ubuntu0.1_amd64.deb ...
Unpacking libguestfs0:amd64 (1:1.24.5-1ubuntu0.1) over (1:1.24.5-1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libguestfs0:amd64 (1:1.24.5-1ubuntu0.1) ...
Setting up libguestfs-perl (1:1.24.5-1ubuntu0.1) ...
Setting up curl (7.35.0-1ubuntu2.5) ...
Setting up libguestfs-tools (1:1.24.5-1ubuntu0.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
ubuntu@trusty:~$ virt-builder --list
virt-builder: index is corrupt: os-version 'fedora-21' appears two or more times

The index file downloaded from 'http://libguestfs.org/download/builder/index.asc' is corrupt.
You need to ask the supplier of this file to fix it and upload a fixed version.
ubuntu@trusty:~$

Not good, but not worse.

tags: added: verification-done
removed: verification-needed
Richard Jones (rjones-redhat) wrote :

 ubuntu@trusty:~$ virt-builder --list
virt-builder: index is corrupt: os-version 'fedora-21' appears two or more times

This is fixed further along the 1.24 stable branch. (https://bugs.launchpad.net/ubuntu/+source/libguestfs/+bug/1433750)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libguestfs - 1:1.24.5-1ubuntu0.1

---------------
libguestfs (1:1.24.5-1ubuntu0.1) trusty; urgency=medium

  * d/p/configure-Make-sure-grep-matches-qemu-2.x-version-st.patch:
      Fix FTBFS caused by QEMU 1.x->2.x update during trusty devel
      (LP: #1498618)
  * d/rules: Fix FTBFS by no longer force-overriding CFLAGS during
    dh_auto_test (LP: #1501075)
  * libguestfs-tools: Add missing dependency on curl (LP: #1368819)
  * Enable building on additional architectures:
    - d/{control,rules}: Enable builds on non-x86 architectures.
      This is sufficient for building on powerpc.
    - d/p/configure-Fix-tests-of-qemu-on-ARM.patch: Teach configure
      how to properly test qemu on ARM. This adds armhf support.
    - d/p/Fix-building-on-architectures-where-ocamlopt-is-not-.patch,
      d/p/More-fixes-for-situations-where-ocamlopt-is-not-avai.patch:
      Use ocamlc on architectures where ocamlopt is not available. This
      will unblock building on arm64 and ppc64el should systemtap-sdt-dev
      become installable there.

 -- dann frazier <email address hidden> Wed, 23 Sep 2015 16:48:41 -0600

Changed in libguestfs (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libguestfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments