libguestfs: error: cannot find any suitable libguestfs supermin

Bug #1086974 reported by Phill Whiteside on 2012-12-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libguestfs (Ubuntu)
Undecided
Unassigned
Quantal
High
Unassigned

Bug Description

[Impact]
attempting to use:
virt-copy-out -d l-raring /var/log .

Results in:
libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib/x86_64-linux-gnu/guestfs)

Running:
libguestfs-test-tool
results in the same error.

[Test Case]
$ apt-get install libguestfs-tools
$ update-guestfs-appliance
$ libguestfs-test-tool
..
libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib/x86_64-linux-gnu/guestfs)
..
$ echo $?
1

Upgrade libguestfs-tools to version from -proposed
$ libguestfs-test-tool
# loads of supermin helper output
$ echo $?
0

PLEASE note you need to have /boot/ available with some kernels.

[Regression Potential]
As various guestfs commands are rendered inoperative with the bug, the regression risk would be extremely low.

Phill Whiteside (phillw) wrote :

* Phill Whiteside:

> attempting to use:
> virt-copy-out -d l-raring /var/log .
> Results in:
> libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib/x86_64-linux-gnu/guestfs)

I believe that I fixed this in 1.18.5-3 which was uploaded to
Debian/unstable on or around 2012-07-19.

-Hilko

Phill Whiteside (phillw) wrote :

Having chatted to ubuntu-devel, I was informed that a newer suite is available (1:1.18.10-1ubuntu2 ) for Raring. The list of apps to be updated was given by carrying out:
dpkg -l \*guestf\* | awk '/^i/ {print $2}
Which gave me the list:
guestfish
libguestfs-perl
libguestfs-tools
libguestfs0:amd64
python-guestfs
Enabling raring via editing sources to allow raring & then refreshing guestfish, suggested 9 packages in total be upgraded.
perl
libperl5.14
perl-base
perl-modules
python-guestfs
libguestfs-tools
libguestfs-perl
guestfish
libguestfs0:amd64

After installation, it then proceeded to 'Configuring libguestfs-tools' This reported early on:
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

After that, it offers to update a whole lot of other things (expected behavior when enabling a more up to date repo). This culminates in:
writing supermin.d/base.img ...
writing supermin.d/hostfiles ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

virt-copy-out now works :)
More importantly...
libguestfs-test-tool
runs through and reports back:
libguestfs: closing guestfs handle 0x109f0a0 (state 0)
===== TEST FINISHED OK =====

Dimitri John Ledkov (xnox) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Raring Ringtail.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in libguestfs (Ubuntu):
status: New → Fix Released
Phill Whiteside (phillw) wrote :

[Impact]
attempting to use:
virt-copy-out -d l-raring /var/log .
Results in:
libguestfs: error: cannot find any suitable libguestfs supermin, fixed or old-style appliance on LIBGUESTFS_PATH (search path: /usr/lib/x86_64-linux-gnu/guestfs)
Running:
libguestfs-test-tool
results in the same error.
[Test Case]
Install guestfish
run libguestfs-test-tool
Error is shown, as above.
Install updates as per comment #3
Error no longer exists.
[Regression Potential]
As various guestfs commands are rendered inoperative with the bug, the regression risk would be extremely low.

Thomas Ward (teward) wrote :

Description modified to account for SRU template. Nominated for "Quantal" series at the request of phillw (for SRUing)

description: updated
Steve Langasek (vorlon) wrote :

Note that for this to be fixed for quantal, someone will need to identify the targeted fix and prepare an SRU of the quantal version including that fix. Nominating it for SRU does not by itself result in anything happening here.

Steve Langasek (vorlon) wrote :

(Given that the Debian maintainer has identified the version of the package which fixed this for unstable, presumably it should be straightforward to cherry-pick that fix; still needs someone to do the work though)

Phill Whiteside (phillw) wrote :

Re #8, I did originally ask about how to obtain the fix suggested in #2. I'm quite happy to do that, but need some help on getting something from debian/unstable It would be in a VM as my system now works and it would appear very few people use guestfish, but with some help I'd be happy to check it out.

Changed in libguestfs (Ubuntu Quantal):
assignee: nobody → Dmitrijs Ledkovs (xnox)
status: New → Confirmed
importance: Undecided → High
description: updated
Nikos Skalkotos (skalkoto) wrote :

The problem is that libguestfs searches in the wrong place to find the appliance. If you run libguestfs-test-tool like this:

$ env LIBGUESTFS_PATH=/usr/lib/guestfs libguestfs-test-tool

It will work

Nikos Skalkotos (skalkoto) wrote :

This doesn't only affect libguestfs-test-tool and virt-*. This bug makes the library unusable unless someone defines the proper LIBGUESTFS_PATH variable. When using the python bindings, you get the same error.

This is fixed in debian 's 1.18.5-3 package:

http://anonscm.debian.org/gitweb/?p=pkg-libvirt/libguestfs.git;a=commitdiff;h=de8c07ecec821633808e6a804bcf1d0a009a8cd3

* Nikos Skalkotos:

> This doesn't only affect libguestfs-test-tool and virt-*. This bug makes
> the library unusable unless someone defines the proper LIBGUESTFS_PATH
> variable. When using the python bindings, you get the same error.

It has been about six weeks since I pointed to the fixed version that I
uploaded to Debian about six months ago. Man, things really get done
quickly around here.

-Hilko

Tobias Bradtke (webwurst) wrote :

As a workaround for Quantal you can create a symlink:

$ sudo ln --symbolic /usr/lib/guestfs /usr/lib/x86_64-linux-gnu/guestfs

description: updated
Dimitri John Ledkov (xnox) wrote :

Successfully uploaded libguestfs_1.18.5-2ubuntu1.dsc to upload.ubuntu.com for ubuntu.
Successfully uploaded libguestfs_1.18.5-2ubuntu1.debian.tar.gz to upload.ubuntu.com for ubuntu.
Successfully uploaded libguestfs_1.18.5-2ubuntu1_source.changes to upload.ubuntu.com for ubuntu.

Uploaded into quantal-proposed unapproved queue. Next a member of Ubuntu SRU team needs to review this upload and publish the package to quantal-proposed package.

Changed in libguestfs (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: Dmitrijs Ledkovs (xnox) → nobody

Hello Phill, or anyone else affected,

Accepted libguestfs into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libguestfs/1:1.18.5-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libguestfs (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Phill Whiteside (phillw) wrote :

libguestfs-test-tool

===== TEST FINISHED OK =====

Thanks everyone who has helped out on this one :)

tags: added: verification-done
removed: verification-needed
Phill Whiteside (phillw) wrote :

Oh, and just to dot the 'I's and cross the 'T's .. it is version 1:1.18.5-2ubuntu1 that I installed after enabling proposed.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libguestfs - 1:1.18.5-2ubuntu1

---------------
libguestfs (1:1.18.5-2ubuntu1) quantal-proposed; urgency=low

  * Install libguestfs supermin in the correct location. (LP: #1086974)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 16 Jan 2013 10:35:55 +0000

Changed in libguestfs (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers