libgtkada2-bin : trying to overwrite `/usr/bin/gdialog', which is also in package zenity

Bug #280188 reported by Philip Muškovac on 2008-10-08
130
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libgtkada2 (Debian)
Fix Released
Unknown
libgtkada2 (Ubuntu)
High
Unassigned
Nominated for Intrepid by Mike Trim
Nominated for Jaunty by Mike Trim
zenity (Debian)
Fix Released
Unknown
zenity (Ubuntu)
Low
Unassigned
Nominated for Intrepid by Mike Trim
Nominated for Jaunty by Mike Trim

Bug Description

Description: Ubuntu intrepid (development branch)
Release: 8.10
libgtkada2-bin:
  Installiert: (keine)
  Kandidat: 2.12.0-2ubuntu1
  Versions-Tabelle:
     2.12.0-2ubuntu1 0
        500 http://de.archive.ubuntu.com intrepid/universe Packages

ProblemType: Package
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 8.10
ErrorMessage: Versuche, »/usr/bin/gdialog« zu überschreiben, welches auch in Paket zenity ist
NonfreeKernelModules: nvidia
Package: libgtkada2-bin None [modified: /var/lib/dpkg/info/libgtkada2-bin.list]
SourcePackage: libgtkada2
Title: package libgtkada2-bin None [modified: /var/lib/dpkg/info/libgtkada2-bin.list] failed to install/upgrade: Versuche, »/usr/bin/gdialog« zu überschreiben, welches auch in Paket zenity ist
Uname: Linux 2.6.27-6-generic i686

Related branches

Philip Muškovac (yofel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed in Intrepid.

# apt-cache policy libgtkada2-bin zenity
libgtkada2-bin:
  Installed: (none)
  Candidate: 2.12.0-2ubuntu1
  Version table:
     2.12.0-2ubuntu1 0
        500 ftp://ftp.free.fr intrepid/universe Packages
zenity:
  Installed: 2.24.0-0ubuntu1
  Candidate: 2.24.0-0ubuntu1
  Version table:
 *** 2.24.0-0ubuntu1 0
        500 ftp://ftp.free.fr intrepid/main Packages
        100 /var/lib/dpkg/status

Changed in libgtkada2:
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Still an issue in Jaunty (libgtkada2-bin 2.12.0-2ubuntu1)

Changed in libgtkada2:
importance: Undecided → High
status: Confirmed → Triaged
Angel Guzman Maeso (shakaran) wrote :

Same for me in Jaunty alpha 3:

Preparing to replace zenity 2.24.0-0ubuntu1 (using .../zenity_2.24.1-0ubuntu1_i386.deb) ...
Unpacking replacement zenity ...
dpkg: error processing /var/cache/apt/archives/zenity_2.24.1-0ubuntu1_i386.deb (--unpack):
 trying to overwrite `/usr/bin/gdialog', which is also in package libgtkada2-bin
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Changed in libgtkada2:
status: Unknown → Fix Released
Mike Trim (miketrim) wrote :

Debian have 'fixed' this by making zenity and libgtkada2-bin conflict; however this means that libgtkada2-bin cannot be installed without removing zenity, which is needed by several packages that are part of the normal Ubuntu install. I'm not sure what the differences are between the zenity gdialog and the libgtkada gdialog, but assuming they are equivalent, perhaps gdialog could be removed from libgtkada and a dependency on zenity added instead?

Philip Muškovac (yofel) wrote :

Thanks for reminding me of the existance of this bug Trim ^^. I use a self-compiled version for gtkada since then where i removed gdialog from the build (At least I don't use it). I looked into what you suggested, but it seems that gdialog_ada provides a very small subset of what zenity provides. So not only the commands are different, the syntax is different as well. Looking at gdialog_zenity it's a perl script that's supposed to convert something. I don't know perl so that's all I found out. What I'm curious about is why gdialog_ada was called gdialog2 back in hardy so libgtkada2-bin could be installed with zenity without a problem.
Another thing I noticed Is that the zenity guys don't seem to have noticed that this bug exists so I'll add a bug for zentiy here. If they can't come up with a solution on their side they should at least add a conflict on libgtkada2-bin.

Mike Trim (miketrim) wrote :

The attached debdiff is against the latest debian packge, 2.12.0-3.

This fixes the conflict with zenity by no longer installing a symlink in /usr/bin/gdialog, and patching gate to call gdialog2 directly.

The latest debian package also fixes LP: #280503.

Mike Trim (miketrim) wrote :

Note: the updated package builds successfully in pbuilder, and installs alongside zenity without problems.

Mike Trim (miketrim) wrote :

Updated patch against latest Ubuntu package 2.12.0-3ubuntu1.

Mike Trim (miketrim) wrote :

Please can someone sponsor this update in karmic.

Sebastien Bacher (seb128) wrote :

the current zenity version uses a conflicts there

Changed in zenity (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Mike Trim (miketrim) wrote :

Having a conflict resolves the packaging error, but it doesn't make libgtkada2 usable since zenity is a dependency of several core Ubuntu packages, e.g. ubuntu-desktop, metacity. Therefore I think it is more reasonable to resolve this by removing the gdialog symlink from the libgtkada2 package as per the debdiff attached above. As far as I am aware there are no other packages that depend on the existence of libgtkada2's gdialog, so this should not cause any breakage.

Philip Muškovac (yofel) wrote :

Afaik the "fix" for zenity comes from debian unstable. So now both packages need the conflicts removed and gtkada needs Mike's fixes.

Philip Muškovac (yofel) wrote :

Yay, fixed in svn XD

------------------------------------------------------------------------
r146020 | charlet | 2009-06-19 08:43:20 +0200 (Fri, 19 Jun 2009) | 7 lines

Rename gdialog executable to gtkada-dialog.
This avoids a conflict with the gdialog binary provided by Zenity on GNOME
systems. See the following bug reports for more information:
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497464
 https://bugs.launchpad.net/bugs/280188
Contributed by Michael Trim.

Mike Trim (miketrim) wrote :

This is now fixed in 2.12.0-4 in Debian unstable.

Philip Muškovac (yofel) wrote :

Merged in Ubuntu

libgtkada2-bin:
  Installed: 2.12.0-4ubuntu1
  Candidate: 2.12.0-4ubuntu1
  Version table:
 *** 2.12.0-4ubuntu1 0
        500 http://archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

Changed in libgtkada2 (Ubuntu):
status: Triaged → Fix Released
Philip Muškovac (yofel) wrote :

Now zenity needs the conflict on libgtkada2-bin removed.

Changed in zenity (Ubuntu):
status: Fix Released → New
Mike Trim (miketrim) wrote :

Please update the intrepid and jaunty libgtkada2 packages to the version in karmic (2.12.0-4ubuntu1). This will fix this bug and bug #280503. This has no impact as the original package version remains the same and in any case the current package version cannot be installed on most GNOME systems due to this bug.

Changed in zenity (Debian):
status: Unknown → New
Changed in zenity (Ubuntu):
status: New → Invalid
status: Invalid → New
Iain Lane (laney) wrote :

Greetings,

I've just cooked up a debdiff backporting the conflicts/replaces fixes from Debian. Attached for sponsorship.

Changed in zenity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zenity - 2.28.0-0ubuntu2

---------------
zenity (2.28.0-0ubuntu2) karmic; urgency=low

  * debian/control: Version conflicts/replaces on libgtkada2-bin to
    (<< 2.12.0-4) as per Debian. There was a file conflict between zenity
    and libgtkada2 which was resolved in this version in Debian and Ubuntu.
    (LP: #280188)

 -- Iain Lane <email address hidden> Wed, 16 Sep 2009 12:12:02 +0100

Changed in zenity (Ubuntu):
status: Confirmed → Fix Released
Changed in zenity (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.