package libpam-modules 1.1.8-3.6ubuntu2.18.04.1 failed to install/upgrade: pre-dependency problem - not installing libpam-modules:amd64

Bug #1871960 reported by Safiullah Rahmani on 2020-04-09
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libgtk3-perl (Ubuntu)
Critical
Unassigned
Focal
Critical
Unassigned
pango1.0 (Ubuntu)
Critical
Unassigned
Focal
Critical
Unassigned

Bug Description

I was updating ubuntu to the 20.04 version. Not all packages were updated. I receive new errors every few seconds. what should I do?

Thanks
safi

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: libpam-modules 1.1.8-3.6ubuntu2.18.04.1
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
ApportVersion: 2.20.11-0ubuntu25
Architecture: amd64
Date: Fri Apr 10 00:36:08 2020
ErrorMessage: pre-dependency problem - not installing libpam-modules:amd64
InstallationDate: Installed on 2019-12-28 (102 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.1ubuntu1
SourcePackage: pam
Title: package libpam-modules 1.1.8-3.6ubuntu2.18.04.1 failed to install/upgrade: pre-dependency problem - not installing libpam-modules:amd64
UpgradeStatus: Upgraded to focal on 2020-04-09 (0 days ago)

Safiullah Rahmani (safirahmani) wrote :
tags: removed: need-duplicate-check
Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and helping to improve Ubuntu.

This is a serious class of upgrade failure, but unfortunately the bug report as filed doesn't contain enough information to reproduce or debug it. How did you do the update to 20.04? Was this using apt from the commandline, or do-release-upgrade or update-manager?

If you used do-release-upgrade or update-manager, can you please attach the full /var/log/dist-upgrade/apt-term.log from your system?

Changed in pam (Ubuntu):
importance: Undecided → Critical
status: New → Incomplete
Ingrid Vreja (tindomielux) wrote :

Hi Steve,

I am new to Ubuntu and just updated from 18.04 (there I had wifi connection issues). I encountered the same bug when I updated via update-manager. But I am very happy that the wifi connection is working well now.

I am attaching the .log file and I hope this bug can be patched because I would really like to keep using Focal Fossa. Thank you for taking care of this! Let me know if I can help in any other way

Steve Langasek (vorlon) wrote :

Ingrid, the log you attached does not include any information about the libpam-modules package. It's possible you have the same bug, but this log does not help us debug it.

Can you double check that the log file you attached was /var/log/dist-upgrade/apt-term.log? The log you attached does not look like a release upgrade log, but rather a regular apt term log.

David D Lowe (flimm) wrote :
Download full text (3.5 KiB)

I also experienced this bug. I was running Ubuntu 18.04, and I upgraded to Ubuntu 20.20 yesterday by running `update-manager -d` on the command-line, which launched the GUI. During the upgrade itself, I was shown a dialog displaying an error relating to pam.

I've attached apt-term.log (for me) to this comment. Here is the relevant error, I think, I don't know how to find the core dump:

Preparing to unpack .../libpam0g_1.3.1-5ubuntu4_amd64.deb ...
Unpacking libpam0g:amd64 (1.3.1-5ubuntu4) over (1.1.8-3.6ubuntu2.18.04.1) ...
Setting up libpam0g:amd64 (1.3.1-5ubuntu4) ...
Fontconfig warning: "/etc/fonts/conf.avail/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
GLib-GObject-WARNING **: specified class size for type 'PangoCairoFcFont' is smaller than the parent type's 'PangoFcFont' class size at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_object_new_valist: assertion 'G_TYPE_IS_OBJECT (object_type)' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
dpkg: error processing package libpam0g:amd64 (--configure):
 installed libpam0g:amd64 package post-installation script subprocess was killed by signal (Segmentation fault), core dumped
Errors were encountered while processing:
 libpam0g:amd64
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 276143 files and directories currently installed.)
Preparing to unpack .../libpam-modules-bin_1.3.1-5ubuntu4_amd64.deb ...
Unpacking libpam-modules-bin (1.3.1-5ubuntu4) over (1.1.8-3.6ubuntu2.18.04.1) ...
dpkg: dependency problems prevent configuration of libpam-modules-bin:
 libpam-modules-bin depends on libpam0g (>= 0.99.7.1); however:
  Package libpam0g:amd64 is not configured yet.

dpkg: error processing package libpam-modules-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libpam-modules-bin
dpkg: regarding .../libpam-modules_1.3.1-5ubuntu4_amd64.deb containing libpam-modules:amd64, pre-dependency problem:
 libpam-modules:amd64 pre-depends on libpam0g (>= 1.3.1)
  libpam0g:amd64 latest configured version is 1.1.8-3.6ubuntu2.18.04.1.

dpkg: error processing archive /var/cache/apt/archives/libpam-modules_1.3.1-5ubuntu4_amd64.deb (--unpack):
 pre-dependen...

Read more...

Steve Langasek (vorlon) wrote :

This failure appears to be coming from the gnome debconf frontend, which for some reason is crashing in the upgrade environment between 18.04 and 20.04.

affects: pam (Ubuntu) → libgtk3-perl (Ubuntu)
Changed in libgtk3-perl (Ubuntu):
status: Incomplete → New
tags: added: ff-incoming
Steve Langasek (vorlon) wrote :

If someone is able to provide an apport crash report which shows a backtrace for the actual crash, that may be helpful in debugging.

David D Lowe (flimm) wrote :

Here is the archive of the contents of my /var/crash directory, which is what I think you requested, I hope that helps.

Jean-Baptiste Lallement (jibel) wrote :

it's been reported to errors.u.c (https://errors.ubuntu.com/oops/7a122fe4-82ff-11ea-abcd-fa163e983629) but it couldn't be retraced

Changed in libgtk3-perl (Ubuntu Focal):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

should we vendorize gtk in the upgrade tarball? or like install/use a snap?

Brian Murray (brian-murray) wrote :

Searching for debconf crashes in the Error Tracker, I found quite a few.

https://errors.ubuntu.com/?release=Ubuntu%2020.04&package=debconf&period=week

Changed in libgtk3-perl (Ubuntu Focal):
milestone: none → ubuntu-20.04
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1871960

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

The pango errors are similar to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958017 , I've backported and uploaded those changes to focal now

Sebastien Bacher (seb128) wrote :

Trying a bionic to focal update, there is a timeslot where pango libraries were out of sync and anything gtk would fail to start on similar error, the fix should help with that. But then libgtk-3-0 was in iU state for almost 10 minutes which would make any GTK binary hit bug #1627564...

Brian Murray (brian-murray) wrote :

I tested an upgrade from Bionic to Focal with -proposed enabled (I had to remove the disabling of -proposed in DistUpgradeController.py) and did not encounter any of the following error messages:

GLib-GObject-WARNING **: specified class size for type 'PangoCairoFcFont' is smaller than the parent type's 'PangoFcFont' class size at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.
GLib-GObject-CRITICAL **: g_object_new_valist: assertion 'G_TYPE_IS_OBJECT (object_type)' failed at /usr/lib/x86_64-linux-gnu/perl5/5.30/Glib/Object/Introspection.pm line 67.

I had seen them when I tried upgrading the same virtual machine when -proposed was not enabled. Attached you'll find my apt-term.log from the successful upgrade.

Changed in pango1.0 (Ubuntu Focal):
status: New → Confirmed
importance: Undecided → Critical
milestone: none → ubuntu-20.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pango1.0 - 1.44.7-2ubuntu4

---------------
pango1.0 (1.44.7-2ubuntu4) focal; urgency=medium

  * Backport some Debian changes to try to fix upgrade issues (lp: #1871960)

  [ Simon McVittie ]
  * d/shlibs.local: Upgrade all binary packages in lockstep.
    Like many projects where one source package builds multiple binary
    packages, Pango has private headers that share non-public interfaces
    between its binary packages. Upgrading one binary package from this
    source without upgrading the others is not something that its upstream
    developers are ever going to test or support, and neither should we.
    (Closes: #958017)
  * libpango-1.0-0: Add Breaks on older libpango*-1.0-0.
    This should ensure that buster users can't get a broken partial upgrade
    by upgrading only libpango-1.0-0, but not the others, from 1.42.x to
    1.44.x.

 -- Sebastien Bacher <email address hidden> Tue, 21 Apr 2020 18:02:31 +0200

Changed in pango1.0 (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in libgtk3-perl (Ubuntu Focal):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.