Transparency not working with Gtk2::TrayIcon

Bug #156886 reported by Quentin Sculo on 2007-10-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgtk2-trayicon-perl (Ubuntu)
Low
Siegfried Gevatter

Bug Description

Binary package hint: libgtk2-trayicon-perl

The tray icons from perl programs using Gtk2::TrayIcon have a white background when the panel is set to be transparent.
This is a known issue of Gtk2::TrayIcon version 0.04
 It has been fixed in Gtk2::TrayIcon 0.06.
So upgrading the package would be nice.

I can confirm that using 0.06 fixes this issue (using gmusicbrowser).

Changed in libgtk2-trayicon-perl:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in libgtk2-trayicon-perl:
importance: Wishlist → Low
status: Confirmed → Triaged
Quentin Sculo (squentin) wrote :

Diff for the new version.

Changed in libgtk2-trayicon-perl:
status: Triaged → Confirmed
Changed in libgtk2-trayicon-perl:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

Uploaded. Thanks for your debdiff!

Changed in libgtk2-trayicon-perl:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgtk2-trayicon-perl - 0.06-0ubuntu1

---------------
libgtk2-trayicon-perl (0.06-0ubuntu1) hardy; urgency=low

  * New version. (LP: #156886)
  * Added debian/watch file
  * debian/control :
    - set maintainer to <email address hidden>
    - updated Standards-Version

 -- Quentin Sculo <email address hidden> Sat, 02 Feb 2004 01:53:00 +0200

Changed in libgtk2-trayicon-perl:
status: Fix Committed → Fix Released
Sam Devol (support-samdevol) wrote :

I've been experiencing this in Lucid.
gmusicbrowser uses libgtk2-trayicon-perl and any icon I use for the tray shows it's transparent area as solid white.

Quentin Sculo (squentin) wrote :

It's a slightly different bug with the same symptom, though this one seems to be theme-dependent.
It has been reported here : http://bugs.launchpad.net/gmb-np/+bug/403135

libgtk2-trayicon-perl is more or less deprecated, replaced Gtk2::StatusIcon.
But it has a few features that are missing in Gtk2::StatusIcon, so I, at least, will probably keep using it.

About this bug in gmusicbrowser, see http://forum.gmusicbrowser.org/index.php?topic=109.0
I found a fix, but it breaks the transparency in non-gnome panels :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers