Activity log for bug #872022

Date Who What changed Old value New value Message
2011-10-10 21:26:03 Renegade22 bug added bug
2011-10-12 21:56:37 Launchpad Janitor eog (Ubuntu): status New Confirmed
2011-10-12 21:57:26 Neil Woolford bug added subscriber Neil Woolford
2011-10-15 07:27:12 mabawsa bug added subscriber mabawsa
2011-10-17 10:31:34 Sebastien Bacher eog (Ubuntu): importance Undecided Low
2011-10-17 10:31:34 Sebastien Bacher eog (Ubuntu): status Confirmed Incomplete
2011-10-18 01:18:10 Neil Woolford attachment added gdb-eog.txt https://bugs.launchpad.net/ubuntu/+source/eog/+bug/872022/+attachment/2556064/+files/gdb-eog.txt
2012-02-17 04:18:03 Launchpad Janitor eog (Ubuntu): status Incomplete Expired
2012-05-24 13:00:23 mannheim eog (Ubuntu): status Expired New
2012-05-24 13:08:02 Launchpad Janitor eog (Ubuntu): status New Confirmed
2012-05-24 13:21:20 mannheim attachment added backtrace https://bugs.launchpad.net/ubuntu/+source/eog/+bug/872022/+attachment/3160989/+files/gdb-eog.txt
2012-05-24 13:31:02 mannheim bug added subscriber mannheim
2012-05-25 13:49:04 Sebastien Bacher affects eog (Ubuntu) libgrip (Ubuntu)
2012-05-25 13:49:04 Sebastien Bacher libgrip (Ubuntu): importance Low High
2012-05-25 13:49:22 Sebastien Bacher bug task added libgrip
2012-05-25 14:32:47 Stephen M. Webb libgrip: status New Confirmed
2012-05-25 14:32:56 Stephen M. Webb libgrip: importance Undecided High
2012-05-29 20:37:20 Stephen M. Webb libgrip: status Confirmed In Progress
2012-05-29 20:37:22 Stephen M. Webb libgrip: assignee Stephen M. Webb (bregma)
2012-05-29 20:49:17 Launchpad Janitor branch linked lp:~bregma/libgrip/lp-872022
2012-05-30 15:43:36 Launchpad Janitor branch linked lp:libgrip
2012-05-30 16:08:17 Launchpad Janitor branch linked lp:libgrip/quantal
2012-05-30 17:50:38 Launchpad Janitor libgrip (Ubuntu): status Confirmed Fix Released
2012-05-30 18:01:42 Stephen M. Webb libgrip: status In Progress Fix Committed
2012-05-30 18:11:59 Stephen M. Webb nominated for series Ubuntu Precise
2012-05-30 18:11:59 Stephen M. Webb bug task added libgrip (Ubuntu Precise)
2012-05-30 18:15:20 Stephen M. Webb libgrip (Ubuntu Precise): status New In Progress
2012-05-30 18:15:22 Stephen M. Webb libgrip (Ubuntu Precise): assignee Stephen M. Webb (bregma)
2012-05-30 18:15:32 Stephen M. Webb libgrip: assignee Stephen M. Webb (bregma)
2012-05-30 18:16:12 Stephen M. Webb libgrip (Ubuntu Precise): importance Undecided High
2012-05-30 18:45:41 Launchpad Janitor branch linked lp:ubuntu/libgrip
2012-05-31 14:34:20 Launchpad Janitor branch linked lp:libgrip/precise
2012-05-31 14:55:43 Stephen M. Webb description whenever I try to start eog it opens a window for as long as a blink of an eye and crashes immediately with this error message: ---------------------- ceylon@ceylon-desktop:~$ eog (eog:29621): GRIP-CRITICAL **: register_internal: assertion `GRIP_IS_GESTURE_MANAGER (manager)' failed Segmentation fault (core dumped) ceylon@ceylon-desktop:~$ ---------------------- only the count of GRIP-CRITICAL lines variate. ProblemType: Bug DistroRelease: Ubuntu 11.10 Package: eog 3.2.0-0ubuntu1 ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4 Uname: Linux 3.0.0-12-generic x86_64 ApportVersion: 1.23-0ubuntu2 Architecture: amd64 Date: Mon Oct 10 23:18:32 2011 EcryptfsInUse: Yes InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110921.2) ProcEnviron: LANGUAGE=en PATH=(custom, no user) LANG=en_US.UTF-8 SHELL=/bin/bash SourcePackage: eog UpgradeStatus: Upgraded to oneiric on 2011-10-04 (5 days ago) whenever I try to start eog it opens a window for as long as a blink of an eye and crashes immediately with this error message: ---------------------- ceylon@ceylon-desktop:~$ eog (eog:29621): GRIP-CRITICAL **: register_internal: assertion `GRIP_IS_GESTURE_MANAGER (manager)' failed Segmentation fault (core dumped) [Impact] The commonly-used application "eog" fails to start for some users because it experiences a segmentation fault in the "libgrip" library. The segmentation fault was caused by the libgrip library attempting to process window connections more than once, and the associated upload removes the extra processing calls. [Test Case] The situation can be forced by manually setting the image-gallery-resizable gnome setting to true and running the eog application. me@mypc:~$ gsettings set org.gnome.eog.ui "image-gallery-resizable" true me@mypc:~$ eog Without the patch, this will result in a segmentation fault. With the patch, no segmentation fault obtains. [Regression Potential] Because the change removes a number of callbacks associated with window creation, it is possible that window processing that used to normally take place will no longer happen. The regression in this case is that where touch screen gestures previously worked (rotations, pinch-to-zoom) with applications such as eog, they will not longer have any effect. This regression has not appeared in testing.
2012-05-31 14:56:19 Stephen M. Webb libgrip (Ubuntu Precise): assignee Stephen M. Webb (bregma)
2012-05-31 14:56:53 Stephen M. Webb bug added subscriber Ubuntu Stable Release Updates Team
2012-05-31 14:56:59 Stephen M. Webb libgrip (Ubuntu Precise): status In Progress New
2012-06-04 23:11:35 Brian Murray libgrip (Ubuntu Precise): status New Fix Committed
2012-06-04 23:11:39 Brian Murray bug added subscriber SRU Verification
2012-06-04 23:11:41 Brian Murray tags amd64 apport-bug eog oneiric amd64 apport-bug eog oneiric verification-needed
2012-06-09 17:53:09 St├ęphane Graber tags amd64 apport-bug eog oneiric verification-needed amd64 apport-bug eog oneiric verification-done
2012-06-13 13:25:22 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/libgrip
2012-06-13 23:12:41 Launchpad Janitor libgrip (Ubuntu Precise): status Fix Committed Fix Released
2012-08-31 21:30:35 Chase Douglas libgrip: status Fix Committed Fix Released
2012-08-31 22:00:09 Launchpad Janitor branch linked lp:~fginther/libgrip/oneiric-0.3.5-backport