Ubuntu

new libgrip makes eog segfault on start in saucy

Reported by Sebastien Bacher on 2013-06-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libgrip
Critical
Stephen M. Webb
Raring
Critical
Stephen M. Webb
libgrip (Ubuntu)
High
Stephen M. Webb
Raring
High
Stephen M. Webb

Bug Description

[Impact]
libgrip was making eog segfaulting

[Test Case]
1. Install the version from -proposed
2. Start eog and check it's not segfaulting
3. Run evince to ensure there is no change or segfault

[Regression potential]
libgrip is only used by eog and evince. So running them both should cover (the same patch is already working fine in saucy)

Stacktrace:

#0 0xb766e4b4 in ?? () from /usr/lib/i386-linux-gnu/libgdk-3.so.0
#1 0xb76a1c6d in gdk_x11_window_get_xid ()
   from /usr/lib/i386-linux-gnu/libgdk-3.so.0
#2 0xb7bec7b4 in processed_mapped_window_request (req=0x82cbec0)
    at gripgesturemanager.c:726
#3 register_mapped_window (manager=<optimized out>, toplevel=0x81da360)
    at gripgesturemanager.c:862
#4 0xb7becec2 in toplevel_mapped_cb (toplevel=0x81da360, event=0x8389380,
    user_data=0xb50022e0) at gripgesturemanager.c:953
#5 0xb786d506 in ?? () from /usr/lib/i386-linux-gnu/libgtk-3.so.0
#6 0xb71469fe in g_closure_invoke (closure=0x82f21f0,
    return_value=return_value@entry=0xbfffebe0, n_param_values=2,
    param_values=param_values@entry=0xbfffec50,
    invocation_hint=invocation_hint@entry=0xbfffebfc)
    at /build/buildd/glib2.0-2.37.1/./gobject/gclosure.c:777
#7 0xb7159fa9 in signal_emit_unlocked_R (node=node@entry=0x80dd040, detail=0,
    instance=0x81da360, emission_return=emission_return@entry=0xbfffecf0,
    instance_and_params=0xbfffec50)
    at /build/buildd/glib2.0-2.37.1/./gobject/gsignal.c:3582
#8 0xb7161476 in g_signal_emit_valist (instance=instance@entry=0x81da360,
    signal_id=signal_id@entry=43, detail=detail@entry=0,
    var_args=0xbfffeda0 "\274\355\377\277\320e\r\b`\213\035\b",
    var_args@entry=0xbfffed9c "\200\223\070\b\274\355\377\277\320e\r\b`\213\035\b") at /build/buildd/glib2.0-2.37.1/./gobject/gsignal.c:3336
#9 0xb7161f93 in g_signal_emit (instance=0x81da360, signal_id=43, detail=0)
    at /build/buildd/glib2.0-2.37.1/./gobject/gsignal.c:3382
#10 0xb79acafb in ?? () from /usr/lib/i386-linux-gnu/libgtk-3.so.0
#11 0xb786d2e8 in gtk_main_do_event ()
   from /usr/lib/i386-linux-gnu/libgtk-3.so.0
#12 0xb766342c in ?? () from /usr/lib/i386-linux-gnu/libgdk-3.so.0
#13 0xb768f3c2 in ?? () from /usr/lib/i386-linux-gnu/libgdk-3.so.0
#14 0xb707c5ce in g_main_dispatch (context=0x80f93b8, context@entry=0x8119e00)
    at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3058
#15 g_main_context_dispatch (context=context@entry=0x80f93b8)
    at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3634
#16 0xb707c978 in g_main_context_iterate (context=context@entry=0x80f93b8,
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3705
#17 0xb707ca38 in g_main_context_iteration (context=0x80f93b8,
    context@entry=0x0, may_block=may_block@entry=1)
    at /build/buildd/glib2.0-2.37.1/./glib/gmain.c:3766
#18 0xb754d144 in g_application_run (application=0x81f98c0, argc=1,
    argv=0xbffff074) at /build/buildd/glib2.0-2.37.1/./gio/gapplication.c:1624

Related branches

lp:~bregma/libgrip/lp-1188693
Merged into lp:libgrip at revision 83
Brandon Schaefer: Approve on 2013-06-07
PS Jenkins bot: Approve (continuous-integration) on 2013-06-07
lp:~bregma/libgrip/raring-lp-1188693
Merged into lp:libgrip/raring at revision 78
PS Jenkins bot: Approve (continuous-integration) on 2013-06-27
Marco Trevisan (Treviño): Approve on 2013-06-27
Changed in libgrip (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-06-07
Changed in libgrip:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Stephen M. Webb (bregma)
Changed in libgrip (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libgrip at revision 83, scheduled for release in libgrip, milestone 0.3.7

Changed in libgrip:
status: Triaged → Fix Committed
Stephen M. Webb (bregma) on 2013-06-07
Changed in libgrip:
milestone: none → 0.3.7
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgrip - 0.3.6daily13.06.10-0ubuntu1

---------------
libgrip (0.3.6daily13.06.10-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * Retrieved window_id from correct widget (lp: #1188693). (LP:
    #1188693)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 83
 -- Ubuntu daily release <email address hidden> Mon, 10 Jun 2013 02:03:01 +0000

Changed in libgrip (Ubuntu):
status: Confirmed → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libgrip/raring at revision None, scheduled for release in libgrip, milestone raring-sru-0

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libgrip (Ubuntu Raring):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-07-10
Changed in libgrip:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2013-07-11
description: updated

The test case should start with replicating the problem. After all, if the
tester can't replicate the segfault, the lack of a segfault with the updated
package doesn't mean much.

Didier Roche (didrocks) wrote :

@Scott: this is untrue, because the current version in distro doesn't segfault, the version which was in proposed ((0.3.6daily13.06.19~13.04-0ubuntu1) and now removed from it was making eog segfaulting.

As you can see the daily release in UNAPPROVED used -V automatically to cover the 2 uploads:
libgrip (0.3.6+13.04.20130711-0ubuntu1) raring; urgency=low

  [ Stephen M. Webb ]
  * Uses the correct ID for the top-level window (lp: #1188693). (LP:
    #1188693)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 78

libgrip (0.3.6daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ Stephen M. Webb ]
  * Moved to GEISv2 to fix an unfortunate lack of events (lp: #1168370).
    (LP: #1168370)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 76

Stephen M. Webb (bregma) on 2013-09-07
Changed in libgrip (Ubuntu Raring):
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High

Hello Sebastien, or anyone else affected,

Accepted libgrip into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libgrip/0.3.6+13.04.20130711-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libgrip (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for raring for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers