libgrip (dependency name change)

Bug #1037856 reported by Francis Ginther on 2012-08-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgrip (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Medium
Francis Ginther

Bug Description

[Impact]
Libgrip has been repackaged to update dependencies on Open Input Framework packages (libgeis) which have been renamed. This package updates to the latest upstream release which contains a bug fix and a removal of references to the earlier project names which are no longer allowed.

[Test Cases]
This is a change to the dependency on libgeis. The existing make targets are used to ensure a successful build.

[Regression Potential]
Minor, the only change is to use a newer libgeis which itself contains bug fixes.

Changed in libgrip (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Francis Ginther (fginther)
Changed in libgrip (Ubuntu):
status: New → Fix Released
description: updated
summary: - [Needs-Packaging] libgrip (dependency name change)
+ libgrip (dependency name change)
description: updated

Hello Francis, or anyone else affected,

Accepted libgrip into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libgrip/0.3.5-0ubuntu1~12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libgrip (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Francis, or anyone else affected,

Accepted libgrip into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libgrip/0.3.2.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libgrip (Ubuntu Oneiric):
status: New → Fix Committed
Francis Ginther (fginther) wrote :

Verified that precise and oneiric packages can be built from source inside a pbuilder chroot.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgrip - 0.3.5-0ubuntu1~12.04.1

---------------
libgrip (0.3.5-0ubuntu1~12.04.1) precise-proposed; urgency=low

  * Backport geis dependency rename for Ubuntu 12.04 (LP: #1037856)

libgrip (0.3.5-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Update dependency on libgeis due to project rename
    - Remove lp872022-disconnect-non-toplevel-signal.patch, merged upstream
  * Update debian/control for upstream gesture project rename
 -- Chase Douglas <email address hidden> Thu, 30 Aug 2012 12:12:45 -0700

Changed in libgrip (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgrip - 0.3.2.1-0ubuntu1

---------------
libgrip (0.3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream microrelease, bug fixes only
    - Update dependency on libgeis due to gesture framework rename
      (LP: #1037856)
  * Updated debian/watch file for project rename
 -- Francis Ginther <email address hidden> Wed, 05 Sep 2012 11:25:17 -0500

Changed in libgrip (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers