"Could not claim the IO device": Canon IXUS 65, Edgy

Bug #64146 reported by Mary Gardiner
26
Affects Status Importance Assigned to Milestone
libgphoto2 (Ubuntu)
Incomplete
Medium
Martin Pitt

Bug Description

When I attach my Canon IXUS 65 to my computer via USB, Import Photos reports "Could not claim the IO device".

Importing photos from this camera worked on Dapper.

$ lsusb
Bus 004 Device 003: ID 04a9:30fe Canon, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Tags: edgy-upgrade
Revision history for this message
Gerhard Rauniak (gerhard-rauniak) wrote :

I have the same Problem with Edgy and my IXUS 65:

tail -f /var/log/messages:

Oct 7 19:31:30 localhost kernel: [17182141.336000] usb 4-4: new high speed USB device using ehci_hcd and address 6
Oct 7 19:31:30 localhost kernel: [17182141.488000] usb 4-4: configuration #1 chosen from 1 choice

lsusb:
Bus 004 Device 006: ID 04a9:30fe Canon, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 1241:1111 Belkin Mouse
Bus 002 Device 001: ID 0000:0000

if I start gnome-volume-manager-gthumb %h I get:
8020: arguments to dbus_message_new_method_call() were incorrect, assertion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 797.
This is normally a bug in some application using the D-Bus library.
libhal.c 995 : Couldn't allocate D-BUS message
error: libhal_device_get_property_type: (null): (null)

and when the window to import the fotos pops up I get this error message:

An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Operation not permitted). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device

Revision history for this message
Mary Gardiner (puzzlement) wrote :

Moving to confirmed.

For others, one fix is to add a line that reads
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="30fe", MODE="0660", GROUP="plugdev"
to /etc/udev/rules.d/45-libgphoto2.rules (and restart udev) -- I am not sure whether that is the correct fix or not.

Changed in libgphoto2:
status: Unconfirmed → Confirmed
Revision history for this message
Gerhard Rauniak (gerhard-rauniak) wrote :

That fixed my problem with the Ixus 65.

I´m really impressed about your "response time". Only 6h to solve my problem. That´s great. Thank you very much :-) :-)

Martin Pitt (pitti)
Changed in libgphoto2:
assignee: nobody → pitti
importance: Undecided → Medium
status: Confirmed → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

 libgphoto2 (2.2.1-2ubuntu4) edgy; urgency=low
 .
   * camlibs/ptp2/library.c: Add Canon IXUS 65. Closes: LP#64146

Changed in libgphoto2:
status: In Progress → Fix Released
Revision history for this message
Brian Elliott Finley (finley) wrote :

This also fixed the issue with my Casio EX-S600. It's USB id is:

  ID 07cf:1043 Casio Computer Co., Ltd

So, by adding this line:
  SYSFS{idVendor}=="07cf", SYSFS{idProduct}=="1043", MODE="0660", GROUP="plugdev"

to my "/etc/udev/rules.d/45-libgphoto2.rules" file, and doing an "/etc/init.d/udev restart", camera auto-discovery, and photo/video removal capability started working again. :-)

Revision history for this message
justplayin (paddyschwartz) wrote :

I get the same messages as gerhard rauniak in comment 1 under edgy and with the camera "Ricoh Caplio G4 Wide". The auto-import under Dapper worked fine.

Adding the new line to "/etc/udev/rules.d/45-libgphoto2.rules" as described above didn't work for me. I saw that an entry with the correct values for idVendor and idProduct already existed in "/etc/udev/rules.d/45-libgphoto2.rules".

lsusb gives me:

Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 05ca:2208 Ricoh Co., Ltd
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 003: ID 046d:c041 Logitech, Inc.
Bus 002 Device 002: ID 045e:00db Microsoft Corp.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

With tail -f /var/log/messages I get:
Oct 30 09:22:10 localhost kernel: [17179663.984000] usb 3-2: new full speed USB device using uhci_hcd and address 2
Oct 30 09:22:11 localhost kernel: [17179664.672000] usb 3-2: configuration #1 chosen from 2 choices

By typing "id" in the console I get:
patrick@pat:~/Downloads$ id
uid=1000(patrick) gid=1000(patrick) Gruppen=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),106(lpadmin),110(scanner),112(admin),1000(patrick

So I seem to be member of the plugdev group.

When trying to list the photos on the camera with "gphoto2 -L" I get:

patrick@pat:~$ gphoto2 -L

*** Fehler ***
PTP-Ein/Ausgabefehler

*** Fehler ***
Ein Fehler trat in der IO-Bibliothek auf (»Unspezifizierter Fehler«): Konnte den Kerneltreiber des Gerätes nicht abfragen.
*** Fehler (-1: »Unspezifizierter Fehler«) ***

Für Debug-Meldungen verwenden Sie bitte die Option »--debug«.
Diese Meldungen können Ihnen helfen, eine Lösung für Ihr Problem zu
finden. Wenn Sie jedoch Fehler- oder Debug-Meldungen an die
Mailingliste <email address hidden> schicken wollen,
so starten sie gphoto2 bitte wie folgt:

    env LANG=C gphoto2 --debug -L

Please make sure there is sufficient quoting around the arguments.

Following the advice in the output of gphoto2 I did a debug with

env LANG=C gphoto2 --debug -L

and attached the output in a file to this comment.

I'm trying to compile libgphoto2 from the svn to see if this changes anything.

Revision history for this message
justplayin (paddyschwartz) wrote :

I compiled libgphoto2 but wasn't smart enough to get gthumb compiled with photo-import enabled because it didn't recognise libgphoto2 I had compiled from svn and installed with checkinstall.

I reinstalled libgphoto2 and gthumb from the official repos and found that in digikam and gtkam the photo-import worked right away. So I'll be using these programs for the import of photos.

I don't understand anything about libgphoto2. So I might be on the wrong track here. But when I plug the camera in and the command "gnome-volume-manager-gthumb %h" gets executed gthumb looks in the directory /usr/lib/libgphoto2/2.2.1 for a camera driver. In the directory I can see two drivers for my Ricoh camera:

ricoh.so
ricoh_g3.so

When I run the program "/usr/lib/libgphoto2/print-camera-list human-readable" it says that the driver for the "Caplio G4" is "ricoh_g3.so" listed. Strange that gthumb doesn't find it or can't use it.

Revision history for this message
Marcin Niechcial (bastard79) wrote :

i have a similar problem with my Canon A610
in dapper autodetect - autorun gnome-volume-manager-gtumb works fine, but after upgrade to edgy it stop auto working.

after plug my camera to usb nothing happend :( but when i'm typing manualy in conosole gnome-volume-manager-gthumb, then i can import images as well as in dapper.

dmesg | grep usb
#on
[17181164.216000] usb 1-1: new full speed USB device using ohci_hcd and address 4
[17181164.444000] usb 1-1: configuration #1 chosen from 1 choice
#off
[17181207.508000] usb 1-1: USB disconnect, address 4

lsmod | grep usb
usbatm 20864 2 speedtch
usbcore 134912 4 speedtch,usbatm,ohci_hcd

please help, i'm working at this about 2 weeks :(

Revision history for this message
towsonu2003 (towsonu2003) wrote :

> i have a similar problem with my Canon A610

you might wanna file a new bug report for that

Revision history for this message
dailyglen (dailyglen) wrote :

I have the exact same problem for a Fuji Finepix F30, to fix I did:

1) $ lsusb | grep Fuji
Bus 002 Device 006: ID 04cb:019b Fuji Photo Film Co., Ltd

2) Added to the file: /etc/udev/rules.d/45-libgphoto2.rules
SYSFS{idVendor}=="04cb", SYSFS{idProduct}=="019b", MODE="0660", GROUP="plugdev"

3) Turned off camera

4) Restart udev: /etc/init.d/udev restart

5) Turned on camera, and voila

Do you want us to open a separate bug report for each incident or should we change the title of this one to be more generic?

Revision history for this message
towsonu2003 (towsonu2003) wrote :

> Do you want us to open a separate bug report for each incident or should we change the
> title of this one to be more generic?

I would think it is easier to keep track of these via new bug reports. but of course, it's up to Martin Pitt.

Changed in libgphoto2:
status: Fix Released → Needs Info
Revision history for this message
Jason Green (salliesdad) wrote :

Had the same issue with a Kodak EasyShare C643. The fix explained by dailyglen worked for me.

Revision history for this message
Marcin Niechcial (bastard79) wrote :

thanks for reply, but it still dont work

lsusb
Bus 002 Device 002: ID 04a9:30fd Canon, Inc.
Bus 002 Device 001: ID 0000:0000

added
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="30fd", MODE="0660", GROUP="plugdev"

;(

i'm tested my camera at company computers on clean edgy install & dist-upgarded from dapper and there is everithings OK with no problem with my camera :( only in my home PC it stops work autorun.

maybe some packages are missing ??
a have no popup when camera is found in system, then i can ignore this or import images, if import then run gnome-volume-manager-gthumb
How can i run this popup manually ?

Revision history for this message
Marcin Niechcial (bastard79) wrote :

PS> if you want new bug report , please open, i don't know how, dont' want duplicate or trashing.
sorry for my english, i'm still learning ;)

Revision history for this message
Ryan Lovett (ryan-spacecoaster) wrote :

I had to the same thing with my Canon A630.

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="313a", MODE="0660", GROUP="plugdev"

Wouldn't it be easier to just glob all the idProducts?

Revision history for this message
Mika Wahlroos (mpw) wrote :

I experienced the same problem with a Nikon CoolPix L2. Setting the permissions in the udev configuration solved it. The id of the devices is as follows:

ID 04b0:0148 Nikon Corp.

The camera worked fine on Dapper. I guess there's a particular reason why the default permissions were changed (or so I assume before further research) but it seems to cause some problems. This shouldn't really happen since people who aren't very savvy at searching for solutions to such issues are left in the cold.

Revision history for this message
Sirius (vorstar) wrote :

I've just had the same problem with my Nikon P4 in PTP mode, and the same fix worked out.

It looks like this bug is pretty common, so I advice changing the bug title to something like: "My USB camera doesn't work, 'Could not claim the IO device'", and getting everyone using Edgy to know about it.

Anyway, thanks for the hint.

Maybe adding more device definitions to this udev rules per default would be a good idea. Merging Dapper and Edgy files maybe, as it worked just fine back in Dapper days.

Thanks.

Revision history for this message
ormus55 (ormus55) wrote :

hi all,
just tried my canon a520 and got the same problem. ubuntu 5.04 doesnt see the usb device.

lsusb code.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 04a9:30c1 Canon, Inc.
Bus 001 Device 001: ID 0000:0000

what do i do now?

help please.

Revision history for this message
martin ekroth (m-ekroth) wrote : Re: "Could not claim the IO device":various digital cameras

i have a clue ,i got a new s6000fd fuji camera,i took pictures on 11/16/2006 and ubuntu 6.10 works fine i download on a folder ,after this date i apply all updates and now .showns this same ~could not claim the usb device~ i check with kubuntu 6.10 same error .

Revision history for this message
David Schaller (bach-leipzig) wrote :

I had exactly the same problem with a Kodak EasyShare Z760. The fix from dailyglen worked perfectly.

Revision history for this message
Abraham Elias (abe-driven2empower) wrote :

The Canon SD40..

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3137", MODE="0660", GROUP="plugdev"

Revision history for this message
Brian Ealdwine (eode) wrote : "Could not claim the IO device": Kodak EasyShare C433

Please also add the Kodak EasyShare C433 to udev's 45-libgphoto2.rules:

SYSFS{idVendor}=="040a", SYSFS{idProduct}=="05aa", MODE="0660", GROUP="plugdev"

..do these get backported into edgy and dapper?

Revision history for this message
Antoine Mairesse (antoine-mairesse) wrote : "Could not claim the IO device": Kodak V705

Here Santa has brought the Kodak V705 :

SYSFS{idVendor}=="040a", SYSFS{idProduct}=="05ab", MODE="0660", GROUP="plugdev"

Revision history for this message
Jonathan Caum (bsalt1313) wrote :

Hey, just to let you guys know, if you happen to own an HP Photosmart E327, add this line to your /etc/udev/rules.d/45-libgphoto2.rules :

SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="8b02", MODE="0660", GROUP="plugdev"

And to anyone else that is having this problem - simply type "lsusb" in the terminal after your camera is plugged in and turned on, search for the line from the lsusb output that identifies your camera, and add a new line to the 45-libgphoto2.rules file and replace the idVendor 4 set of characters with the first set of 4 from the lsusb line, and then do the same for idProduct for the last 4 (after the colon).

Revision history for this message
Vincent Tsugranes (gooey2-deactivatedaccount) wrote :

Casio EX-Z700:
SYSFS{idVendor}=="07cf", SYSFS{idProduct}=="104c", MODE="0660", GROUP="plugdev"

Revision history for this message
Raul Wegmann (r-launchpad) wrote :

Fujifilm FinePix F31fd:
SYSFS{idVendor}=="04cb", SYSFS{idProduct}=="01c1", MODE="0660", GROUP="plugdev"

Revision history for this message
ElLute (andog) wrote :

Fujifilm FinePix S6500fd:
SYSFS{idVendor}=="04cb", SYSFS{idProduct}=="01bf", MODE="0660", GROUP="plugdev"

Revision history for this message
chip (subscribe-unixstyle) wrote :

Canon IXUS 600:

$ lsusb
Bus 004 Device 004: ID 04a9:3115 Canon, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
$

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3115", MODE="0660", GROUP="plugdev"

Revision history for this message
chip (subscribe-unixstyle) wrote :

I am so sorry, please discard the previous post. It's about Canon IXUS 900 Ti

Canon IXUS 900 Ti:

$ lsusb
Bus 004 Device 004: ID 04a9:3115 Canon, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
$

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3115", MODE="0660", GROUP="plugdev"

Revision history for this message
Kalyan (kalyan-kumar-gmail) wrote : Nikon Coolpix S6

Thanks.
This solution worked for Nikon Coolpix S6 on Ubuntu 6.10 too.

writing explicty so that someone else could benifit from the search.

Thanks Again,
Kalyan

Revision history for this message
Goren (g0ren) wrote :

Canon PowerShot A450:
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3155", MODE="0660", GROUP="plugdev"

Wasn't in the file by default, so when i tried to connect it i got an error. After i inserted the above line it works ok.

Revision history for this message
Evgeny Kuznetsov (nekr0z) wrote :

Have got a Canon A80 with the same problem. ID is 04a9:309a, and it IS in that file, but the error still appears.

Revision history for this message
Robert Woestman (robertwoes) wrote :

same issue.
lsusb
Bus 003 Device 008: ID 04a9:3076 Canon, Inc. PowerShot A300

did
gksu gedit /etc/udev/rules.d/45-libgphoto2.rules

added line
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3076", MODE="0660", GROUP="plugdev"

DID NOT WORK

I am using edgy.

Revision history for this message
Robert Woestman (robertwoes) wrote :
Revision history for this message
Evgeny Kuznetsov (nekr0z) wrote :

Check bug #91250 if adding a line doesn't work.

Revision history for this message
Fox3 (pmudmap5) wrote :

My Cannon S2 IS is in /etc/udev/rules.d/45-libgphoto2.rules

Still "Could not claim the IO device":

Tried changing mode to "0666" still can't get at it.

Edgy.

It was working fine until the update yesterday :-(. Am able to get at it from the Cannon tools in wincrap...

Revision history for this message
Tobias (tobias-frech) wrote :

Hi!
Thanks, nekr0z, for your reference to bug #91250.
After the last update my Finepix F30 stopped working in gthumb, thanks to the change described there it works again.
Tobias

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

Adding this comment to thanks nekr0z too and to add an entry for google... the solution in bug #91250 works for my Kodak DX4330 too.

Revision history for this message
DaveMcCollum (dave-mccollum) wrote :

Canon S400 Elph gets same error. Manufacturer "04a9" and Product "3075" are listed multiple times in 45-libgphoto2.rules.......what gives?????

Revision history for this message
Mikko Saarinen (mikk0) wrote :

My Canon PowerShot A75 worked fine until I started toying with usb bluetooth dongle - don't know if that is the reason, but now all I get is this message (An error occurred in the io-library...) :(

mikko@mini:~$ lsusb
Bus 001 Device 008: ID 04a9:30b5 Canon, Inc. PowerShot A75

mikko@mini:~$ cat /etc/udev/rules.d/45-libgphoto2.rules | grep 04a9 | grep 30b5
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="30b5", MODE="0660", GROUP="plugdev"

So the line already exists in udev rules.
I can get the photos from the camera if I start the program with command:
mikko@mini:~$ sudo gnome-volume-manager-gthumb

Why does this require sudo? My id tells that I'm in the group plugdev:
mikko@mini:~$ id
uid=1000(mikko) gid=1000(mikko) ryhmät=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),30(dip),46(plugdev),100(users),111(scanner),114(admin),1000(mikko)

The good thing is, that at least I can get the photos by using sudo, but I have no clue why this doesn't work as a regular user anymore :(

Revision history for this message
Brian Ealdwine (eode) wrote : Re: [Bug 64146] Re: "Could not claim the IO device": Canon IXUS 65, Edgy

On Saturday 07 April 2007 04:15:41 Mikko Saarinen wrote:
> *** This bug is a duplicate of bug 67532 ***
> https://bugs.launchpad.net/bugs/67532
>
> My Canon PowerShot A75 worked fine until I started toying with usb
> bluetooth dongle - don't know if that is the reason, but now all I get
> is this message (An error occurred in the io-library...) :(
>
> mikko@mini:~$ lsusb
> Bus 001 Device 008: ID 04a9:30b5 Canon, Inc. PowerShot A75
>
> mikko@mini:~$ cat /etc/udev/rules.d/45-libgphoto2.rules | grep 04a9 | grep
> 30b5 SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="30b5", MODE="0660",
> GROUP="plugdev"
>
> So the line already exists in udev rules.
> I can get the photos from the camera if I start the program with command:
> mikko@mini:~$ sudo gnome-volume-manager-gthumb
>
> Why does this require sudo? My id tells that I'm in the group plugdev:
> mikko@mini:~$ id
> uid=1000(mikko) gid=1000(mikko)
> ryhmät=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),3
>0(dip),46(plugdev),100(users),111(scanner),114(admin),1000(mikko)
>
> The good thing is, that at least I can get the photos by using sudo, but
> I have no clue why this doesn't work as a regular user anymore :(

This is just a guess, and is probably not the issue. But perhaps you ran it
as root at one point, and it created files in your homedir (or a subdirectory
thereof) that belong to root (and you're now not able to change them)..

If you no files in your homedir that should belong to any other user than
yourself, do:

sudo chown -R :plugdev <homedir>

..replacing <homedir> with the path to your home directory, such as:

sudo chown -R :plugdev /home/mikko

The bug you are experiencing, though, is a separate bug from the one this
bugreport is for, and any further correspondence on it should go in a
separate bugreport.

Revision history for this message
DaveMcCollum (dave-mccollum) wrote :

My Notes on How I Was Able to Make My Camera Connect on Edgy

Getting Canon S400 Elph to Connect

FROM........
https://launchpad.net/ubuntu/+source/libgphoto2/+bug/67532..............

- Following aldegaz's instructions above, and changing the 3rd line in /etc/udev/rules.d/45-libgphoto2.rules to:

SUBSYSTEM!="usb_device", GOTO="libgphoto2_rules_end"

[my comment]
--- this appears to work so far a/o 3/27/2007 17:06
 f-spot works, and that's all I really cared about anyway.

NOTES:

the line (3rd line) that got replaced is this.....

 BUS!="usb*", GOTO="libgphoto2_rules_end"

It seems to be important that this information be on the 3rd line of file. I tried other stuff, adding lines etc. and left other lines commented out that forced this line away from line 3. That caused the restart of udev to fail!!! I've never seen an application be dependent on the actual line number of something, but it really, really seems to be important to gphoto2 or udev in general.....very strange but must be remembered!!!! KEEP THIS IN MIND!!!

Also, BE SURE TO BACK THIS FILE UP BEFORE YOU MESS WITH IT!!!!!!!!!!! I nearly got in trouble, because my changes and commented-out lines caused udev to fail. Fortunately, I had another box running Edgy to fall back on and see how it's stuff looked. LESSON LEARNED!!!....don't screw with stuff w/o backing it up first!!! Enuf said.

Revision history for this message
DaveB (david-j-barker) wrote : Canon Powershot G7

I had the same problem with a Canon Powershot G7
This was fixed in the same was as the previous posts:
lsusb ouput:
Bus 005 Device 004: ID 04a9:3125 Canon, Inc.

Added this line to /etc/udev/rules.d/45-libgphoto2.rules
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3125", MODE="0660", GROUP="plugdev"

and restarted udev - this has been documented well in the comments above.

Now everything works peachy.

Revision history for this message
Scott (sroberson) wrote : Canon EOS Rebel XTi

lsusb:
...
Bus 001 Device 008: ID 04a9:3110 Canon, Inc.
...

Added this line to /etc/udev/rules.d/45-libgphoto2.rules
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3110", MODE="0660", GROUP="plugdev"

Restarted udev. Voila!

Revision history for this message
Goren (g0ren) wrote :

The fixes are cool and they work ok, but i wander if i have to re-edit /etc/udev/rules.d/45-libgphoto2.rules evey time new udev appears or some other updates? I do it for the third time today. Maybe i'm a lamer and all that stuff, but is it really no way to fix it in repositories or somethng?

Revision history for this message
Roger Keays (roger-ilikespam) wrote :

I get the same error message reported in the first post to this bug when starting gnome-volume-manager-gthumb on feisty:

process 5227: arguments to dbus_message_new_method_call() were incorrect, assertion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 1074.
This is normally a bug in some application using the D-Bus library.
libhal.c 1058 : Couldn't allocate D-BUS message
error: libhal_device_get_property_type: (null): (null)

The message reported by the dialog is different though. It says "PTP Protocol error, data expected"

I tried adding the product id to libphoto.rules, but this doesn't fix the problem for me.

The camera is a Casio EX-Z750 (07cf:103b) and worked fine with Dapper. It stopped working some time during an Edgy update, and is still broken in Feisty.

Revision history for this message
Roger Keays (roger-ilikespam) wrote :

Please disregard the last comment. It seems my SD card was corrupted.

Revision history for this message
Tom Sayles (tsayles) wrote :

I was having the same problem with my Cannon PowerShot A540. What DaveMcCollum said on 2007-04-07, changing the BUS!="usb*"... line to SUBSYSTEM!="usb_device"... seems to have fixed it.

Thanks Dave!

Revision history for this message
nobtiba (nghevd) wrote :

Hi Bros!
I am working with Aiptek mini Pencam 1.3, Vendor ID 04fc; Product ID: 504a. Then i did the fix for both bug 64146 and bug 91250
add a line: SYSFS{idVendor}=="04fc", SYSFS{idProduct}=="504a", MODE="0660", GROUP="plugdev"
and
changing the BUS!="usb*"... line to SUBSYSTEM!="usb_device"...

But nothing can help! I still got the following error when trying to access the camera to get info or download picture (by gphoto 2):

 gphoto2 --camera "Aiptek Pencam" --port "usb:001,016" --list-files

*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <email address hidden>, please run
gphoto2 as follows:

    env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt --camera "Aiptek Pencam" --port "usb:001,016" --list-files

Please make sure there is sufficient quoting around the arguments.

======================================

So could you please give me some help ! I spend too much time stuck in this problem :((

Revision history for this message
nobtiba (nghevd) wrote : RE: [Bug 64146] Re: "Could not claim the IO device": Canon IXUS 65, Edgy

-----Original Message-----
From: <email address hidden> on behalf of nobtiba
Sent: Thu 12/6/2007 3:49 PM
To: Vuong Dao Nghe
Subject: [Bug 64146] Re: "Could not claim the IO device": Canon IXUS 65, Edgy

*** This bug is a duplicate of bug 67532 ***
    https://bugs.launchpad.net/bugs/67532

Hi Bros!
I am working with Aiptek mini Pencam 1.3, Vendor ID 04fc; Product ID: 504a. Then i did the fix for both bug 64146 and bug 91250
add a line: SYSFS{idVendor}=="04fc", SYSFS{idProduct}=="504a", MODE="0660", GROUP="plugdev"
and
changing the BUS!="usb*"... line to SUBSYSTEM!="usb_device"...

But nothing can help! I still got the following error when trying to
access the camera to get info or download picture (by gphoto 2):

 gphoto2 --camera "Aiptek Pencam" --port "usb:001,016" --list-files

*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <email address hidden>, please run
gphoto2 as follows:

    env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt --camera
"Aiptek Pencam" --port "usb:001,016" --list-files

Please make sure there is sufficient quoting around the arguments.

======================================

So could you please give me some help ! I spend too much time stuck in
this problem :((

--
"Could not claim the IO device": Canon IXUS 65, Edgy
https://bugs.launchpad.net/bugs/64146
You received this bug notification because you are a direct subscriber
of the bug.

Hi, Thanks for reminding, but it could not fix my problem. I got the same error above ! Please help !!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers