Unable to mount Canon cameras via USB

Bug #339563 reported by Aethralis on 2009-03-08
124
This bug affects 17 people
Affects Status Importance Assigned to Milestone
libgphoto2 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Nick
Nominated for Jaunty by Leonid Selivanov

Bug Description

Binary package hint: gphoto2

I can't mount my digital camera in Jaunty. Worked in Intrepid. The error message I get is: Sorry, could not display all the contents of "Canon, Inc. PowerShot A510 (normal mode) / PowerShot A510 (PTP mode)": Failed to get folder list: -111: Invalid filename.

The other machine with Ubuntu 8.10 has no problems displaying the contents.

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: gphoto2 None [modified: /var/lib/dpkg/info/gphoto2.list]
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gphoto2
Uname: Linux 2.6.28-8-generic i686

Leonid Selivanov (bravebug) wrote :

I am also affects this bug. But I have Canon EOS-350D.
Failed to get folder list: -111: Invalid filename.
But the camera work in ubuntu 8.04 and 8.10 without problems.

Ubuntu 9.04
Linux hog 2.6.28-9-generic #31-Ubuntu SMP Wed Mar 11 15:43:58 UTC 2009 i686 GNU/Linux

Leonid Selivanov (bravebug) wrote :

I followed the instructions from https://wiki.ubuntu.com/DebuggingRemovableDevices

summary: - Camera does not mount
+ Failed to mount cameras Canon

/var/log/messages:
Apr 27 00:52:31 hog kernel: [ 6547.073097] usb 2-1: new high speed USB device using ehci_hcd and address 5
Apr 27 00:52:32 hog kernel: [ 6547.219336] usb 2-1: configuration #1 chosen from 1 choice

affects: gphoto2 (Ubuntu) → ubuntu
Leonid Selivanov (bravebug) wrote :

In summary:
* unable to mount Canon cameras via USB (Jaunty)
* this works well in older versions (8.04, 8.10)
* does not depend on the working environment (KDE, Gnome)
* does not depend on the system architecture (i386, amd64)

Anybody may send additional information?

summary: - Failed to mount cameras Canon
+ Unable to mount Canon cameras via USB (Jaunty)

I've found that my Canon Powershot A510 doesn't work with my desktop PC running Jaunty amd64 but it *does* work with my Acer Aspire One running Ubuntu Netbook Remix Addition (Jaunty).

Aside from the obvious hardware differences:
 * My desktop is running amd64 Ubuntu vs. the netbook remix being 32 bit
 * I did a fresh install of Jaunty on the netbook vs. an upgrade from intrepid on the desktop.
 * Whatever packaging differences there are between regular Ubuntu and UNR?

I hope that helps narrow down where the problem may be.

Constant (constant-julien) wrote :

'Same' here:

/var/log/messages:
May 17 21:41:53 Cienfuegos kernel: [ 239.512046] usb 2-7: new high speed USB device using ehci_hcd and address 6
May 17 21:41:53 Cienfuegos kernel: [ 239.681571] usb 2-7: configuration #1 chosen from 1 choice
shows up in lsusb:
Bus 002 Device 006: ID 04cb:01d5 Fuji Photo Film Co., Ltd FinePix F47 (PTP)

but no pop ups to download the jpgs; "No devices plugged in"

AMD64 3500 9.04 32bit Kubuntu 9.04
Regards, Constant

captwiggum (captwiggum) wrote :

Same deal for me. My Canon camera worked great with gphoto2 and/or auto-mounted under 8.04 & 8.10.
I recently upgraded to 9.04, and it has stopped working. Now it does not auto-mount, and gphoto2 also fails.
I have also followed these instructions to collect debug info and logs:
https://wiki.ubuntu.com/DebuggingRemovableDevices
All the data from my system when plugging in the camera is in this attachment.

captwiggum (captwiggum) wrote :

** SOLUTION **
Doh! The work-around is posted:
http://www.ubuntugeek.com/some-of-known-ubuntu-904jaunty-jackalope-bugs-with-workarounds.html

For me, it didn't auto-mount after this, but it was accessible. I usually copy all my photos off the camera from a command line like this: gphoto2 -P

Leonid Selivanov (bravebug) wrote :

captwiggum, Thanks, whatever solution.

Pm (pmichaud) wrote :

The workaround given by captwiggum doesn't solve the problem for me (bug #367434) -- I'm running on Kubuntu, which doesn't appear to have anything like gvfs-gphoto2-volume-monitor .

Pm

Marcus Meissner (meissner) wrote :

install gphoto2 commandline and the run

gphoto2 -L

please

Cameron Hart (bitshifternz) wrote :

After I failed to copy files through F-Spot I tried the gphoto2 command line. It failed initially because the device was in use. I then unmounted the device in Nautilus and the gphoto2 -L command succeeded.

I've attached the log from when it failed because the device was in use.

I'd also like to see this bug fixed please. You can find my post on ubuntuforums http://ubuntuforums.org/showthread.php?t=1210248

A partial quote from the post:

"When connecting my powershot A520 then Nautilus pops up with the following error message:
------
The folder contents could not be displayed.

Sorry, could not display all the contents of "Canon, Inc. Digital IXUS 50 (normal mode) / IXY Digital 55 (normal mode) / PowerShot A520 (PTP mode) / PowerShot SD400 (normal mode)": Failed to get folder list: -111: Invalid filename
------
GThumb is able to import the photos but as soon as gthumb is started, the mounted camera disappears from nautilus.

In 8.10 I was able to access the camera in Nautilus and this is my preferred way because then I can make directories and store other files on my card."

Anything further we can do to get this fixed? In terms of importance, I'm not able to access my camera as a USB mass storage device. This means that whatever files I've placed on the card are not accessible anymore unless it is an image file or video. I do not have a card reader. Yes I can access the files on a different computer and email it to myself but that can hardly be the idea of how it should work right?

szczym (szczym) on 2009-09-02
affects: ubuntu → libgphoto2 (Ubuntu)
Changed in libgphoto2 (Ubuntu):
status: New → Confirmed

Same problem here with Kubuntu 9.04 w/ KDE 4.3.2. Files generated from https://wiki.ubuntu.com/DebuggingRemovableDevices are attached to this post.

Is there any workaround for Kubuntu, or should this be reported as a new bug ? Since digital cameras are everywhere today, this is quite an annoying bug.

Matt Hegarty (mrhegarty) wrote :

Experienced this bug plugging in a Canon 500D to 10.10 (2.6.35-25-generic, 64 bit)

This fixed it - though had to start Shotwell, then I could access the camera via 'Places' menu

sudo killall gvfs-gphoto2-volume-monitor

Paul Abrahams (abrahams) wrote :

Same problem here. I've plugged in a Canon A10 Powershot. lsusb sees it and so does gphoto -l:
pwa@pwa-K60IJ:~$ gphoto2 -l
Detected a 'Canon:PowerShot A10'.
There are 2 folders in folder '/'.
 - DCIM
 - MISC
There are 2 folders in folder '/DCIM'.
 - 132CANON
 - CANONMSC
There are 0 folders in folder '/DCIM/132CANON'.
There are 0 folders in folder '/DCIM/CANONMSC'.
There are 0 folders in folder '/MISC'.
pwa@pwa-K60IJ:~$ ls /DCIM
ls: cannot access /DCIM: No such file or directory

However, the Device Notifier says "No Devices Available". digikam autodetects the camera but then shows no files when I try to import from it. I can't find the DCIM folder. It's certainly not at the specific location /DCIM.

As an experiment I created a folder /DCIM with universal permissions. Having done that, the message from gphoto2 -l changed:
pwa@pwa-K60IJ:~$ gphoto2 -l
There are 0 folders in folder '/'.
Something is quite wrong here, and apparently the problem has been there for years.

Paul Abrahams (abrahams) wrote :

I forgot to mention that I'm running Kubuntu 11.10.

Luis Alvarado (luisalvarado) wrote :

This is still happening in 12.04 32 Bit with a Canon DS6041. i can connect the camera via USB. It detects the camera with no problems but if I try to access it everything freezes until I kill nautilus.

summary: - Unable to mount Canon cameras via USB (Jaunty)
+ Unable to mount Canon cameras via USB

Same problem here on 12.04 with a Canon EOS 50D. I try to copy a file to the flash drive on the camera and get the following:

There was an error copying the file into gphoto2://[usb:002,017]/.
Error writing file: -108: No such file or directory

captwiggum (captwiggum) wrote :

I've been using gphoto2 and nautilus to access various Canon cameras for years, using each step of Ubuntu over that time.
Its working well for me in 12.04. But my understanding, is that it does not present as a regular flash drive. There is a special driver that makes browsing possible in nautilus, and gphoto2 has this built-in. I've always heard the limitation is that its read-only. I'm not aware that you could ever copy files to the flash card in your camera from any tool in Ubuntu. Although I have no need to do that, so I have not tried. In my install, a simple "gphoto2 -P" does it all for dumping photos from camera to disk. Oh there is one other thing, nautilus will claim the device when you plugin your Canon. Since I prefer gphoto2 I just click the eject icon in nautilus to release the device. Then gphoto2 works fine. I know this will not help everyone, just offering some input.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers