package libgphoto2-2 2.4.0-2ubuntu1 failed to install/upgrade: podproces post-installation script zwrócił kod błędu 139

Bug #145732 reported by janusz on 2007-09-27
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgphoto2 (Ubuntu)
Undecided
Unassigned

Bug Description

while installing libgphoto2-2 it cant be installed coused by error unately
Segmentation fault (core dumped)
dpkg: błąd przetwarzania libgphoto2-2 (--configure):
 podproces post-installation script zwrócił kod błędu 139

unfort

ProblemType: Package
Architecture: i386
Date: Thu Sep 27 20:08:05 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: podproces post-installation script zwrócił kod błędu 139
Package: libgphoto2-2 2.4.0-2ubuntu1
PackageArchitecture: i386
SourcePackage: libgphoto2
Title: package libgphoto2-2 2.4.0-2ubuntu1 failed to install/upgrade: podproces post-installation script zwrócił kod błędu 139
Uname: Linux joanna-laptop 2.6.22-12-386 #1 Sun Sep 23 17:37:35 GMT 2007 i686 GNU/Linux

janusz (jtheom) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Changed in libgphoto2:
status: New → Invalid
Martin Pitt (pitti) wrote :

Pedro, I heavily disagree. This *is* a bug, and you should not prematurely close bug reports without inspecting at least the log. Installing libgphoto2-2 failed with a segfault, which should not happen.

Janus, can you please give the output of

  sudo sh -ex /var/lib/dpkg/info/libgphoto2-2.postinst configure 2.4.0-2ubuntu1

? Thank you!

Changed in libgphoto2:
status: Invalid → Incomplete
sv3t (tassev) wrote :

ligphoto2-2 gives the same problem here. Below is the result of the command Martin Pitt asked for:

+ set -e
+ [ configure = configure ]
+ ldconfig
+ PACKAGE=libgphoto2
+ mkdir -p /usr/share/hal/fdi/preprobe/10osvendor/
+ /usr/lib/libgphoto2/print-camera-list hal-fdi
+ rm -f /usr/share/hal/fdi/information/10freedesktop/10-camera-libgphoto2.fdi
+ rm -f /usr/share/hal/fdi/information/20thirdparty/libgphoto2.fdi
+ rm -f /usr/share/hal/fdi/information/10freedesktop/10-camera-libgphoto2-device.fdi
+ [ -d /etc/udev/ ]
+ which udevinfo
+ udevinfo -V
+ awk {if ($3 >= 98) exit 1}
+ /usr/lib/libgphoto2/print-camera-list udev-rules mode 0660 group plugdev
Segmentation fault (core dumped)

sv3t (tassev) wrote :

I managed to fix the problem. I located and deleted all files of my previous libgphoto and gphoto installation, which for some reason were not deleted after uninstall. After that new install works without a problem.

Thanx for fast response,

To deal with this error I just manually removed all information about
libgphoto2-2 from /var/lib/dpkg/info
Next again
apt-get check
apt-get update
apt-get install libgphoto2-2

everythin works fine.
What was it??

Janusz

Dnia 28-09-2007 o godz. 15:37 Martin Pitt napisał(a):
> Pedro, I heavily disagree. This *is* a bug, and you should not
> prematurely close bug reports without inspecting at least the log.
> Installing libgphoto2-2 failed with a segfault, which should not happen.
>
> Janus, can you please give the output of
>
> sudo sh -ex /var/lib/dpkg/info/libgphoto2-2.postinst configure
> 2.4.0-2ubuntu1
>
> ? Thank you!
>
> ** Changed in: libgphoto2 (Ubuntu)
> Status: Invalid => Incomplete
>
> --
> package libgphoto2-2 2.4.0-2ubuntu1 failed to install/upgrade: podproces
> post-installation script zwrócił kod błędu 139
> https://bugs.launchpad.net/bugs/145732
> You received this bug notification because you are a direct subscriber
> of the bug.

----------------------------------------------------
Medale rozdane! Zobacz jak walczyli najlepsi
w drodze na sam szczyt!
Mistrzowie Speedway Ekstraliga. Kliknij:
http://klik.wp.pl/?adr=http%3A%2F%2Fcorto.www.wp.pl%2Fas%2Fmistrzowiespeedway.html&sid=53

Mike Richman (mike-d-richman) wrote :

I had the same problem upgrading from Feisty to Gutsy with the graphical installer. I can confirm that for me, the following appears to have fixed libgphoto2-2 and all its dependencies:

sudo rm /var/lib/dpkg/info/libgphoto2-2*
sudo apt-get dist-upgrade

-Mike

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in libgphoto2:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers