Hangs after using the 'save a copy' dialog

Bug #59267 reported by Christian Elkjaer on 2006-09-06
12
Affects Status Importance Assigned to Milestone
libgnomeui (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

Version: 0.6.0-0ubuntu1

To reproduce:

Pick an arbitrary pdf file (locally or from some internet website) and choose 'Save a Copy' from the menu. Now, either choose the cancel or the save button and Evince will hang.

I can conclude that it actually gets past the point of saving a copy but then hangs.

Holger Bauer (umarmung-planet) wrote :

I see this too. However, evince doesn't freeze when you save to /tmp or run it with root permissions.

Changed in evince:
status: Unconfirmed → Confirmed
Holger Bauer (umarmung-planet) wrote :

Here is a better backtrace with debug symbols

Sebastien Bacher (seb128) wrote :

Thanks for your bug. As commented on bug #59267 which is a duplicated, that looks like a GTK issue similar to bug #59394

Changed in evince:
assignee: nobody → desktop-bugs
importance: Untriaged → High
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 libgnomeui (2.16.0-0ubuntu2) edgy; urgency=low
 .
   * debian/patches/90_from_cvs_fix_fileselector_lock.patch:
     - patch from CVS, fix apps like evince or rhythmbox locking when using the
       fileselector (Ubuntu: #59267, #59394)

Changed in evince:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers